ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB10 SVN repository not connection

Post new topicReply to topic
IIB10 SVN repository not connection View previous topic :: View next topic
Author Message
jb3
PostPosted: Tue Sep 18, 2018 2:00 am Post subject: IIB10 SVN repository not connection Reply with quote

Apprentice

Joined: 18 Aug 2017
Posts: 26

Hi All,

I am upgrading to IIB 10, and installed the SVN plugin (Core SVNKit Library, JNA Library) and Subeclipse Plugin.

I can now see the SVN perspective, but when i add an existing repository location, the console throws below error:

Quote:
svn: PROPFIND request failed on '/svn/ESB'
svn: SSLv3 SSLContext not available



I also checked under the Windows -> Preferences -> Team -> SVN -> SVN interface . selecting on JavaHL gives below error:

Quote:
Failed to load JavaHL Library


If i select the SVNKit option, there is no error on the preferences dialog box, but i am still unable to add the existing repository location.


Please help.
Thanks
Back to top
View user's profile Send private message
gfrench
PostPosted: Wed Nov 07, 2018 9:08 am Post subject: Reply with quote

Acolyte

Joined: 10 Feb 2002
Posts: 64

Funny I should come across this. Possibly an exact hit, and maybe raised by my absent colleague no longer around. The error I see with IIB Toolkit 10.0.0.7:-

Quote:
svn: No appropriate protocol (protocol is disabled or cipher suites are inappropriate)


and I have no background to what has installed and there is fairly little documentation on how to integrate SVN and IIB Toolkit.

So this was my problem diagnosis, and resolution incase anyone finds this, like me, with no clue:-

I thought this might be an SSL to TLS1.2. How do we configure the SSL encryption between subversion and the SVN server? Is this non configurable and to do with the version of the plugin? If so how can I tell what version of the plugin was installed?

I played around for ages unistalling and reinstalling plugins (Help - About IBM Toolkit -> Installation Details -> Installed Software) before unistalling anything SVN related. I then went to the market place (help -> Eclipse Marketplace), having configured a proxy, and tried to reinstall Subclipse. It suggested some dependency issues so I unistalled some more and then reinstalled.

It installed:-

Subclipse 4.2.4.2018
Subclipse Integration for Mylyn (Optional) 5.2.0.1
Subclipse JavaHL Windows Native DLL's 1.9.7.2018...
Subclipse Revision Graph 4.2.0.1
SVNKit Client Adapter 1.8.12.1

which seems to work with IIB Toolkit 10.0.0.7. Sounds very simple, but google has been tested :0)
Back to top
View user's profile Send private message Send e-mail Visit poster's website
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB10 SVN repository not connection
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.