ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportBIP0960E Project directory does not exist

Post new topicReply to topic
BIP0960E Project directory does not exist View previous topic :: View next topic
Author Message
IIBn00b
PostPosted: Wed Sep 09, 2020 1:11 am Post subject: BIP0960E Project directory does not exist Reply with quote

Newbie

Joined: 19 Nov 2019
Posts: 7

I have seen this being asked multiple times. To my knowledge it did not answer my problem so here it goes:

I have a flow which I want to build on my Jenkins server. This flow has a dependency to a Java project.

The original mqsicreatebar command looks like this:
mqsicreatebar -data `pwd`/iib-workspace -b ${PROJECT_NAME}.bar -a ${PROJECT_NAME} > ./mqsicreatebar.log 2>&1

For other projects this is working fine. The bar file gets created.

As said, my current project has a dependency to a java project. I get a ClassNotFoundException if I do not change anything in the working project.

The java project is called MyJavaProject. I copy this project into the /iib-workspace location and change the msqicreatebar command to this:

mqsicreatebar -data `pwd`/iib-workspace -b ${PROJECT_NAME}.bar -a ${PROJECT_NAME} -p MyJavaProject -o MyJavaProject > ./mqsicreatebar.log
2>&1

Creating the bar file in the toolkit is working.

running above command on the Jenkins server gives me this error in the mqsicreatebar.log:

BIP0960E Incorrect "-a", "-l", "-s", "-p", or "-o" argument supplied to mqsicreatebar.

Project directory "MyJavaProject" does not exist.

I think the location of the project directory is wrong which makes me wonder what the correct location should be.
Or am I missing something else?

(Using IIB 10.0.0.18 )
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportBIP0960E Project directory does not exist
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.