ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportCommon SAP Adapter problems at deployment

Post new topicReply to topic
Common SAP Adapter problems at deployment View previous topic :: View next topic
Author Message
havaguin
PostPosted: Fri Feb 01, 2019 6:47 am Post subject: Common SAP Adapter problems at deployment Reply with quote

Newbie

Joined: 31 Jan 2019
Posts: 2

We're migrating apps from WMB 8 to IIB 10. Several of the applications include a Lib (with the adapter configuration), which in turn reference a common SAP Adapter (Java) Project. One of these apps throws warnings at deployment like so:
Quote:

( LCLCHIB01.default ) The XMLNSC validator signalled that a warning occurred at line '3' while validating a XML schema.
The file being processed was 'SapZdebmasch.xsd' in library 'XXXX_IDOC_LIB'. The library is being deployed as part of application 'XXXX_APP'.
The message from the XMLNSC validator is:
'schema_reference.4: Failed to read schema document 'SapBusinessObjectMetadata.xsd', because 1) could not find the document; 2) the document could not be read; 3) the root element of the document is not <xsd:schema>.'

A XMLNSC warning occurred during the validation of a XML schema.

Processing will continue, but you should review and resolve the problems that are indicated in the message from the XMLNSC validator.


and appears to crash the node, forcing an auto-restart.

Converting the Java project to a static library and including it removes the errors at deployment, but causes the SAP Inbound Resource Adapter to be uneditable, giving the error:
Quote:
No resource adapter can be found for the selected adapter component.
The resource adapter connector project required by theis adapter component may not exist in the workspace.
Or, there are no connector projects referenced by the message set project containing the adapter component.
Exception details: There are no connector projects referenced by this message set project.


Copying the files from the common adapter project into the consuming Lib project containing the actual adapter configuration seems to work, but is kludgy and defeats the purpose.

Creating a separate adapter project for each project from scratch seems to work, but there are a lot of apps to touch in a short window.

I understand that WAS Adapters don't work in a Shared Lib, but why won't it find what it needs when referenced as a Java or Lib project? Should every app have its own adapter project, or is there a way to share properly?

Thank you.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportCommon SAP Adapter problems at deployment
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.