ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportJMSexpiration Value Not working

Post new topicReply to topic
JMSexpiration Value Not working View previous topic :: View next topic
Author Message
Learning_MQ_IIB
PostPosted: Wed Sep 19, 2018 12:12 am Post subject: JMSexpiration Value Not working Reply with quote

Novice

Joined: 13 Mar 2018
Posts: 14

Hi All,

As mentioned in the knowledge center, trying to set the JMS Expiration in the ESQL module as shown below:

SET OutputRoot.JMSTransport.Transport_Folders.Header_Values.JMSExpiration = 6000;

In the JMSOutput, Expiration property is set to "Inherit from header"

However, when I see in the destination (MQ), the expiry is not being set.

Also, tried setting MQMD.Expiry as below:
SET OutputRoot.MQMD.Expiry = 6000;

Still no success.
Any clue what is missing.

- Thanks
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Wed Sep 19, 2018 1:53 am Post subject: Reply with quote

Master

Joined: 17 Jul 2017
Posts: 236
Location: UK

hi...see whether the Exp field is getting set at the RFH2 header of the MQ message.

But if you know that the destination is going to be MQ why are using JMSOutput node, can't you use MQOutput instead?
Back to top
View user's profile Send private message
Learning_MQ_IIB
PostPosted: Sun Sep 23, 2018 7:35 pm Post subject: Reply with quote

Novice

Joined: 13 Mar 2018
Posts: 14

In IIB I am just adding the following folder as mentioned in the knowledge center:

OutputRoot.JMSTransport.Transport_Folders.Header_Values.JMSExpiration

This is going to be published to JMS topic. MQ Queue is just one of the subscriber.

Also, failed to mention earlier that if I set the value in JMSOutput node itself (under Advanced --> Message Expiration), the value works.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportJMSexpiration Value Not working
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.