ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportAMQ9213: A communications error for TCP/IP occurred

Post new topicReply to topic
AMQ9213: A communications error for TCP/IP occurred View previous topic :: View next topic
Author Message
KIDINMQ
PostPosted: Mon Sep 03, 2018 2:39 am Post subject: AMQ9213: A communications error for TCP/IP occurred Reply with quote

Newbie

Joined: 12 Nov 2013
Posts: 9

Help required to find out possible cause of this failure. This doesn't seems to be a regular Network issue where all the Network layers been thoroughly verified. Below the error is often writing in the Partial repository while starting(if messages arrived) the CLUSSDR, however the channel is in RUNNING state all the time and the local Queue @ Remote QMgr(Repository in this case) is updating with newer messages but the latency in Network causing the messages stuck at destination since the MDB not picking within the expected interval/timeout by WebSphere. Restart of the Partial and Remote QMgr(Cluster repository QMgr in this case) doesn't help.

-------------------------------------------------------------------------------
03/09/18 10:39:59 AM
AMQ9213: A communications error for TCP/IP occurred.

EXPLANATION:
An unexpected error occurred in communications.
ACTION:
The return code from the TCP/IP(select) [TIMEOUT] 360 seconds call was 0
(X'0'). Record these values and tell the systems administrator.
----- amqccita.c : 2995 -------------------------------------------------------
03/09/18 10:39:59 AM
AMQ9999: Channel program ended abnormally.

EXPLANATION:
Channel program 'TO.XXXX' ended abnormally.
ACTION:
Look at previous error messages for channel program 'TO.XXXX' in the error
files to determine the cause of the failure.
----- amqrccca.c : 883 --------------------------------------------------------
Back to top
View user's profile Send private message Send e-mail
gbaddeley
PostPosted: Mon Sep 03, 2018 7:10 pm Post subject: Reply with quote

Padawan

Joined: 25 Mar 2003
Posts: 1909
Location: Melbourne, Australia

Quote:
This doesn't seems to be a regular Network issue where all the Network layers been thoroughly verified.

It could be an intermittent network issue where packets are lost or blocked.
Timeout error on a select() usually means MQ was waiting to receive a particular TCP packet, or there was an internal TCP handshake going on, but it didn't complete within 360 seconds.
Can your network folks run a packet trace during normal operation, and then compare to trace during abnormal operations? It could identify the missing packet.
Quote:
latency in Network causing the messages stuck at destination

How much latency? Anything more than a few tens of milliseconds is cause for concern.
_________________
Glenn
Back to top
View user's profile Send private message
KIDINMQ
PostPosted: Tue Sep 04, 2018 1:55 am Post subject: latency in Network causing the messages stuck at destination Reply with quote

Newbie

Joined: 12 Nov 2013
Posts: 9

Thanks for prompt reply, the latency would be 360 secs only it seems and all the Network layers, vlans, comms, physical cables & possible areas been throughly verified. This still doesn't seems to be a regular Network issue or any packet loss issue. Still I will let Network folks to re initiate their troubleshoot on Packet loss. Thanks
Back to top
View user's profile Send private message Send e-mail
fjb_saper
PostPosted: Tue Sep 04, 2018 4:10 am Post subject: Re: latency in Network causing the messages stuck at destina Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19827
Location: LI,NY

KIDINMQ wrote:
Thanks for prompt reply, the latency would be 360 secs only it seems and all the Network layers, vlans, comms, physical cables & possible areas been thoroughly verified. This still doesn't seems to be a regular Network issue or any packet loss issue. Still I will let Network folks to re initiate their troubleshoot on Packet loss. Thanks


If your latency is really only 360ms, I can understand that ... but 360 s that means a 6 min latency. For that your partner needs to be in outer space... or else there is seriously something wrong with your network setup!!!
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
gbaddeley
PostPosted: Wed Sep 05, 2018 4:00 pm Post subject: Re: latency in Network causing the messages stuck at destina Reply with quote

Padawan

Joined: 25 Mar 2003
Posts: 1909
Location: Melbourne, Australia

KIDINMQ wrote:
Thanks for prompt reply, the latency would be 360 secs only

It can't be that high! Latency is the elapsed time from TCP packet being sent to it being received.
Quote:
it seems and all the Network layers, vlans, comms, physical cables & possible areas been throughly verified. This still doesn't seems to be a regular Network issue or any packet loss issue. Still I will let Network folks to re initiate their troubleshoot on Packet loss. Thanks

Network could be OK in a general sense, but there is something happening at the TCP socket layer(s) for MQ traffic, otherwise the MQ error logs would not contain those messages. It could also be an issue at the OS level or TCP driver level.

Is this on AIX? There is a known issue with some MAC address prefixes that cause rare instances of random packet loss.
_________________
Glenn
Back to top
View user's profile Send private message
KIDINMQ
PostPosted: Wed Sep 05, 2018 9:50 pm Post subject: Network could be OK in a general sense, but there is someth Reply with quote

Newbie

Joined: 12 Nov 2013
Posts: 9

Thanks for the reply, I will let my Network folks to verify the suggested ares. FYI, it's Solaris
Back to top
View user's profile Send private message Send e-mail
KIDINMQ
PostPosted: Thu Sep 20, 2018 6:33 am Post subject: Almost Resolved Reply with quote

Newbie

Joined: 12 Nov 2013
Posts: 9

Not sure if its too early to say, that issue is resolved, but it looks like the change did the trick. Replacing of Network port(Physical) as it's damaged is the CHANGE. Thanks everyone who contributed their time.
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ SupportAMQ9213: A communications error for TCP/IP occurred
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.