ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB Urlencoding with %2F

Post new topicReply to topic
IIB Urlencoding with %2F View previous topic :: View next topic
Author Message
lonesheep
PostPosted: Thu Apr 26, 2018 2:13 am Post subject: IIB Urlencoding with %2F Reply with quote

Novice

Joined: 12 Sep 2017
Posts: 20

Hi,

A quick question (hopefully). I have a HTTP Input node which is to receive a REST request. The request takes in query parameters, and one of these parameters can contain a forward slash '/'.

However, if I encode that '/' as %2F, I seem to get a Http 400 BAD REQUEST response back.

Has anyone else encountered this issue.

I'm using IIB 10.0.0.10.

Cheers
Back to top
View user's profile Send private message
souciance
PostPosted: Mon Apr 30, 2018 12:58 am Post subject: Re: IIB Urlencoding with %2F Reply with quote

Disciple

Joined: 29 Jun 2010
Posts: 152

lonesheep wrote:
Hi,

A quick question (hopefully). I have a HTTP Input node which is to receive a REST request. The request takes in query parameters, and one of these parameters can contain a forward slash '/'.

However, if I encode that '/' as %2F, I seem to get a Http 400 BAD REQUEST response back.

Has anyone else encountered this issue.

I'm using IIB 10.0.0.10.

Cheers


We use query parameters and are on 10.0.0.11 so it should be ok.
Did you debug/trace the flow to see if the message went beyond the HTTP Input node?
Back to top
View user's profile Send private message
timber
PostPosted: Tue May 01, 2018 2:25 am Post subject: Reply with quote

Shaman

Joined: 25 Aug 2015
Posts: 769

It would be fairly remarkable if IIB was not able to handle such a basic URL convention. Have you tried sending the same query string to a different server?
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB Urlencoding with %2F
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.