ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker Supportthere is a delay of 2min b/w SOAPRequest and SOAPInput nodes

Post new topicReply to topic
there is a delay of 2min b/w SOAPRequest and SOAPInput nodes View previous topic :: View next topic
Author Message
srikanthc60
PostPosted: Wed Apr 25, 2018 10:27 pm Post subject: there is a delay of 2min b/w SOAPRequest and SOAPInput nodes Reply with quote

Acolyte

Joined: 21 Jul 2013
Posts: 74

We notice that in our message flow, there is a delay of 2min b/w SOAPRequest and SOAPInput nodes.

We have 4 mins timeout set for transaction.

from SOAPRequest node, Web service request taking 2 mins to reach SOAPInput node in other flow on same EG and for processing it takes more than 2 mins+ time and ultimately getting timeout before SOAPRequest node getting response.

FYI, we have broker-wide and embedded listeners enabled and EG (message flow with above nodes) is using embedded listener for SOAP nodes.

mqsireportproperties IBNODE -b httplistener -o HTTPListener -n startListener --> TRUE

mqsireportproperties IBNODE -e EG_01 -o ExecutionGroup -n httpNodesUseEmbeddedListener --> FALSE
mqsireportproperties IBNODE -e EG_01-o ExecutionGroup -n soapNodesUseEmbeddedListener --> TRUE

Any idea why there was a delay of 2 mins.

Any help is appreciated.Thanks in advance!!
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Thu Apr 26, 2018 12:31 am Post subject: Reply with quote

Disciple

Joined: 17 Jul 2017
Posts: 155
Location: UK

hi...have you tried enabling the user trace for the flow which should help in pinpointing where the delay is occurring
Back to top
View user's profile Send private message
srikanthc60
PostPosted: Thu Apr 26, 2018 1:03 am Post subject: Reply with quote

Acolyte

Joined: 21 Jul 2013
Posts: 74

Not enabled yet.. I will do when there are timeouts again.

Any idea why there was a delay of 2 mins between SOAPRequest and SOAPInput. Do we need to change any setting at HTTPConnector level to process concurrent requests?
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Thu Apr 26, 2018 1:16 am Post subject: Reply with quote

Disciple

Joined: 17 Jul 2017
Posts: 155
Location: UK

The webservice you are trying to hit via SoapRequest node, it is worth checking whether the traffic is routed via some network proxy which might explain the delay. Have you tried hitting the same webservice outside of broker, eg:- curl or soapui and compare the response times
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker Supportthere is a delay of 2min b/w SOAPRequest and SOAPInput nodes
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.