ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral DiscussionMQ Channel initiator consumes high cpu

Post new topicReply to topic
MQ Channel initiator consumes high cpu View previous topic :: View next topic
Author Message
mqoncs
PostPosted: Tue Apr 10, 2018 3:30 pm Post subject: MQ Channel initiator consumes high cpu Reply with quote

Novice

Joined: 23 Dec 2014
Posts: 17

Messages on the channel init queue are not getting consumed and causing high CPU usage of runmqchi process. Any ideas what would be the cause of this.
Back to top
View user's profile Send private message
bruce2359
PostPosted: Tue Apr 10, 2018 4:07 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8110
Location: US: west coast, almost. Otherwise, enroute.

Look in the error logs for this qmgr.
_________________
I would tell you a UDP joke, but you might not get it.
Back to top
View user's profile Send private message
mqoncs
PostPosted: Tue Apr 10, 2018 4:30 pm Post subject: Reply with quote

Novice

Joined: 23 Dec 2014
Posts: 17

Yes, We have verified but there are no errors related to this.

Also noticed that the messages on the chl initq are placing by amqrmppa to MQTT queue SYSTEM.MQXR.COMMAND which it is not existed on the qmgr.
Back to top
View user's profile Send private message
bruce2359
PostPosted: Tue Apr 10, 2018 4:55 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8110
Location: US: west coast, almost. Otherwise, enroute.

Are you using the telemetry component of MQ?

Any other relevant information you would like to share? Like o/s, mq version, ...
_________________
I would tell you a UDP joke, but you might not get it.
Back to top
View user's profile Send private message
mvic
PostPosted: Wed Apr 11, 2018 5:08 am Post subject: Re: MQ Channel initiator consumes high cpu Reply with quote

Jedi

Joined: 09 Mar 2004
Posts: 2050

mqoncs wrote:
Messages on the channel init queue are not getting consumed and causing high CPU usage of runmqchi process. Any ideas what would be the cause of this.

Sounds like a bug.
Perhaps it's one of these?
IT23576
IT22864
Anyway, open a PMR. IBM should ask you to run a trace so they can see what the runmqchi process is doing. In fact why not do that now, in case the problem cannot be repeated later.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral DiscussionMQ Channel initiator consumes high cpu
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.