ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportDatabase error on rollback

Post new topicReply to topic
Database error on rollback View previous topic :: View next topic
Author Message
YRADI
PostPosted: Tue Mar 06, 2018 12:39 am Post subject: Database error on rollback Reply with quote

Newbie

Joined: 01 Feb 2015
Posts: 2

We have tried to apply the fix pack MB v8 8.0.0.9 in our production environment. However, it didnt work due to failed connection with the some SQL and DB2 database.
So we had to rollback our change and start our MB with version 8.0.0.5.

Kindly we need your help in troubleshooting this issue. Below is the error we faced when we tried to run the mqsicvp command to perform verification tests for the connection between the broker and the database and to verify ODBC connections.

osiprd01% mqsicvp PRD1.IBE.BRK -n ESBINTERFACES
BIP8299I: User 'fopsprd01' from security resource name 'ESBINTERFACES' will be used for the connection to datasource 'ESBINTERFACES'.
BIP8290I: Verification passed for the ODBC environment.

BIP2393E: Database error: ODBC return code '-1' from data source ''ESBINTERFACES'' using ODBC driver manager ''/opt/ibm/IE02/2.0.0/lib/libodbcinterface.so''.
The broker received an error when processing a database operation. The ODBC return code was '-1'. See the following messages for information obtained from the database abou this error.
Use the following messages to determine the cause of the error. Typical problems are an incorrect data source, or table names. Correct either the database or the broker coniguration. Use the mqsicvp command to test connectivity to this database.
BIP2322E: Database error: SQL State ''IM002''; Native Error Code '0'; Error Text ''[unixODBC][Driver Manager]Data source name not found, and no default driver specified''.
The error has the following diagnostic information: SQL State ''IM002'' SQL Native Error Code '0' SQL Error Text ''[unixODBC][Driver Manager]ata source name not found, and no default driver specified''
This message may be accompanied by other messages describing the effect on the message broker itself. Use the reason identified in this message with the accompanying messaes to determine the cause of the error. Use the mqsicvp command to test connectivity to this database.

BIP8040E: Unable to connect to the database.
The database cannot be accessed with the specified user Id and password pair.
- Check that the database is running.
- Check that the database has an adequate number of database connections available for use.
- On Windows, check that an ODBC connection has been created.
- On systems that use $ODBCINI, check that the file pointed to by $ODBCINI has been correctly updated.
- On z/OS check the BIPDSNAO member of the component's dataset, and check the DB2 64bit ODBC driver (DSNAO64C) is in the STEPLIB.
- Use mqsisetdbparms to set the password to the correct value and try again.
You have new mail.


Please find below the DB version list. The highlighted DBs are the failed to connect after applying the fix pack.

root@osiprd01 # more DBver |egrep "Datasource | databaseProviderVersion"
BIP8270I: Connected to Datasource 'PAPPDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'PLOGDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'DPRDOFY' as user 'ofyprd01'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
BIP8270I: Connected to Datasource 'DPRDFFIC' as user 'OFYSTG01'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
BIP8270I: Connected to Datasource 'ESBINTERFACES' as user 'fopsprd01'. The datasource platform is 'Microsoft SQL Server', version '11.00.3000'.
BIP8270I: Connected to Datasource 'PAPPDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'DPRDFFIC' as user 'ofystg01'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
BIP8270I: Connected to Datasource 'ESBINTERFACES' as user 'fopsprd01'. The datasource platform is 'Microsoft SQL Server', version '11.00.3000'.
BIP8270I: Connected to Datasource 'PLOGDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'DPRDSMS' as user 'SMSPRD01'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
BIP8270I: Connected to Datasource 'DPRDFFIC' as user 'PFIPRD02'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
BIP8270I: Connected to Datasource 'DPRDFMCM' as user 'dbo'. The datasource platform is 'Microsoft SQL Server', version '11.00.3000'.
BIP8270I: Connected to Datasource 'ADNPDCUS' as user 'OSICUSPROF'. The datasource platform is 'Microsoft SQL Server', version '11.00.3000'.
BIP8270I: Connected to Datasource 'eDRIS' as user 'fopsprd01'. The datasource platform is 'Microsoft SQL Server', version '11.00.3000'.
BIP8270I: Connected to Datasource 'PAPPDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'DPRDFFIC' as user 'ETSPRD01'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
BIP8270I: Connected to Datasource 'DPRDOSI' as user 'ETSPRD01'. The datasource platform is 'DB2/NT64', version '10.05.0008'.
BIP8270I: Connected to Datasource 'PAPPDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'PLOGDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'PAPPDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'DPRDFFIC' as user 'ofystg01'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
BIP8270I: Connected to Datasource 'PAPPDB01' as user 'mbid'. The datasource platform is 'DB2/SUN64', version '09.05.0003'.
BIP8270I: Connected to Datasource 'DPRDSMS' as user 'smsprd01'. The datasource platform is 'DB2/NT64', version '09.07.0008'.
root@osiprd01 #


osiprd01% uname -a
SunOS osiprd01 5.10 Generic_150400-13 sun4u sparc SUNW,SPARC-Enterprise
osiprd01%
osiprd01%
osiprd01% java -version
java version "1.6.0_75"
Java(TM) 2 Runtime Environment, Standard Edition (IBM build 1.6.0_75-b13 09_Apr_2014_08_03 solaris sparcv9 (SR16))
Java HotSpot(TM) 64-Bit Server VM (build 20.75-b01, mixed mode)
IBM Java ORB build orb60-20140319.00
XML build XL TXE Java 1.0.38
XML build IBM JAXP 1.4.10
XML build XML4J 4.5.24
osiprd01%
Back to top
View user's profile Send private message Send e-mail
abhi_thri
PostPosted: Tue Mar 06, 2018 12:58 am Post subject: Reply with quote

Master

Joined: 17 Jul 2017
Posts: 236
Location: UK

Assuming you've applied the 8.0.0.9 fixpack on non-Prod environments first, does the database connections (assuming the same database version levels) work as expected there?
Back to top
View user's profile Send private message
YRADI
PostPosted: Tue Mar 06, 2018 1:13 am Post subject: Reply with quote

Newbie

Joined: 01 Feb 2015
Posts: 2

Yes we tested and its running since one month
Back to top
View user's profile Send private message Send e-mail
abhi_thri
PostPosted: Tue Mar 06, 2018 2:03 am Post subject: Reply with quote

Master

Joined: 17 Jul 2017
Posts: 236
Location: UK

Thinks you could check are,
- whether the mqsiprofile profile is loaded correctly for 8.0.0.9
- The odbc files and the stanzas are correct, eg:- whether the driver path is pointing to the driver used by 8.0.0.9
- If everything looks correct it may be worth enabling odbc trace and see that shows more detail about the error.

From 8.0.0.6 onwards seems to be using DataDirect v7.1 instead of v7 (crosscheck which driver are you using - default still seems to be v6)

PS: It may be worth adding a subject line to this thread
Back to top
View user's profile Send private message
Vitor
PostPosted: Tue Mar 06, 2018 6:08 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25361
Location: Ohio, USA

abhi_thri wrote:
PS: It may be worth adding a subject line to this thread


Why give us any clues???

I made something up......
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
joebuckeye
PostPosted: Thu Mar 08, 2018 11:35 am Post subject: Reply with quote

Partisan

Joined: 24 Aug 2007
Posts: 339
Location: Columbus, OH

Isn't the reason for your error listed right here:

Quote:
BIP2322E: Database error: SQL State ''IM002''; Native Error Code '0'; Error Text ''[unixODBC][Driver Manager]Data source name not found, and no default driver specified''.


Whatever this is:
Quote:
root@osiprd01 # more DBver |egrep "Datasource | databaseProviderVersion"


Is no proof of your data sources. It just shows that someone at some point in time gathered this data into a file called DBver. How old is it?

You need to run mqsicvp <broker name> and it will list all the Data Sources (among other things) your broker is configured to use.

And you really need to update IIB to v10.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportDatabase error on rollback
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.