ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ Supportrunmqsc -c against a multi-instance qm

Post new topicReply to topic
runmqsc -c against a multi-instance qm View previous topic :: View next topic
Author Message
Esa
PostPosted: Wed Dec 21, 2016 12:20 am Post subject: runmqsc -c against a multi-instance qm Reply with quote

Grand Master

Joined: 22 May 2008
Posts: 1372
Location: Finland

Hi,

I'm testing client connections to a multi-instance queue manager with runmqsc -c. My CCDT has an entry with a list of connection names in CONNAME. But the client connects only to the first connection name in the list. If I switch over the queue manager, I get AMQ9508 Program cannot connect to the queue manager with no reason code.

If I switch the order of connection names in the CONNAME list, the client connects to the other instance, which is now the first in the list.

Both server and client are running on Red Hat Linux. MQ Server version is 8.0.0.4. MQ Client version is 8.0.0.2.

Is it so that runmqsc does not suppot CONNAME lists in client mode?
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Dec 21, 2016 5:19 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 18868
Location: LI,NY

It should. If you can positively point it back to the client list in the ccdt channel, then go ahead and open a PMR. What I suspect though is a poorly defined ccdt.

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
umatharani
PostPosted: Thu Dec 22, 2016 4:49 pm Post subject: Reply with quote

Apprentice

Joined: 23 Oct 2008
Posts: 37

I suspect the problem could be because of the APAR IT09524 if you have created the table using runmqsc -n(i.e. on the client side). Try with a table created from the server or try with a table created on MQ 8003 or higher MQ levels on the client side.

Thanks,
mahesh
Back to top
View user's profile Send private message
Esa
PostPosted: Fri Dec 23, 2016 10:23 am Post subject: Reply with quote

Grand Master

Joined: 22 May 2008
Posts: 1372
Location: Finland

I tested with CCDT's created with runmqsc -n and on a server running v. 8.0.0.4. I guess I should upgrade the client to version 8.0.0.4 and test if the problem persists. Thanks for the info, this APAR is not mentioned in V. 8 fix list.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ Supportrunmqsc -c against a multi-instance qm
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.