ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexiSeries, OpenVMS, HP-NSSQueue Manager Restart Problem on AS400

Post new topicReply to topic
Queue Manager Restart Problem on AS400 View previous topic :: View next topic
Author Message
ravi_sri24
PostPosted: Mon Jul 06, 2009 5:20 am Post subject: Queue Manager Restart Problem on AS400 Reply with quote

Voyager

Joined: 11 May 2006
Posts: 83

Hi All,

I have created the queue manager and start the queue manager it worked fine, but after some day's server is reboored but the queue manager is not started automatically when i tried to start the queue manager after some day's manually the queue manager is not starting and getting faild with the below MQ Journal entries , Could you please help me on this


07/06/09 08:52:58 - Process(381.1) User(QMQM) Jobname(136765/QMQM/AMQZXMAX )
AMQ7433: An Error occured while performing a journal replay.

EXPLANATION:

Cause . . . . . : WebSphere MQ encountered a problem reading one or more
journal entries while performing a journal replay operation.
Recovery . . . : If you have previously created a journal receiver for a
queue manager or are performing a cold restart of a queue manager, delete the
QMQMCHKPT file from the queue manager subdirectory in /QIBM/UserData/mqm/qmgrs/
and attempt to restart the queue manager. If the problem persists, use the
standard facilities supplied with your system to record the problem identifier,
and to save the generated output files. Contact your IBM support center. Do not
discard these files until the problem has been resolved.
Technical Description . . . . . . . . : None.
----- amqalccx.c : 1004 -------------------------------------------------------
07/06/09 08:52:58 - Process(381.1) User(QMQM) Jobname(136765/QMQM/AMQZXMAX )
AMQ7432: WebSphere MQ journal entry not available for replay.

EXPLANATION:

Cause . . . . . : A journal replay operation was attempted, but the
operation required journal entries from journal receivers that are not
currently present on the system.
Recovery . . . : Restore the required journal receivers from backup. Then
try the operation again.
Technical Description . . . . . . . . : The journal entry that was required
for the operation was dated 06/27/09 21:41:39. You need to restore all
WebSphere MQ journal receivers backed up since that date.
Back to top
View user's profile Send private message
exerk
PostPosted: Mon Jul 06, 2009 5:36 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5921

And did you?

Quote:
If you have previously created a journal receiver for a queue manager or are performing a cold restart of a queue manager, delete the QMQMCHKPT file from the queue manager subdirectory in QIBM/UserData/mqm/qmgrs/ and attempt to restart the queue manager.

_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
ravi_sri24
PostPosted: Mon Jul 06, 2009 5:45 am Post subject: Reply with quote

Voyager

Joined: 11 May 2006
Posts: 83

Yes I did but still facing the same problem

exerk wrote:
And did you?

Quote:
If you have previously created a journal receiver for a queue manager or are performing a cold restart of a queue manager, delete the QMQMCHKPT file from the queue manager subdirectory in QIBM/UserData/mqm/qmgrs/ and attempt to restart the queue manager.
Back to top
View user's profile Send private message
exerk
PostPosted: Mon Jul 06, 2009 5:49 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5921

So you tried that, and then tried?

Quote:
The journal entry that was required for the operation was dated 06/27/09 21:41:39. You need to restore all WebSphere MQ journal receivers backed up since that date.

_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
ravi_sri24
PostPosted: Mon Jul 06, 2009 6:05 am Post subject: Reply with quote

Voyager

Joined: 11 May 2006
Posts: 83

We dont have any backup's to restore, Am not familer with the AS400 Journals can you please suggest me where can i look for the journal backup's
Back to top
View user's profile Send private message
exerk
PostPosted: Mon Jul 06, 2009 6:13 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5921

ravi_sri24 wrote:
We dont have any backup's to restore...




ravi_sri24 wrote:
...Am not familer with the AS400 Journals can you please suggest me where can i look for the journal backup's


Try the iSeries System Administrators, they might have them tucked away somewhere. Also, fault diagnose how the journals were lost, and take action to ensure it doesn't happen again, or that a proper back-up regime is in place.
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
sumit
PostPosted: Tue Jul 07, 2009 6:38 am Post subject: Reply with quote

Partisan

Joined: 19 Jan 2006
Posts: 398

exerk wrote:
Also, fault diagnose how the journals were lost...

By the way, what are the reasons which may cause such problem? Can it be because:
1. Queue manager was not stopped properly?
2. Someone or some process disturbed the journal creation or existing journals?
_________________
Regards
Sumit
Back to top
View user's profile Send private message Yahoo Messenger
boristep
PostPosted: Sun Jan 17, 2016 4:49 am Post subject: AMQ7432: WebSphere MQ journal entry not available for replay Reply with quote

Novice

Joined: 02 Jan 2013
Posts: 11

Anyway, if we dont have the backup of the needed receiver, what we have to do? define a new QM, reinstall the MQ product ...
Back to top
View user's profile Send private message
smdavies99
PostPosted: Sun Jan 17, 2016 7:10 am Post subject: Re: AMQ7432: WebSphere MQ journal entry not available for re Reply with quote

Jedi Council

Joined: 10 Feb 2003
Posts: 6077
Location: Somewhere over the Rainbow this side of Never-never land.

boristep wrote:
Anyway, if we dont have the backup of the needed receiver, what we have to do? define a new QM, reinstall the MQ product ...


Please explain why you reopened a thread dating from 2009?
If you have a similar problem then open a new thread and reference this one.
The MQ product has moved on considerably since 2009.
_________________
WMQ User since 1999
MQSI/WBI/WMB/'Thingy' User since 2002
Linux user since 1995

Every time you reinvent the wheel the more square it gets (anon). If in doubt think and investigate before you ask silly questions.
Back to top
View user's profile Send private message
bruce2359
PostPosted: Sun Jan 17, 2016 7:25 am Post subject: Re: AMQ7432: WebSphere MQ journal entry not available for re Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8128
Location: US: west coast, almost. Otherwise, enroute.

smdavies99 wrote:
Please explain why you reopened a thread dating from 2009?
If you have a similar problem then open a new thread and reference this one.
The MQ product has moved on considerably since 2009.

A minor infraction of form.
_________________
I would tell you a UDP joke, but you might not get it.
Back to top
View user's profile Send private message
bruce2359
PostPosted: Sun Jan 17, 2016 7:27 am Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8128
Location: US: west coast, almost. Otherwise, enroute.

Moved to as/400 iSeries forum.
_________________
I would tell you a UDP joke, but you might not get it.
Back to top
View user's profile Send private message
zpat
PostPosted: Sun Jan 17, 2016 10:24 am Post subject: Reply with quote

Jedi Council

Joined: 19 May 2001
Posts: 5651
Location: UK

There are some APAR fixes in this area for issues relating to being unable to restart QMs on i-series.

Also the IBM support center can tell you how to work around these bugs to get them back up and running (without any restore).

You can find most of these with google as well.
_________________
Well, I don't think there is any question about it. It can only be attributable to human error. This sort of thing has cropped up before, and it has always been due to human error.
Back to top
View user's profile Send private message
colbype
PostPosted: Thu Feb 11, 2016 12:46 pm Post subject: Reply with quote

Novice

Joined: 13 Jan 2009
Posts: 23

Doing a cold restart will get you back up and running in most cases.

As for your journals, check to see if they are managed by the system or not. A lot of places have journal cleanup jobs that run every so often. Most of the time they state that if a journal is detached and saved, it is ok to remove them.

The app groups said to remove journals every 30 minutes and during an restart/IPL, the journal was saved and detached so they removed it. Normally I always had them exclude MQ journals so I could manage the save/cleanup on my own schedule.
Back to top
View user's profile Send private message
bruce2359
PostPosted: Thu Feb 11, 2016 1:01 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8128
Location: US: west coast, almost. Otherwise, enroute.

What version of mq are you running?
_________________
I would tell you a UDP joke, but you might not get it.
Back to top
View user's profile Send private message
colbype
PostPosted: Thu Feb 18, 2016 6:20 am Post subject: Reply with quote

Novice

Joined: 13 Jan 2009
Posts: 23

A mix between 7.0 for all V5R4 systems and 7.1 for V6 and above.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexiSeries, OpenVMS, HP-NSSQueue Manager Restart Problem on AS400
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.