ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ API SupportPub/Sub between JMS and non-JMS users

Post new topicReply to topic
Pub/Sub between JMS and non-JMS users View previous topic :: View next topic
Author Message
nberger
PostPosted: Mon Jul 09, 2001 1:08 pm Post subject: Reply with quote

Newbie

Joined: 08 Jul 2001
Posts: 7

I am trying to use MQSeries pub/sub between JMS and non-JMS. My non-JMS user can receive non-JMS publications but doesn't receive any messages when subscribing to JMS publications.

Any ideas????
Back to top
View user's profile Send private message
kolban
PostPosted: Mon Jul 09, 2001 1:43 pm Post subject: Reply with quote

Grand Master

Joined: 22 May 2001
Posts: 1072
Location: Fort Worth, TX, USA

Use the IBM supplied sample "amqspsd" (see the Pub/Sub users guide) and inquire on the pub/sub broker. Ensure that the subscriptions are as they appear. If it would help, post the results back here for analysis.

I am assuming that you are using the MA0C Pub/Sub distribution as opposed to the one supplied in the MQSI V2 product?
Back to top
View user's profile Send private message
nberger
PostPosted: Tue Jul 10, 2001 8:39 am Post subject: Reply with quote

Newbie

Joined: 08 Jul 2001
Posts: 7

Thanks for the tip - I hadn't used that tool before. From the output it looks like we just have a mismatch in subscription topics - I had "topic://topicname" and JMS interprets that for MQ as just "topicname".

So we're going to make that adjustment and try again. Thanks again and I'll keep you posted.
Back to top
View user's profile Send private message
nberger
PostPosted: Tue Jul 10, 2001 12:09 pm Post subject: Reply with quote

Newbie

Joined: 08 Jul 2001
Posts: 7

I am now receiving messages but even after I parse out the MQRFH info I'm still getting messages that just say "RFH" when I print them out. I can retrieve the message from the character buffer by searching for the first words in the message, but it kind of defeats the point of getting a message if you have to know what it contains to read it.

Does anyone know the proper way to get past the MQRFH2 headers included in the JMS publications? The JMS publisher can't seem to figure out how to turn them off...

Oh yes, and we are using the MA0C stuff. Thanks.
Back to top
View user's profile Send private message
kolban
PostPosted: Tue Jul 10, 2001 1:16 pm Post subject: Reply with quote

Grand Master

Joined: 22 May 2001
Posts: 1072
Location: Fort Worth, TX, USA

This thread now being worked in the following posting:

http://www.mqseries.net/phpBB/viewtopic.php?topic=98&forum=5&1
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ API SupportPub/Sub between JMS and non-JMS users
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.