ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportConnection timeout error while calling https web service

Post new topicReply to topic
Connection timeout error while calling https web service View previous topic :: View next topic
Author Message
manish1184
PostPosted: Thu Oct 15, 2020 1:13 am Post subject: Connection timeout error while calling https web service Reply with quote

Newbie

Joined: 15 Oct 2020
Posts: 1

Hi All,

I am using IIB 9.0.0.2.
I have some web services which is calling WSO2 application via load balancer.

I am calling the WSO2 web service which is https from SOAP Request Node. I have configured truststore and it works fine. But after few days, I get Connection timeout error for all the requests. Below is the integration server console log :



-------------------------------------------------------------
This service was working but now I am getting above error for all requestS which goes to WSO2. But when I restart the integration server then again this service works perfectly but after some days again I get connection timeout error. My flow is :
Soap Input --> compute --> Soap Request Node (https configure) --> Compute node --> Soap Reply Node

Soap Request Node is hitting WSO2 LOAD Balancer. There is no change in certificates from WSO2 side . I am able to do telnet the LOAD Balancer with 443 port. If I am hitting the wso2 service(using Load balancer URL) directly from SOAP UI,then I am getting correct response . When I hit the service through IIB then I am getting connection timeout error.
Back to top
View user's profile Send private message
Vitor
PostPosted: Thu Oct 15, 2020 5:21 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 26062
Location: Texas, USA

Is it always the same instance of the load balanced service which fails? Is one configured incorrectly?
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportConnection timeout error while calling https web service
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.