ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportPort change HTTPS for integration server does not work

Post new topicReply to topic
Port change HTTPS for integration server does not work View previous topic :: View next topic
Author Message
MKHODER1
PostPosted: Sat Sep 26, 2020 3:06 am Post subject: Port change HTTPS for integration server does not work Reply with quote

Novice

Joined: 18 Aug 2018
Posts: 24

Hi everyone,

I deployed a service exposed in https on the integration server here is the result to display the https properties

mqsireportproperties IN01 -e IS01 -o HTTPSConnector -r

HTTPSConnector
uuid='HTTPSConnector'
userTraceLevel='none'
traceLevel='none'
userTraceFilter='none'
traceFilter='none'
port='0'
address=''
maxPostSize=''
acceptCount=''
compressableMimeTypes=''
compression=''
connectionLinger=''
connectionTimeout=''
maxHttpHeaderSize=''
maxKeepAliveRequests='0'
maxThreads=''
minSpareThreads=''
noCompressionUserAgents=''
restrictedUserAgents=''
socketBuffer=''
tcpNoDelay='true'
explicitlySetPortNumber=''
enableLookups=''
enableMQListener=''
shutdownDelay=''
allowCrossConnectorPolling=''
autoRespondHTTPHEADRequests=''
integratedWindowsAuthentication=''
iwaTimeoutSeconds='300'
serverName=''
corsEnabled='false'
corsAllowOrigins='*'
corsAllowCredentials='false'
corsExposeHeaders='Content-Type'
corsMaxAge='-1'
corsAllowMethods='GET,HEAD,POST,PUT,PATCH,DELETE,OPTIONS'
corsAllowHeaders='Accept,Accept-Language,Content-Language,Content-Type'
disableHttpMethods=''
disableConnector=''
relaxedPathChars=''
relaxedQueryChars=''
algorithm=''
clientAuth=''
keystoreFile=''
keystorePass=''
keystoreType=''
truststoreFile=''
truststorePass=''
truststoreType=''
sslProtocol=''
ciphers=''
keypass=''
keyAlias=''
sslSessionTimeout=''
crlFile=''
propagateClientCert=''
sessionCacheSize=''
Connector
cachedSSLSessions='0'
port='8780'
type='Broker'
URLRegistration
url='/httpInputWithHTTPS'
UsedBySOAPNNodes='FALSE'
UsedByHTTPNNodes='TRUE'
nodeLabel='HTTP Input'
flowLabel='https'
URLRegistration
url='/soapInputWithHTTPS'
UsedBySOAPNNodes='TRUE'
UsedByHTTPNNodes='FALSE'
nodeLabel='SOAP Input'
flowLabel='https'

BIP8071I: Successful command completion.

I want to switch to using the embedded listener https on the integration server.

I configured the integration server to listen on 8843 for HTTPS requests with the following command :

mqsichangeproperties IN01 -e IS01 -o HTTPSConnector -n explicitlySetPortNumber -v 8443


The urls are gone, did I miss a part of the configuration ?

mqsireportproperties IN01 -e IS01 -o HTTPSConnector -r
HTTPSConnector
uuid='HTTPSConnector'
userTraceLevel='none'
traceLevel='none'
userTraceFilter='none'
traceFilter='none'
port='0'
address=''
maxPostSize=''
acceptCount=''
compressableMimeTypes=''
compression=''
connectionLinger=''
connectionTimeout=''
maxHttpHeaderSize=''
maxKeepAliveRequests='0'
maxThreads=''
minSpareThreads=''
noCompressionUserAgents=''
restrictedUserAgents=''
socketBuffer=''
tcpNoDelay='true'
explicitlySetPortNumber='8443'
enableLookups=''
enableMQListener=''
shutdownDelay=''
allowCrossConnectorPolling=''
autoRespondHTTPHEADRequests=''
integratedWindowsAuthentication=''
iwaTimeoutSeconds='300'
serverName=''
corsEnabled='false'
corsAllowOrigins='*'
corsAllowCredentials='false'
corsExposeHeaders='Content-Type'
corsMaxAge='-1'
corsAllowMethods='GET,HEAD,POST,PUT,PATCH,DELETE,OPTIONS'
corsAllowHeaders='Accept,Accept-Language,Content-Language,Content-Type'
disableHttpMethods=''
disableConnector=''
relaxedPathChars=''
relaxedQueryChars=''
algorithm=''
clientAuth=''
keystoreFile=''
keystorePass=''
keystoreType=''
truststoreFile=''
truststorePass=''
truststoreType=''
sslProtocol='TLSv1.2'
ciphers=''
keypass=''
keyAlias=''
sslSessionTimeout=''
crlFile=''
propagateClientCert=''
sessionCacheSize=''
BIP8071I: Successful command completion.

stderror
2020-09-24 18:12:17.621 49 java.lang.Exception: Could not start HTTP(S)Connector.
2020-09-24 18:12:17.621 49 at com.ibm.broker.inlinehttp.tomcatthreadpool.TomcatInstanceManager.startTomcatIfNecessary(TomcatInstanceManager.java:1893)
2020-09-24 18:12:17.622 49 at com.ibm.broker.inlinehttp.tomcatthreadpool.TomcatInstanceManager.getInstanceForPortInternal(TomcatInstanceManager.java:534)
2020-09-24 18:12:17.622 49 at com.ibm.broker.inlinehttp.tomcatthreadpool.TomcatInstanceManager.getInstanceForPort(TomcatInstanceManager.java:425)
2020-09-24 18:12:17.623 49 at com.ibm.broker.axis2.TomcatNodeRegistrationUtil.registerInputNode(TomcatNodeRegistrationUtil.java:207)
2020-09-24 18:12:17.623 49 at com.ibm.broker.axis2.TomcatNodeRegistrationUtil.registerHTTPInputNode(TomcatNodeRegistrationUtil.java:114)
2020-09-24 18:12:17.624 49 Caused by: java.io.IOException: Cannot obtain URL for the relative path [/app/iib/keystore/iib.jks]. Check that catalina.base is set.
2020-09-24 18:12:17.625 49 at org.apache.tomcat.util.file.ConfigFileLoader.getInputStream(ConfigFileLoader.java:102)
2020-09-24 18:12:17.625 49 at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getStore(JSSESocketFactory.java:473)
2020-09-24 18:12:17.626 49 at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getTrustStore(JSSESocketFactory.java:434)
2020-09-24 18:12:17.626 49 at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getTrustManagers(JSSESocketFactory.java:707)
2020-09-24 18:12:17.626 49 at org.apache.tomcat.util.net.jsse.JSSESocketFactory.getTrustManagers(JSSESocketFactory.java:617)
2020-09-24 18:12:17.627 49 at org.apache.tomcat.util.net.jsse.JSSESocketFactory.init(JSSESocketFactory.java:540)
2020-09-24 18:12:17.628 49 at org.apache.tomcat.util.net.jsse.JSSESocketFactory.createSocket(JSSESocketFactory.java:256)
2020-09-24 18:12:17.628 49 at org.apache.tomcat.util.net.JIoEndpoint.bind(JIoEndpoint.java:401)
2020-09-24 18:12:17.628 49 at org.apache.tomcat.util.net.AbstractEndpoint.init(AbstractEndpoint.java:750)
2020-09-24 18:12:17.629 49 at org.apache.coyote.AbstractProtocol.init(AbstractProtocol.java:467)
2020-09-24 18:12:17.629 49 at org.apache.coyote.http11.AbstractHttp11JsseProtocol.init(AbstractHttp11JsseProtocol.java:119)
2020-09-24 18:12:17.630 49 at com.ibm.broker.inlinehttp.tomcatthreadpool.TomcatInstanceManager.startTheActualConnector(TomcatInstanceManager.java:1223)
2020-09-24 18:12:17.630 49 at com.ibm.broker.inlinehttp.tomcatthreadpool.TomcatInstanceManager.startTomcatIfNecessary(TomcatInstanceManager.java:1730)
2020-09-24 18:12:17.631 49 ... 4 more
2020-09-24 18:12:17.632 49 Caused by: java.lang.IllegalArgumentException: URI is not absolute
2020-09-24 18:12:17.632 49 at java.net.URI.toURL(URI.java:1099)
2020-09-24 18:12:17.633 49 at org.apache.tomcat.util.file.ConfigFileLoader.getInputStream(ConfigFileLoader.java:100)
2020-09-24 18:12:17.633 49 ... 16 more


Many thanks


Last edited by MKHODER1 on Tue Sep 29, 2020 6:39 am; edited 1 time in total
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Sun Sep 27, 2020 10:44 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20394
Location: LI,NY

you may have a clash on the same port of HTTPS and non HTTPS traffic.
It also looks like this traffic may have the same URL...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportPort change HTTPS for integration server does not work
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.