ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportODBC DSN configuration errors (Windows)

Post new topicReply to topic
ODBC DSN configuration errors (Windows) View previous topic :: View next topic
Author Message
simonalexander2005
PostPosted: Tue Sep 01, 2020 5:15 am Post subject: ODBC DSN configuration errors (Windows) Reply with quote

Apprentice

Joined: 13 Jun 2016
Posts: 45

I previous installed IIB version 9 on Windows 7. The ODBC drivers appear in both "Microsoft ODBC Administrator" (32-bit) and "Data Sources x64 (ODBC)".

I have now installed IIB version 10 (10.0.0.21 Developer edition) alongside it, and the x64 data sources window doesn't show the version 10 drivers.

Additionally, I can create data sources (System DSN) under Version 10.0.0.21 using the 32-bit version of the administrator tool, but when I try to delete the Data Source I get the following messages:

Quote:
The setup routines for the IBM Integration Bus 10.0.0.21 Developer Edition - DataDirect Technologies 64-BIT Oracle Wire Protoco [sic] ODBC driver could not be found. Please reinstall the driver.

Driver's ConfigDSN, ConfigDriver, or ConfigTranslator failed. Errors Found: Component not found in registry


I can create and delete IIB9 Data Sources just fine, using either tool.

The fact that the name of the driver is cut off in the quote implies to me that there is an issue with some max name length being surpassed, but I don't know if that's true or not. I have tried editing the registry to make the name match that seen in the textbox (in accordance with some instructions I saw online), but it just made the driver details change in the 32-bit UI and still not appear in the 64-bit.

In the registry I have the following:

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\IBM Integration (9.0.0.2) - DataDirect Technologies 7.0 64-BIT Oracle Wire Protocol

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\IBM Integration (9.0.0.2) - DataDirect Technologies 7.0 64-BIT Sybase Wire Protocol

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\IBM Integration Bus 10.0.0.21 Developer Edition - DataDirect Technologies 64-BIT Oracle Wire Protocol

    HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\IBM Integration Bus 10.0.0.21 Developer Edition - DataDirect Technologies 64-BIT Sybase Wire Protocol

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI\IBM Integration (9.0.0.6) - DataDirect Technologies 7.1 64-BIT Oracle Wire Protocol

    HKEY_LOCAL_MACHINE\SOFTWARE\Wow6432Node\ODBC\ODBCINST.INI\IBM Integration (9.0.0.6) - DataDirect Technologies 7.1 64-BIT Sybase Wire Protocol


I assume I need to reinstall the IIB ODBC drivers? - If so, can I do that; and if not, what do I need to do to resolve this?
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Tue Sep 01, 2020 5:40 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20417
Location: LI,NY

You should probably uninstall the toolkit and reinstall it. And make sure that the installing user has registry privileges... i.e. run as Administrator...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
simonalexander2005
PostPosted: Tue Sep 01, 2020 6:30 am Post subject: Reply with quote

Apprentice

Joined: 13 Jun 2016
Posts: 45

I've only got "IIB Developer Edition" in Add/Remove programs, rather than Toolkit separately. Will uninstalling IIB delete my brokers?
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Tue Sep 01, 2020 10:34 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20417
Location: LI,NY

simonalexander2005 wrote:
I've only got "IIB Developer Edition" in Add/Remove programs, rather than Toolkit separately. Will uninstalling IIB delete my brokers?
No, it won't. Just remove and reinstall the developer edition. In the registry at the level below
Code:
HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\IBM Integration Bus 10.0.0.21 Developer Edition - DataDirect Technologies 64-BIT Oracle Wire Protocol
you should have entries pointing to ukoraxxx.dll and so on...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
simonalexander2005
PostPosted: Wed Sep 02, 2020 3:57 am Post subject: Reply with quote

Apprentice

Joined: 13 Jun 2016
Posts: 45

I uninstalled, restarted, installed as administrator, restarted; but it's still not right.

In the registry I do have the entries for IIB 10, but they don't appear in the list of drivers in the ODBC Data Source Administrator (x64). for the 32-bit ODBC Administrator they appear, but I still get the same errors when I try and delete or edit a DSN - so no change
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Sep 02, 2020 4:44 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20417
Location: LI,NY

simonalexander2005 wrote:
I uninstalled, restarted, installed as administrator, restarted; but it's still not right.

In the registry I do have the entries for IIB 10, but they don't appear in the list of drivers in the ODBC Data Source Administrator (x64). for the 32-bit ODBC Administrator they appear, but I still get the same errors when I try and delete or edit a DSN - so no change

You may have a corrupted install. Can you download a new one?
This is what I have im my registry for oracle:
Code:
Computer\HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\IBM Integration Bus 10.0.0.10 Developer Edition - DataDirect Technologies 64-BIT Oracle Wire Protocol
and underneath
Driver = D:\Program Files\IBM\IIB\10.0.0.10\server\bin\ukora95.dll
DriverODBCVer = 03.52
HelpRootDirectory = D:\Program Files\IBM\IIB\10.0.0.10\server\DataDirect\help
Setup = D:\Program Files\IBM\IIB\10.0.0.10\server\bin\ukora95.dll
SQLLevel = 1
and a few other entries...

Did you try and add the driver to your ODBC 64 setup?
Hope it helps
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
simonalexander2005
PostPosted: Wed Sep 02, 2020 6:49 am Post subject: Reply with quote

Apprentice

Joined: 13 Jun 2016
Posts: 45

fjb_saper wrote:

This is what I have im my registry for oracle (...)


Yes, me too; both times I installed I had this same set of entries.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Sep 02, 2020 12:00 pm Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20417
Location: LI,NY

simonalexander2005 wrote:
fjb_saper wrote:

This is what I have im my registry for oracle (...)


Yes, me too; both times I installed I had this same set of entries.

They do appear in my ODBC 64 -- drivers section...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
simonalexander2005
PostPosted: Wed Sep 02, 2020 11:19 pm Post subject: Reply with quote

Apprentice

Joined: 13 Jun 2016
Posts: 45

fjb_saper wrote:
simonalexander2005 wrote:
fjb_saper wrote:

This is what I have im my registry for oracle (...)


Yes, me too; both times I installed I had this same set of entries.

They do appear in my ODBC 64 -- drivers section...


Well not mine, that's the issue...
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Thu Sep 03, 2020 6:07 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20417
Location: LI,NY

Did you verify that you have the driver entries in the registry?
And if you do, are you sure your windows installation is not corrupt?
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
simonalexander2005
PostPosted: Thu Sep 03, 2020 6:37 am Post subject: Reply with quote

Apprentice

Joined: 13 Jun 2016
Posts: 45

fjb_saper wrote:
Did you verify that you have the driver entries in the registry?
And if you do, are you sure your windows installation is not corrupt?


I do have the driver entries in the registry, but not in the data sources adminstrator (x64). I guess it's always possible there's something up with Windows...
Back to top
View user's profile Send private message
simonalexander2005
PostPosted: Sun Oct 04, 2020 11:50 pm Post subject: Reply with quote

Apprentice

Joined: 13 Jun 2016
Posts: 45

simonalexander2005 wrote:
fjb_saper wrote:
Did you verify that you have the driver entries in the registry?
And if you do, are you sure your windows installation is not corrupt?


I do have the driver entries in the registry, but not in the data sources adminstrator (x64). I guess it's always possible there's something up with Windows...


I have now fixed this, so I'll make a note here in case it helps others.

The issue is, the name of the driver "IBM Integration Bus 10.0.0.10 Developer Edition - DataDirect Technologies 64-BIT Oracle Wire Protocol" is too long for Windows to cope with. So, I went into the Registry and basically did a find-and-replace with a shorter name, everywhere that name comes up. This then fixed this issue and the DSNs all works again.

Specifically, under HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\ODBC Data Sources and HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI and HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon Oct 05, 2020 4:43 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 26068
Location: Texas, USA

Thank you for sharing your solution
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
nextyr3again
PostPosted: Fri Nov 13, 2020 8:21 am Post subject: Awesome, thank you very much!! this worked for me Reply with quote

Newbie

Joined: 02 Oct 2014
Posts: 1

simonalexander2005 wrote:
simonalexander2005 wrote:
fjb_saper wrote:
Did you verify that you have the driver entries in the registry?
And if you do, are you sure your windows installation is not corrupt?


I do have the driver entries in the registry, but not in the data sources adminstrator (x64). I guess it's always possible there's something up with Windows...


I have now fixed this, so I'll make a note here in case it helps others.

The issue is, the name of the driver "IBM Integration Bus 10.0.0.10 Developer Edition - DataDirect Technologies 64-BIT Oracle Wire Protocol" is too long for Windows to cope with. So, I went into the Registry and basically did a find-and-replace with a shorter name, everywhere that name comes up. This then fixed this issue and the DSNs all works again.

Specifically, under HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBC.INI\ODBC Data Sources and HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI and HKEY_LOCAL_MACHINE\SOFTWARE\ODBC\ODBCINST.INI\ODBC Drivers
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Fri Nov 13, 2020 9:14 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20417
Location: LI,NY

Great to know you got it working
Thanks for sharing
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportODBC DSN configuration errors (Windows)
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.