ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker Supporton IIB 10.0.0.7, createbar is failing

Post new topicReply to topic
on IIB 10.0.0.7, createbar is failing View previous topic :: View next topic
Author Message
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 4:22 am Post subject: on IIB 10.0.0.7, createbar is failing Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8

on IIB 10.0.0.7, createbar is failing post adding the Rest api subflow into existing message flow with swagger yaml file reference into the existing project.
Back to top
View user's profile Send private message Send e-mail
fjb_saper
PostPosted: Fri Aug 07, 2020 4:41 am Post subject: Re: on IIB 10.0.0.7, createbar is failing Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20421
Location: LI,NY

m.kamalakshi.88 wrote:
on IIB 10.0.0.7, createbar is failing post adding the Rest api subflow into existing message flow with swagger yaml file reference into the existing project.

Let me try explaining that to you: I've built that nice miniaturized fission reactor, and it's failing to produce any energy...

So no unless you give us much more information, we won't be able to help.
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Vitor
PostPosted: Fri Aug 07, 2020 4:45 am Post subject: Re: on IIB 10.0.0.7, createbar is failing Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 26074
Location: Texas, USA

fjb_saper wrote:
I've built that nice miniaturized fission reactor, and it's failing to produce any energy...


Yes, and as an early adopter I'd like a refund please. I'd also like to talk to your lawyer about my recently luminous cat.

fjb_saper wrote:
unless you give us much more information, we won't be able to help.





From what you've posted here, the best thing I can hypothesize is that something's wrong.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 5:13 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8

The message is:

A required display could not be obtained from the underlying operating system. To resolve this issue on Linux install X Virtual Frame Buffer (Xvfb), start Xvfb, and set the DISPLAY environment variable on your system.
Back to top
View user's profile Send private message Send e-mail
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 5:16 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8

on Linux, I installed X Virtual Frame Buffer (Xvfb), started Xvfb, and set the DISPLAY environment variable on your system.

Still getting same error
[/img]
Back to top
View user's profile Send private message Send e-mail
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 5:19 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8

[ERROR] Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.7:run (buliding-bars-ant) on project ProjectName: An Ant BuildException has occured: The following error occurred while executing this line:
[ERROR] /home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:7: The following error occurred while executing this line:
[ERROR] /home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:78: exec returned: 1
[ERROR] around Ant part ...<ant antfile="/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml" target="run"/>... @ 5:108 in /home/builduser/builds/ProjectName/InProgress/target/antrun/build-main.xml
[ERROR] -> [Help 1]
org.apache.maven.lifecycle.LifecycleExecutionException: Failed to execute goal org.apache.maven.plugins:maven-antrun-plugin:1.7:run (buliding-bars-ant) on project ProjectName: An Ant BuildException has occured: The following error occurred while executing this line:
/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:7: The following error occurred while executing this line:
/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:78: exec returned: 1
around Ant part ...<ant antfile="/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml" target="run"/>... @ 5:108 in /home/builduser/builds/ProjectName/InProgress/target/antrun/build-main.xml
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:216)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:153)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:145)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:84)
at org.apache.maven.lifecycle.internal.LifecycleModuleBuilder.buildProject(LifecycleModuleBuilder.java:59)
at org.apache.maven.lifecycle.internal.LifecycleStarter.singleThreadedBuild(LifecycleStarter.java:183)
at org.apache.maven.lifecycle.internal.LifecycleStarter.execute(LifecycleStarter.java:161)
at org.apache.maven.DefaultMaven.doExecute(DefaultMaven.java:318)
at org.apache.maven.DefaultMaven.execute(DefaultMaven.java:153)
at org.apache.maven.cli.MavenCli.execute(MavenCli.java:555)
at org.apache.maven.cli.MavenCli.doMain(MavenCli.java:214)
at org.apache.maven.cli.MavenCli.main(MavenCli.java:158)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:95)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
at java.lang.reflect.Method.invoke(Method.java:620)
at org.codehaus.plexus.classworlds.launcher.Launcher.launchEnhanced(Launcher.java:290)
at org.codehaus.plexus.classworlds.launcher.Launcher.launch(Launcher.java:230)
at org.codehaus.plexus.classworlds.launcher.Launcher.mainWithExitCode(Launcher.java:414)
at org.codehaus.plexus.classworlds.launcher.Launcher.main(Launcher.java:357)
Caused by: org.apache.maven.plugin.MojoExecutionException: An Ant BuildException has occured: The following error occurred while executing this line:
/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:7: The following error occurred while executing this line:
/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:78: exec returned: 1
around Ant part ...<ant antfile="/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml" target="run"/>... @ 5:108 in /home/builduser/builds/ProjectName/InProgress/target/antrun/build-main.xml
at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:355)
at org.apache.maven.plugin.DefaultBuildPluginManager.executeMojo(DefaultBuildPluginManager.java:106)
at org.apache.maven.lifecycle.internal.MojoExecutor.execute(MojoExecutor.java:208)
... 19 more
Caused by: /home/builduser/builds/ProjectName/InProgress/target/antrun/build-main.xml:5: The following error occurred while executing this line:
/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:7: The following error occurred while executing this line:
/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:78: exec returned: 1
at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:551)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:444)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:95)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
at java.lang.reflect.Method.invoke(Method.java:620)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.Project.executeTarget(Project.java:1368)
at org.apache.maven.plugin.antrun.AntRunMojo.execute(AntRunMojo.java:327)
... 21 more
Caused by: /home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:7: The following error occurred while executing this line:
/home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:78: exec returned: 1
at org.apache.tools.ant.ProjectHelper.addLocationToBuildException(ProjectHelper.java:551)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:444)
at org.apache.tools.ant.taskdefs.CallTarget.execute(CallTarget.java:105)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.NativeMethodAccessorImpl.invoke0(Native Method)
at sun.reflect.NativeMethodAccessorImpl.invoke(NativeMethodAccessorImpl.java:95)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
at java.lang.reflect.Method.invoke(Method.java:620)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:3
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:442)
... 33 more
Caused by: /home/builduser/builds/ProjectName/InProgress/NotShipped/Installer/build.xml:78: exec returned: 1
at org.apache.tools.ant.taskdefs.ExecTask.runExecute(ExecTask.java:646)
at org.apache.tools.ant.taskdefs.ExecTask.runExec(ExecTask.java:672)
at org.apache.tools.ant.taskdefs.ExecTask.execute(ExecTask.java:498)
at org.apache.tools.ant.UnknownElement.execute(UnknownElement.java:291)
at sun.reflect.GeneratedMethodAccessor38.invoke(Unknown Source)
at sun.reflect.DelegatingMethodAccessorImpl.invoke(DelegatingMethodAccessorImpl.java:56)
at java.lang.reflect.Method.invoke(Method.java:620)
at org.apache.tools.ant.dispatch.DispatchUtils.execute(DispatchUtils.java:106)
at org.apache.tools.ant.Task.perform(Task.java:348)
at org.apache.tools.ant.Target.execute(Target.java:390)
at org.apache.tools.ant.Target.performTasks(Target.java:411)
at org.apache.tools.ant.Project.executeSortedTargets(Project.java:1399)
at org.apache.tools.ant.helper.SingleCheckExecutor.executeTargets(SingleCheckExecutor.java:3
at org.apache.tools.ant.Project.executeTargets(Project.java:1251)
at org.apache.tools.ant.taskdefs.Ant.execute(Ant.java:442)
... 47 more
[ERROR]
[ERROR]
[ERROR] For more information about the errors and possible solutions, please read the following articles:
[ERROR] [Help 1] http://cwiki.apache.org/confluence/display/MAVEN/MojoExecutionException
[ERROR]
[ERROR] After correcting the problems, you can resume the build with the command
[ERROR] mvn <goals> -rf :ProjectName
Back to top
View user's profile Send private message Send e-mail
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 5:27 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8

Back to top
View user's profile Send private message Send e-mail
fjb_saper
PostPosted: Fri Aug 07, 2020 5:32 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20421
Location: LI,NY

Apparently you need to install X11 (cue the DISPLAY variable) and have an X11 server ready to catch the display...
Remember, even though it's headless mqsicreatebar runs eclipse and as such you'd better have a display to catch it...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 5:55 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8

Post X11 installation, setting X11Forwarding yes and restarting sshd on /iib-10.0.0.10/tools/

Now getting this when I run mqsicreatebar command

mqsicreatebar -data /home/builduser/builds/ProjectName/InProgress -b /home/builduser/builds/ProjectName/InProgress/ProjectName.bar -p ProjectName emb logging sharedESQL ProjectNameJava loggingJava -o ProjectNameJava/.classpath loggingJava/.classpath ProjectName/1.msgflow ProjectName/2.msgflow ProjectName/3.msgflow -l AsyncModel BundleModel -trace -v /home/builduser/builds/ProjectName/InProgress/buildBAR.log -cleanBuild -deployAsSource | tee /home/builduser/bin/check.log
Command log file is set to: /home/builduser/builds/ProjectName/InProgress/buildBAR.log
BIP0960E Incorrect "-a", "-l", "-p", or "-o" argument supplied to mqsicreatebar.

Project directory "BundleModel" does not exist.


Job found still running after platform shutdown. Jobs should be canceled by the plugin that scheduled them during shutdown: com.ibm.etools.mft.node.NodeToolingPlugin$RemainingInitializationJob


However under /home/builduser/builds/ProjectName/InProgress the BundleModel is present

drwxrwxr-x 4 builduser builduser 188 Aug 7 06:49 AsyncModel
drwxrwxr-x 4 builduser builduser 37 Aug 7 06:49 BundleModel
Back to top
View user's profile Send private message Send e-mail
Vitor
PostPosted: Fri Aug 07, 2020 6:05 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 26074
Location: Texas, USA

m.kamalakshi.88 wrote:


Now getting this when I run mqsicreatebar command

mqsicreatebar -data /home/builduser/builds/ProjectName/InProgress -b /home/builduser/builds/ProjectName/InProgress/ProjectName.bar -p ProjectName emb logging sharedESQL ProjectNameJava loggingJava -o ProjectNameJava/.classpath loggingJava/.classpath ProjectName/1.msgflow ProjectName/2.msgflow ProjectName/3.msgflow -l AsyncModel BundleModel -trace -v /home/builduser/builds/ProjectName/InProgress/buildBAR.log -cleanBuild -deployAsSource | tee /home/builduser/bin/check.log


I so hope you have that automated.


m.kamalakshi.88 wrote:
BIP0960E Incorrect "-a", "-l", "-p", or "-o" argument supplied to mqsicreatebar.

Project directory "BundleModel" does not exist.


Well that seems clear.

m.kamalakshi.88 wrote:

However under /home/builduser/builds/ProjectName/InProgress the BundleModel is present

drwxrwxr-x 4 builduser builduser 188 Aug 7 06:49 AsyncModel
drwxrwxr-x 4 builduser builduser 37 Aug 7 06:49 BundleModel


So the first obvious thought is that the command isn't looking there.

Why (I ask disinterestedly) do the vast majority of other parameters explicitly quote the /home/builduser/builds..... path but that parameter does not? What criteria are you applying as to when you specify the full path and when you make the command search?
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 6:11 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8

BundleModel is the new swagger reference library project.
AsyncModel is the existing XML reference library project.

Its able to refer AsyncModel then why not BundleModel.


Updated the full path now getting

mqsicreatebar -data /home/builduser/builds/ProjectName/InProgress -b /home/builduser/builds/ProjectName/InProgress/ProjectName.bar -p ProjectName emb logging sharedESQL ProjectNameJava loggingJava -o ProjectNameJava/.classpath loggingJava/.classpath ProjectName/1.msgflow ProjectName/2.msgflow ProjectName/3.msgflow -l AsyncModel /home/builduser/builds/ProjectName/InProgress/BundleModel -trace -v /home/builduser/builds/ProjectName/InProgress/buildBAR.log -cleanBuild -deployAsSource | tee /home/builduser/bin/check.log
Command log file is set to: /home/builduser/builds/ProjectName/InProgress/buildBAR.log
BIP0960E Incorrect "-a", "-l", "-p", or "-o" argument supplied to mqsicreatebar.

Project directory "home" does not exist.


Job found still running after platform shutdown. Jobs should be canceled by the plugin that scheduled them during shutdown: com.ibm.etools.mft.node.NodeToolingPlugin$RemainingInitializationJob


And under /home/builduser/builds/ProjectName/InProgress
drwxrwxr-x 4 builduser builduser 188 Aug 7 06:49 AsyncModel
drwxrwxr-x 4 builduser builduser 37 Aug 7 06:49 BundleModel
Back to top
View user's profile Send private message Send e-mail
Vitor
PostPosted: Fri Aug 07, 2020 6:30 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 26074
Location: Texas, USA

m.kamalakshi.88 wrote:
Updated the full path now getting

...

BIP0960E Incorrect "-a", "-l", "-p", or "-o" argument supplied to mqsicreatebar.

Project directory "home" does not exist.


So, just to be clear, when you added the fully qualified path to the object it couldn't find, suddenly it could find it?

What does that, combined with the fact it's now looking for a directory called "home" it can't find, tell you about your runtime environment?
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
m.kamalakshi.88
PostPosted: Fri Aug 07, 2020 6:56 am Post subject: Reply with quote

Newbie

Joined: 07 Aug 2020
Posts: 8



Setting project property: env.HISTSIZE -> 1000
Setting project property: env.LOGNAME -> builduser
Setting project property: env.HOME -> /home/builduser
Setting project property: env.LS_COLORS -> rs=0:di=01;34:ln=01;36:mh=00:pi=40;33:so=01;35:do=01;35:bd=40;33;01:cd=40;33;01:or=40;31;01:mi=01;05;37;41:su=37;41:sg=30;43:ca=30;41:tw=30;42:ow=34;42:st=37;44:ex=01;32:*.tar=01;31:*.tgz=01;31:*.arc=01;31:*.arj=01;31:*.taz=01;31:*.lha=01;31:*.lz4=01;31:*.lzh=01;31:*.lzma=01;31:*.tlz=01;31:*.txz=01;31:*.tzo=01;31:*.t7z=01;31:*.zip=01;31:*.z=01;31:*.Z=01;31:*.dz=01;31:*.gz=01;31:*.lrz=01;31:*.lz=01;31:*.lzo=01;31:*.xz=01;31:*.bz2=01;31:*.bz=01;31:*.tbz=01;31:*.tbz2=01;31:*.tz=01;31:*.deb=01;31:*.rpm=01;31:*.jar=01;31:*.war=01;31:*.ear=01;31:*.sar=01;31:*.rar=01;31:*.alz=01;31:*.ace=01;31:*.zoo=01;31:*.cpio=01;31:*.7z=01;31:*.rz=01;31:*.cab=01;31:*.jpg=01;35:*.jpeg=01;35:*.gif=01;35:*.bmp=01;35:*.pbm=01;35:*.pgm=01;35:*.ppm=01;35:*.tga=01;35:*.xbm=01;35:*.xpm=01;35:*.tif=01;35:*.tiff=01;35:*.png=01;35:*.svg=01;35:*.svgz=01;35:*.mng=01;35:*.pcx=01;35:*.mov=01;35:*.mpg=01;35:*.mpeg=01;35:*.m2v=01;35:*.mkv=01;35:*.webm=01;35:*.ogm=01;35:*.mp4=01;35:*.m4v=01;35:*.mp4v=01;35:*.vob=01;35:*.qt=01;35:*.nuv=01;35:*.wmv=01;35:*.asf=01;35:*.rm=01;35:*.rmvb=01;35:*.flc=01;35:*.avi=01;35:*.fli=01;35:*.flv=01;35:*.gl=01;35:*.dl=01;35:*.xcf=01;35:*.xwd=01;35:*.yuv=01;35:*.cgm=01;35:*.emf=01;35:*.axv=01;35:*.anx=01;35:*.ogv=01;35:*.ogx=01;35:*.aac=01;36:*.au=01;36:*.flac=01;36:*.mid=01;36:*.midi=01;36:*.mka=01;36:*.mp3=01;36:*.mpc=01;36:*.ogg=01;36:*.ra=01;36:*.wav=01;36:*.axa=01;36:*.oga=01;36:*.spx=01;36:*.xspf=01;36:
Setting project property: env.PATH -> /opt/ibm/mqsi/iib-10.0.0.10/common/jdk/bin:/home/builduser/installables/apache-maven-3.1.0/bin:/usr/local/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/opt/ibm/mqsi/iib-10.0.0.7/common/jdk/jre/bin:/home/builduser/.local/bin:/home/builduser/bin:/usr/lib64/qt-3.3/bin:/usr/local/bin:/bin:/usr/bin:/usr/local/sbin:/usr/sbin:/sbin:/opt/IBM/apache-maven-2.2.1/bin:/home/builduser/bin:.:/opt/IBM/SDPShared/plugins
Setting project property: env.LESSOPEN -> ||/usr/bin/lesspipe.sh %s
Setting project property: env.SSH_TTY -> /dev/pts/1
Setting project property: env.M2 -> /home/builduser/installables/apache-maven-3.1.0/bin
Setting project property: env.PWD -> /home/builduser/builds/ProjectName/InProgress
Setting project property: env.XDG_SESSION_ID -> 9
Setting project property: env.USER -> builduser
Setting project property: env.SHLVL -> 2
Setting project property: env.SHELL -> /bin/bash
Setting project property: env.JAVA_HOME -> /opt/ibm/mqsi/iib-10.0.0.10/common/jdk
Setting project property: env.XDG_RUNTIME_DIR -> /run/user/1001
Setting project property: env.MAIL -> /var/spool/mail/builduser
Setting project property: env.M2_HOME -> /home/builduser/installables/apache-maven-3.1.0
Setting project property: env.TERM -> xterm
Setting project property: env.HISTCONTROL -> ignoredups
Setting project property: env.LANG -> en_US.UTF-8
Setting project property: env.IBM_JAVA_COMMAND_LINE -> /opt/ibm/mqsi/iib-10.0.0.10/common/jdk/bin/java -classpath /home/builduser/installables/apache-maven-3.1.0/boot/plexus-classworlds-2.4.2.jar -Dclassworlds.conf=/home/builduser/installables/apache-maven-3.1.0/bin/m2.conf -Dmaven.home=/home/builduser/installables/apache-maven-3.1.0 org.codehaus.plexus.classworlds.launcher.Launcher -U -X clean install
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker Supporton IIB 10.0.0.7, createbar is failing
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.