ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB not making connection to Linux file

Post new topicReply to topic Goto page Previous  1, 2
IIB not making connection to Linux file View previous topic :: View next topic
Author Message
Vitor
PostPosted: Wed Apr 29, 2020 6:55 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25978
Location: Texas, USA

syedimtiyaz1234 wrote:
I could not understand "see the ProcessId broker property to make the file name unique to each EG"


That's a link I expected you to click on.

syedimtiyaz1234 wrote:
it just shows me one process id connected to this file


Of course it does.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
syedimtiyaz1234
PostPosted: Wed Apr 29, 2020 8:51 am Post subject: Reply with quote

Novice

Joined: 22 Jan 2018
Posts: 24

is there any way we know by which Userid this broker or EG has access to. Is there any commands that i can run to see.

yes i opened that linked but do we need to update the flow and on file name having Pid on the file name
Back to top
View user's profile Send private message
Vitor
PostPosted: Wed Apr 29, 2020 12:36 pm Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25978
Location: Texas, USA

syedimtiyaz1234 wrote:
is there any way we know by which Userid this broker or EG has access to. Is there any commands that i can run to see.


I thought we'd eliminated permission problems.

An ls-a will show you the user id.

syedimtiyaz1234 wrote:
yes i opened that linked but do we need to update the flow and on file name having Pid on the file name


Yes, but I'm suggesting you do it as a temporary, problem investigating measure.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
syedimtiyaz1234
PostPosted: Thu Apr 30, 2020 11:10 am Post subject: Reply with quote

Novice

Joined: 22 Jan 2018
Posts: 24

If i understand what you are asking , this is just to rule out that file is not getting access by 2 instance.

i have tried to point to another directory having all access by doing so, that directory will have access of only one instance of that message flow from that integration Server.

So its the same what you are suggesting to create file with having PID(of that Integration Server) and in Message flow i point to that particular file.
Back to top
View user's profile Send private message
Vitor
PostPosted: Thu Apr 30, 2020 12:29 pm Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25978
Location: Texas, USA

syedimtiyaz1234 wrote:
So its the same what you are suggesting to create file with having PID(of that Integration Server) and in Message flow i point to that particular file.


No it isn't. If the flow is configured to point to a given directory / file name, all instances of that will use the same configuration and file names no matter which EG they're running in.

If the file name include the PID of the running EG, you're guaranteed unqiueness.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
syedimtiyaz1234
PostPosted: Fri May 01, 2020 6:10 am Post subject: Reply with quote

Novice

Joined: 22 Jan 2018
Posts: 24

so this is what i did,

i create one new file with _{PID} of executionGrp(gave all permission)

and in Message Flow , in Trace Node, i edited the file Path and added _{PID}.txt

here {PID} is the actual process Id of that EG.

But still not luck and only this Instance of flow is deployed on this Integration Node.
Back to top
View user's profile Send private message
Vitor
PostPosted: Fri May 01, 2020 6:37 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25978
Location: Texas, USA

Then it's clearly broken & a PMR is your next action.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
syedimtiyaz1234
PostPosted: Mon May 04, 2020 7:34 am Post subject: Reply with quote

Novice

Joined: 22 Jan 2018
Posts: 24

and more thing we noticed so just wanted to put here if anyone can think about it.

we have 6-7 Integration servers and some were old created and few were recenty created.

the Application is only able to log when deployed to new EGs and not the old ones.
Back to top
View user's profile Send private message
syedimtiyaz1234
PostPosted: Thu May 14, 2020 5:29 am Post subject: Reply with quote

Novice

Joined: 22 Jan 2018
Posts: 24

we found the issue.

The Trace node was disabled for those Integration servers.

mqsireporttrace <broker> -e <IntegartionServer> -n

BIP8871I: Integration server: ******** has trace nodes: off for its message flows.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Goto page Previous  1, 2 Page 2 of 2

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB not making connection to Linux file
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.