ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportODBC Datasource Issue in Linux?

Post new topicReply to topic
ODBC Datasource Issue in Linux? View previous topic :: View next topic
Author Message
junaid
PostPosted: Thu Oct 24, 2019 9:41 pm Post subject: ODBC Datasource Issue in Linux? Reply with quote

Acolyte

Joined: 29 Nov 2018
Posts: 53

I have used DBInput node for connection polling everything is working smoothly while development on windows machine. But after deploying on Linux taking abnormal behavior while running ( while Polling ) system got hangs and high CPU utilization but same senario is working smoothly on windows.

Is ODBC stable and production ready at linux ? Are we missing any configuration related things for configuring odbc data-source at linux.
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon Nov 04, 2019 7:00 am Post subject: Re: ODBC Datasource Issue in Linux? Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25856
Location: Texas, USA

junaid wrote:
Is ODBC stable and production ready at linux ?


If you're using the IBM supplied ODBC drivers, yes.

junaid wrote:
Are we missing any configuration related things for configuring odbc data-source at linux.


Given that it's not working, that would be my guess. But since you've said nothing about how you've configured it, it's just a guess.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
junaid
PostPosted: Thu Nov 07, 2019 3:40 am Post subject: ODBC Datasource Issue in Linux? Reply with quote

Acolyte

Joined: 29 Nov 2018
Posts: 53

Issue has been resolved.
In odbc.ini file "DRIVER=/u01/esbuser/ibm/db2/V11.1/lib64/libdb2.so"
32 bit i.e. (llibdb2.so)driver was used in odbc.ini file on Linux instead of 64 bit i.e. (llibdb2o.so)
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportODBC Datasource Issue in Linux?
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.