ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportMessages stalled on XMITQ

Post new topicReply to topic Goto page 1, 2, 3  Next
Messages stalled on XMITQ View previous topic :: View next topic
Author Message
matth
PostPosted: Fri Sep 27, 2019 11:02 am Post subject: Messages stalled on XMITQ Reply with quote

Apprentice

Joined: 13 Feb 2007
Posts: 40
Location: Brazil

Hi:

I have an MQSeries 8.0.0.0 running on Windows server. In some XMITQ queues current depth shows some (circa 10) messages which are stalled. They are strange because channel sender/receiver still running and all other messages runs well (dozens/day).

I browse some messages and they seens to be reply-to-queue COD/COA messages and Message Identifier Column seens to be corrupt.


[img]https://uploaddeimagens.com.br/imagens/mqseries-png[/img]

Regards
Back to top
View user's profile Send private message
bruce2359
PostPosted: Fri Sep 27, 2019 12:39 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8531
Location: US: west coast, almost. Otherwise, enroute.

I believe you are looking at the transmission queue header (XQH).

When an app MQPUTs a message to a transmission queue, the qmgr inserts an XQH into the package put to the xmit queue. The XQH has its own MQMD and Rname and RQMname - the destination of the message, along with your apps MQMD and data payload.

The xqh is used for routing purposes. The CorrelId of the XQH identifies the destination where the msg will be delivered. Looks ok to me. Look further into the message to see your app MQMD and data.

A likely possibility why the msgs have not been transmitted is that the MQPUTting app has not yet committed the mags in the UofW.
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
gbaddeley
PostPosted: Sun Sep 29, 2019 4:20 pm Post subject: Re: Messages stalled on XMITQ Reply with quote

Jedi

Joined: 25 Mar 2003
Posts: 2039
Location: Melbourne, Australia

matth wrote:
Hi:
I have an MQSeries 8.0.0.0 running on Windows server. In some XMITQ queues current depth shows some (circa 10) messages which are stalled. They are strange because channel sender/receiver still running and all other messages runs well (dozens/day).
I browse some messages and they seens to be reply-to-queue COD/COA messages and Message Identifier Column seens to be corrupt.
[img]https://uploaddeimagens.com.br/imagens/mqseries-png[/img]
Regards

The image is blocked, I can't view it. What makes you think the msg id is corrupt? The sender MCA does not actually use this field when sending a msg. What is in the MQXQH for these msgs?

If it bothers you, stop the channel, get enable the queue, move the msgs to a backup queue for close analysis, and start the channel.
_________________
Glenn
Back to top
View user's profile Send private message
bruce2359
PostPosted: Sun Sep 29, 2019 5:56 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8531
Location: US: west coast, almost. Otherwise, enroute.

matth: Please display a few messages using supplied utility amqsbcg. I'm interested in the MQMD and XQH that precedes your data (MQMD, other headers, your app data payload.
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
matth
PostPosted: Mon Sep 30, 2019 11:46 am Post subject: Reply with quote

Apprentice

Joined: 13 Feb 2007
Posts: 40
Location: Brazil

Hi Guys:

I believe they are corrupted, because are composed from non printable characters. I tried to copy-paste it here, but forum config (!?!) blocks it. I tried to use print-screen, but I believe made something wrong. Ill try another way soon.
Back to top
View user's profile Send private message
matth
PostPosted: Mon Sep 30, 2019 12:11 pm Post subject: Reply with quote

Apprentice

Joined: 13 Feb 2007
Posts: 40
Location: Brazil

(The image server seens to be up (now))
Back to top
View user's profile Send private message
hughson
PostPosted: Mon Sep 30, 2019 1:48 pm Post subject: Reply with quote

Grand Master

Joined: 09 May 2013
Posts: 1282
Location: Bay of Plenty, New Zealand

matth wrote:
I believe they are corrupted, because are composed from non printable characters. I tried to copy-paste it here, but forum config (!?!) blocks it. I tried to use print-screen, but I believe made something wrong. I'll try another way soon.

The image you posted only shows non-printable characters in the Correlation identifier.



The Correlation identifier field is not actually a string field, it is a bytes field, and so non-printable characters are to be expected when trying to display this field as a string. A little to the right of the column in question is the bytes display of the same field. Look in there to view all the bytes that make up the Correlation identifier and you will understand why some are non-printable.

To reiterate, this is not corruption, this is normal behaviour for generated Correlation identifiers.

Cheers,
Morag
_________________
Morag Hughson @MoragHughson
IBM MQ Technical Education Specialist
Get your IBM MQ training here!
MQGem Software
Back to top
View user's profile Send private message Visit poster's website
matth
PostPosted: Tue Oct 01, 2019 2:50 am Post subject: Reply with quote

Apprentice

Joined: 13 Feb 2007
Posts: 40
Location: Brazil

Ok, but returning to original question. Why these messages stay on XMITQ? What may I look to identify message problem?
Back to top
View user's profile Send private message
HubertKleinmanns
PostPosted: Tue Oct 01, 2019 3:14 am Post subject: Reply with quote

Shaman

Joined: 24 Feb 2004
Posts: 724
Location: Germany

matth wrote:
Ok, but returning to original question. Why these messages stay on XMITQ? What may I look to identify message problem?


As bruce2359 already asked: Please display a few messages using supplied utility amqsbcg.
_________________
Regards
Hubert
Back to top
View user's profile Send private message Visit poster's website
bruce2359
PostPosted: Tue Oct 01, 2019 5:46 am Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8531
Location: US: west coast, almost. Otherwise, enroute.

Also, display the xmitq. What is the value of UNCOM?
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
matth
PostPosted: Tue Oct 01, 2019 10:28 am Post subject: Reply with quote

Apprentice

Joined: 13 Feb 2007
Posts: 40
Location: Brazil

bruce2359 wrote:
Also, display the xmitq. What is the value of UNCOM?

What means UNCOM? Is it a property of Queue? Message? Queue Status?

[]s
Back to top
View user's profile Send private message
bruce2359
PostPosted: Tue Oct 01, 2019 10:35 am Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8531
Location: US: west coast, almost. Otherwise, enroute.

matth wrote:
bruce2359 wrote:
Also, display the xmitq. What is the value of UNCOM?

What means UNCOM? Is it a property of Queue? Message? Queue Status?

[]s

Queue status. Whether or not there are uncommitted messages in the xmit queue. Messages put to a queue in UofWs must be committed before they can be sent down the channel.
https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_8.0.0/com.ibm.mq.ref.adm.doc/q086260_.htm
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
matth
PostPosted: Wed Oct 02, 2019 6:08 am Post subject: Reply with quote

Apprentice

Joined: 13 Feb 2007
Posts: 40
Location: Brazil

I may ask for amqsbcg of trouble queue, but if I post here, forum blocks it because content have special chars.

Att,
Back to top
View user's profile Send private message
matth
PostPosted: Wed Oct 02, 2019 6:09 am Post subject: Reply with quote

Apprentice

Joined: 13 Feb 2007
Posts: 40
Location: Brazil

matth wrote:
I may ask for amqsbcg of trouble queue, but if I post here, forum blocks it because content have special chars.

Att,


Uncommited Messages: No
Back to top
View user's profile Send private message
bruce2359
PostPosted: Wed Oct 02, 2019 6:12 am Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8531
Location: US: west coast, almost. Otherwise, enroute.

matth wrote:
I may ask for amqsbcg of trouble queue, but if I post here, forum blocks it because content have special chars.

Att,

How does the forum block you? Is there an error message?

How are you posting the output from amqsbcg? Copy and paste text? Screen scrape? Something else? AFIK, mqseries.net doesnt impose character restrictions. Please use text copy and paste.
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Goto page 1, 2, 3  Next Page 1 of 3

MQSeries.net Forum IndexGeneral IBM MQ SupportMessages stalled on XMITQ
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.