ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportJson to XML transformation issue - Procedure calling procedu

Post new topicReply to topic
Json to XML transformation issue - Procedure calling procedu View previous topic :: View next topic
Author Message
amr89
PostPosted: Thu Jun 27, 2019 2:25 am Post subject: Json to XML transformation issue - Procedure calling procedu Reply with quote

Novice

Joined: 08 Feb 2011
Posts: 16

Hi Folks,
We have a requirement to transform Json to XML message . The json request consists of json array elements and child list items(like list array within list ) . All these have to be transformed to xml accordingly . We are following procedure calling itself approach to traverse and construct xml.
Once we restart Integration server and trigger message for first time message flow gives xml which have many repetitions of input list items . But transformation works fine without any issue from second time or so..

Wanted to understand why message flow behaves like this . your help is much appreciated.

Msgflow have : MQ Input Node -> compute Node ->MQ Output Node .

Software Version : IIB V10.0.0.9
MQ V8.0.0.9
Back to top
View user's profile Send private message
timber
PostPosted: Thu Jun 27, 2019 3:16 am Post subject: Reply with quote

Grand Master

Joined: 25 Aug 2015
Posts: 1017

The information you have given could be restated like this:
- The message flow receives a recursive JSON document
- The JSON needs to be converted to XML with exactly the same structure as the input JSON
- The transformation logic is implemented as a set of recursive ESQL procedure calls
- It doesn't work the first time after a restart, but usually works fine after that.

That is not enough information to diagnose the problem. Please supply the missing information.
Back to top
View user's profile Send private message
amr89
PostPosted: Thu Jun 27, 2019 3:33 am Post subject: Reply with quote

Novice

Joined: 08 Feb 2011
Posts: 16

Hi Timber ,
Thanks for response . May I know what information you are expecting ...
Back to top
View user's profile Send private message
timber
PostPosted: Thu Jun 27, 2019 4:44 am Post subject: Reply with quote

Grand Master

Joined: 25 Aug 2015
Posts: 1017

I was hoping that you could work that out for yourself (or at least some of it). Do you think you would be able to propose a fix based on that information?

I suggest that you tell us what the correct output looks like, what the incorrect output looks like, and at least some information about the ESQL.
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Thu Jun 27, 2019 10:35 pm Post subject: Reply with quote

Master

Joined: 17 Jul 2017
Posts: 298
Location: UK

hi...assuming you are using the same input message for both attempts I would suggest collecting the flow user traces and compare it to see the differences (that should indicate whether the flow is taking a different code path for the first attempt which you can then dig further)
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportJson to XML transformation issue - Procedure calling procedu
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.