ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportBIP3602E error on SOAP call

Post new topicReply to topic
BIP3602E error on SOAP call View previous topic :: View next topic
Author Message
petervh1
PostPosted: Fri Jun 07, 2019 2:54 am Post subject: BIP3602E error on SOAP call Reply with quote

Acolyte

Joined: 19 Apr 2010
Posts: 51

I am trying a basic web services call using the following data:

Code:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <RetreiveImages xmlns="http://tempuri.org/">
         <sMode>N</sMode><sUserID>IJS</sUserID>
         <sMachineID>IJS</sMachineID>
         <sIDN>9703275447084</sIDN>
         <sFunction>16</sFunction>
         <sSubFunction>00</sSubFunction>
         <sImageFlags>NNYN</sImageFlags>
      </RetreiveImages>
   </soap:Body>
</soap:Envelope>


The snippet of my WSDL is:
Code:

<wsdl:binding name="LiveCaptureIJSHttpBinding" type="tns:LiveCaptureIJS">
        <soap:binding style="document" transport="http://schemas.xmlsoap.org/soap/http"/>
        <wsdl:operation name="RetreiveImages">
      <soap:operation soapAction="http://tempuri.org/"/>
      <wsdl:input name="RetreiveImages">
        <soap:body use="literal"/>
      </wsdl:input>
      <wsdl:output name="RetreiveImagesResponse">
        <soap:body use="literal"/>
      </wsdl:output>
    </wsdl:operation>
    </wsdl:binding>


I get the following error:
Code:

<soapenv:Envelope xmlns:soapenv="http://schemas.xmlsoap.org/soap/envelope/">
   <soapenv:Body>
      <soapenv:Fault>
         <faultcode>soapenv:Server</faultcode>
         <faultstring>BIP3113E: Exception detected in message flow gen.LiveCaptureIJS.SOAP Input (integration node TESTNODE_Peter)</faultstring>
         <detail>
            <Text>BIP3749E: The SOAP Input node 'gen.LiveCaptureIJS.SOAP Input' encountered an error while validating an inbound message.
An internal error occurred during message validation.
See previous error messages to determine the cause of the error. : F:\build\S1000_slot1\S1000_P\src\WebServices\WSLibrary\ImbSOAPInputNode.cpp: 1197: ImbSOAPInputNode::validateData: ComIbmSOAPInputNode: gen/LiveCaptureIJS#FCMComposite_1_1
BIP3614E: A SOAP logical tree cannot be built from the message bitstream.
The bitstream is not a valid Web service message.
Review further error messages for an indication to the cause of the error. : F:\build\S1000_slot1\S1000_P\src\WebServices\WSLibrary\ImbSOAPParser.cpp: 2196: ImbSOAPParser::createSoapShapedTree: :
BIP3602E: The Web service payload ''{http://tempuri.org/}RetreiveImages'' does not match an operation described by WSDL binding ''LiveCaptureIJSHttpBinding'' in file ''LiveCaptureIJS.wsdl''.
The first child of the SOAP Body does not correspond to any of the operations defined in the specified WSDL definition.
Check that the correct WSDL definition was deployed. : F:\build\S1000_slot1\S1000_P\src\WebServices\WSLibrary\ImbSOAPParser.cpp: 1927: ImbSOAPParser::createSoapShapedTree: :</Text>
         </detail>
      </soapenv:Fault>
   </soapenv:Body>
</soapenv:Envelope>


I'm sure there's a basic error somewhere, but I can't seem to find it.

Thanks in advance
Back to top
View user's profile Send private message
petervh1
PostPosted: Mon Jun 10, 2019 3:26 am Post subject: Reply with quote

Acolyte

Joined: 19 Apr 2010
Posts: 51

I have made some progress, in that I can now call the operation successfully. However this only works if my data is as follows:
Code:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:tns1="http://LiveCaptureIJS" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <tns1:RetreiveImages>
         <sMode>N</sMode>
         <sUserID>IJS</sUserID>
         <sMachineID>IJS</sMachineID>
         <sIDN>9703275447084</sIDN>
         <sFunction>16</sFunction>
         <sSubFunction>00</sSubFunction>
         <sImageFlags>NNYN</sImageFlags>
      </tns1:RetreiveImages>
   </soap:Body>
</soap:Envelope>

That is - no attribute on the RetreiveImages element. I need to be able to call the operation where my XML is as follows:
Code:

<?xml version="1.0" encoding="utf-8"?>
<soap:Envelope xmlns:soap="http://schemas.xmlsoap.org/soap/envelope/" xmlns:xsi="http://www.w3.org/2001/XMLSchema-instance" xmlns:xsd="http://www.w3.org/2001/XMLSchema">
   <soap:Body>
      <RetreiveImages xmlns="http://tempuri.org/">
         <sMode>N</sMode><sUserID>IJS</sUserID>
         <sMachineID>IJS</sMachineID>
         <sIDN>9703275447084</sIDN>
         <sFunction>16</sFunction>
         <sSubFunction>00</sSubFunction>
         <sImageFlags>NNYN</sImageFlags>
      </RetreiveImages>
   </soap:Body>
</soap:Envelope>
Back to top
View user's profile Send private message
timber
PostPosted: Mon Jun 10, 2019 4:45 am Post subject: Reply with quote

Guardian

Joined: 25 Aug 2015
Posts: 984

That is not an attribute - it is a namespace declaration. Sounds as if your WSDL is incorrect. It does not describe the namespace in the required SOAP request.

Please don't ask me to explain in detail - the web is full of information about XML namespaces and SOAP/WSDL.
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon Jun 10, 2019 5:17 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25671
Location: Ohio, USA

timber wrote:
Please don't ask me to explain in detail - the web is full of information about XML namespaces and SOAP/WSDL.


I'll explain briefly, and you're welcome.

The example you post that works says the RetrieveImages element is in the http://LiveCaptureIJS namespace. The example you post that fails say the element is in the http://tempuri.org namespace.

The WSDL you posted says that element in the http://LiveCaptureIJS namespace, which would seem to explain why it's working.

Hence the comment from my worthy associate:

Quote:
Sounds as if your WSDL is incorrect.


I endorse this comment.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
petervh1
PostPosted: Mon Jun 10, 2019 5:52 am Post subject: Reply with quote

Acolyte

Joined: 19 Apr 2010
Posts: 51

Thanks Vitor.

I'm not sure where to change the namespace info in the WSDL.

If I use the "Start by creating an integration service..." wizard, the Namespace value is automatically set to http://RetreiveImagesIJS. I'm assuming I'd need to change the info in the WSDL once the wizard has completed.
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon Jun 10, 2019 5:58 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25671
Location: Ohio, USA

petervh1 wrote:
I'm not sure where to change the namespace info in the WSDL.


I again echo the comments of my worthy associate:

Quote:
the web is full of information about XML namespaces and SOAP/WSDL.


You could also ask whoever's sending the message to fix it. Conceptually, the WSDL describes the message the SOAP endpoint is expecting and is published through one of a number of possible mechanisms to consumers. The broker parser is entirely accurate when it's throwing an error saying the message it's receiving doesn't match any in the WSDL.

This leads us to a wider question around who authored the WSDL, it's connection to the message producers and a lot of political stuff that's not relevant here. I mention it only because if you edit the WSDL so it matches this consumers message, you need to make sure anyone currently using that WSDL to send you messages changes to the new (edited) one or their messages will fail and you're back where you started.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
timber
PostPosted: Mon Jun 10, 2019 7:12 am Post subject: Reply with quote

Guardian

Joined: 25 Aug 2015
Posts: 984

Quote:
I'm not sure where to change the namespace info in the WSDL
Fair enough - we all have to start somewhere. Your next step is to do some learning, and understand how WSDL works. Then you will understand Vitor's answer - maybe the WSDL is correct, and the input message is wrong.

Summary: You cannot develop an integration solution by randomly changing settings until it 'works'.
Back to top
View user's profile Send private message
petervh1
PostPosted: Mon Jun 10, 2019 9:06 am Post subject: Reply with quote

Acolyte

Joined: 19 Apr 2010
Posts: 51

Thanks to timber and Vitor for pointing out the mismatch. I believe the WSDL is correct as it stands, and that the user's message will need to be changed.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportBIP3602E error on SOAP call
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.