ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportUnreadable format after moving DLQ message to local queue

Post new topicReply to topic
Unreadable format after moving DLQ message to local queue View previous topic :: View next topic
Author Message
limboonlee
PostPosted: Sun Apr 07, 2019 11:33 pm Post subject: Unreadable format after moving DLQ message to local queue Reply with quote

Novice

Joined: 29 Apr 2009
Posts: 12

Hi all, need your help.

I made a mistake in the XMITQ name of a remote queue, and the messages sent to this remote queue ended up in the DLQ with the reason DLQ:Reason(Unknown Xmit queue). While in the DLQ, the Format is MQREAD.

I used MO71 to move the messages to a temporary local queue, using the "load/unload messages" and checking the "Strip headers" checkbox. Messages can be moved to the temp local queue but the Format is now some unreadable characters.

This is on MainFrame MQ9.0.

And when I send these messages to midrange queue, the application is not able to read the messages.

Should the Format be something like MQSTR? If yes, anyway to go about changing the format?

Thank you.
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Mon Apr 08, 2019 12:21 am Post subject: Reply with quote

Master

Joined: 17 Jul 2017
Posts: 275
Location: UK

hi...when you used MO71 with 'Strip headers' won't it remove the legitimate outbound MQMD as well which may have some downstream impact (eg:- Encoding/ccsid values getting reset)

Ideally only the Deadletter header should be removed from the message, have you looked at using the Dead letter handler,

https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.0.0/com.ibm.mq.ref.adm.doc/q089000_.htm
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Mon Apr 08, 2019 4:06 pm Post subject: Reply with quote

Guardian

Joined: 17 Nov 2005
Posts: 941
Location: New Zealand

Hi,

What version of MO71 are you using ? If it is a recent one then we can certainly look at helping you. When headers are stripped from a DLQ you should still end up with a consistent message.

Of course remember that you can always just unload the message to a file, edit the message using your favourite editor (and this could be the format field) and then load the message back up again if things have gone awry.

Cheers,
Paul.
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
limboonlee
PostPosted: Mon Apr 08, 2019 10:39 pm Post subject: Reply with quote

Novice

Joined: 29 Apr 2009
Posts: 12

PaulClarke wrote:
Hi,

What version of MO71 are you using ? If it is a recent one then we can certainly look at helping you. When headers are stripped from a DLQ you should still end up with a consistent message.

Of course remember that you can always just unload the message to a file, edit the message using your favourite editor (and this could be the format field) and then load the message back up again if things have gone awry.

Cheers,
Paul.


I am using 9.0.6. Yes, I have the message after I strip the header, but due to the format been some unreadable characters, when I load back the message to the eventual destination queue, the application is not picking up the message. Hmmmm........ I may have missed out something. I didn't ask the app team to try to pick up the messages, so it might work with the unreadable format.

Hahaha. Didn't cross my mind that it can be done this way. Thanks.


Last edited by limboonlee on Mon Apr 08, 2019 10:44 pm; edited 1 time in total
Back to top
View user's profile Send private message
limboonlee
PostPosted: Mon Apr 08, 2019 10:40 pm Post subject: Reply with quote

Novice

Joined: 29 Apr 2009
Posts: 12

abhi_thri wrote:
hi...when you used MO71 with 'Strip headers' won't it remove the legitimate outbound MQMD as well which may have some downstream impact (eg:- Encoding/ccsid values getting reset)

Ideally only the Deadletter header should be removed from the message, have you looked at using the Dead letter handler,

https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.0.0/com.ibm.mq.ref.adm.doc/q089000_.htm


Thanks for the reply. Manage to strip the DLQ Header using the handler.
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Mon Apr 08, 2019 10:44 pm Post subject: Reply with quote

Guardian

Joined: 17 Nov 2005
Posts: 941
Location: New Zealand

Well, 9.0.6 isn't quite the latest version of MO71. I suggest you download the latest and try again. Apart from anything else there are a number of new features you might find useful. If you still find (or believe) that MO71 is not doing the right thing for this particular message then please take a qload unload of the message before and after and send it to support@mqgem.com and we'll look into whether the format field is not being transferred correctly.

Cheers,
Paul.
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ SupportUnreadable format after moving DLQ message to local queue
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.