ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ Supportqload missing one AMS message

Post new topicReply to topic
qload missing one AMS message View previous topic :: View next topic
Author Message
KIT_INC
PostPosted: Thu Mar 21, 2019 6:41 am Post subject: qload missing one AMS message Reply with quote

Knight

Joined: 25 Aug 2006
Posts: 581

I know that qload is no longer supported. But just curious if anyone has seen this also. MQ is V7.5.
I have 7 AMS protected message on BKUP queue

Starting MQSC for queue manager QM1.

2 : DIS QL(BKUP) CURDEPTH
AMQ8409: Display Queue details.
QUEUE(BKUP) TYPE(QLOCAL)
CURDEPTH(7)

:
END

BKUP is AMS protected with a policy and user1 has the proper AMS set up to unprotect message.

user1@svr123:/var/mqm/UTIL> qload -m QM1 -i BKUP -f /tmp/bkuptest.txt
QLOAD Program by Paul Clarke [ V1.6 Build:Jul 12 2008 ]
Read - Files: 0 Messages: 6 Bytes: 35484060
Written - Files: 1 Messages: 6 Bytes: 35484060

Only 6 messages was handled (not right)

BKUP.QA has no policy. It is an alias Q to BKUP.

user1@svr123:/var/mqm/UTIL> qload -m QM1 -i BKUP.QA -f /tmp/NOAMSbkuptest.txt
QLOAD Program by Paul Clarke [ V1.6 Build:Jul 12 2008 ]
Read - Files: 0 Messages: 7 Bytes: 41412070
Written - Files: 1 Messages: 7 Bytes: 41412070

All 7 messages handled (This is right)

There is no error in AMQERR01.LOG and no message in
AMQ8409: Display Queue details.
QUEUE(SYSTEM.PROTECTION.ERROR.QUEUE) TYPE(QLOCAL)
CURDEPTH(0)

Where else can I look for diagnostic information ?
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Thu Mar 21, 2019 2:36 pm Post subject: Reply with quote

Guardian

Joined: 17 Nov 2005
Posts: 941
Location: New Zealand

This is indeed odd. I can't immediately think of why this might be happening. It is hard to imagine that it is something that QLOAD is doing but you never know.
I guess what we really want to see are the reason code returned from each MQI call.

It is a shame you are using the SupportPac version. As you may know MQGem Software has continued to develop QLOAD and many changes have been added to the original functionality. One of which was to add some verbose options which will print out the reason codes. This was added in version 8.0.2 however there have been 5 version since then. If you would like me to send you a trial licence so you can run the product version of QLOAD with the -va flag then just send an email to support@mqgem.com

Alternatively, of course, you could try running an MQ trace. This will show you just what is happening inside the queue manager and you should be able to deduce the MQI calls that QLOAD is issuing.

Cheers,

Paul.
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ Supportqload missing one AMS message
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.