ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportChange the encoding in the logs (errors)

Post new topicReply to topic
Change the encoding in the logs (errors) View previous topic :: View next topic
Author Message
Jozef1
PostPosted: Sun Feb 17, 2019 12:35 am Post subject: Change the encoding in the logs (errors) Reply with quote

Newbie

Joined: 17 Feb 2019
Posts: 6

Hello.

When installing, I set the language to English. Add this lines : \MQExplorer \ eclipse \ configuration \ config.ini and add this lines:

Code:
org.osgi.framework.language = en
osgi.nl = en_US


Change: MQExplorer.ini in folder MQ\bin64 Now it launches in English

Code:
-Duser.language=en -Xmx512M


But in log encoding. How to fix it?(System win7 default = Russian)
Back to top
View user's profile Send private message
Jozef1
PostPosted: Sun Feb 17, 2019 12:36 am Post subject: Reply with quote

Newbie

Joined: 17 Feb 2019
Posts: 6

Screenshot:
Back to top
View user's profile Send private message
mvic
PostPosted: Sun Feb 17, 2019 4:57 am Post subject: Re: Change the encoding in the logs (errors) Reply with quote

Jedi

Joined: 09 Mar 2004
Posts: 2076

On your command line, type
Code:
chcp

What is the output?
Back to top
View user's profile Send private message
Jozef1
PostPosted: Sun Feb 17, 2019 5:54 am Post subject: Re: Change the encoding in the logs (errors) Reply with quote

Newbie

Joined: 17 Feb 2019
Posts: 6

mvic wrote:
On your command line, type
Code:
chcp

What is the output?


Code 866.
But problem encoding in logs MQ

Back to top
View user's profile Send private message
mvic
PostPosted: Sun Feb 17, 2019 6:24 am Post subject: Re: Change the encoding in the logs (errors) Reply with quote

Jedi

Joined: 09 Mar 2004
Posts: 2076

The MQ code that is responsible for writing error messages, thinks that your locale is Russian, so is using the Russian message catalog.

chcp = 866 would explain why runmqsc gave its output in Russian. Try chcp 437 in your cmd prompt before running runmqsc.

But about the error messages:

It sounds like you want the queue manager code to ignore any locale settings it is automatically detecting, and use English instead.

I wonder if this page helps: https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.1.0/com.ibm.mq.ins.doc/q008955_.htm
Back to top
View user's profile Send private message
Jozef1
PostPosted: Sun Feb 17, 2019 7:44 am Post subject: Re: Change the encoding in the logs (errors) Reply with quote

Newbie

Joined: 17 Feb 2019
Posts: 6

mvic wrote:
The MQ code that is responsible for writing error messages, thinks that your locale is Russian, so is using the Russian message catalog.

chcp = 866 would explain why runmqsc gave its output in Russian. Try chcp 437 in your cmd prompt before running runmqsc.

But about the error messages:

It sounds like you want the queue manager code to ignore any locale settings it is automatically detecting, and use English instead.

I wonder if this page helps: https://www.ibm.com/support/knowledgecenter/en/SSFKSJ_9.1.0/com.ibm.mq.ins.doc/q008955_.htm


Replacing the encoding in the command libe did not help.
But adding a new line to the PATH helped a lot and everything now works fine!
P.S. I have one more question. I'm trying to write an application on JAVA that reads the queue (there are no errors in the logs). For this, I better create a new topic?
Back to top
View user's profile Send private message
mvic
PostPosted: Sun Feb 17, 2019 12:53 pm Post subject: Re: Change the encoding in the logs (errors) Reply with quote

Jedi

Joined: 09 Mar 2004
Posts: 2076

Quote:
But adding a new line to the PATH helped a lot and everything now works fine!

What was the new line? Normally there are no line endings in the contents of PATH.
Jozef1 wrote:
For this, I better create a new topic?

Yes, that would be best.
Back to top
View user's profile Send private message
Jozef1
PostPosted: Sun Feb 17, 2019 1:03 pm Post subject: Re: Change the encoding in the logs (errors) Reply with quote

Newbie

Joined: 17 Feb 2019
Posts: 6

mvic wrote:
Quote:
But adding a new line to the PATH helped a lot and everything now works fine!

What was the new line? Normally there are no line endings in the contents of PATH.
Jozef1 wrote:
For this, I better create a new topic?

Yes, that would be best.


Globally set the MQS_FORCE_NTLANGID(value 1033) environment variable, to the language identifier of the desired language, for messages displayed by the queue manager. You should set the MQS_FORCE_NTLANGID system wide. Otherwise, every user displaying messages needs to have the environment variable set individually.
Thank You!
Back to top
View user's profile Send private message
mvic
PostPosted: Sun Feb 17, 2019 1:10 pm Post subject: Re: Change the encoding in the logs (errors) Reply with quote

Jedi

Joined: 09 Mar 2004
Posts: 2076

Jozef1 wrote:
Thank You!

You're welcome.
What you've done is not the same as adding something to the PATH.
But I now understand what you meant. Thanks.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportChange the encoding in the logs (errors)
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.