ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ Supportdmpmqcfg returns empty

Post new topicReply to topic
dmpmqcfg returns empty View previous topic :: View next topic
Author Message
souciance
PostPosted: Tue Dec 11, 2018 2:23 pm Post subject: dmpmqcfg returns empty Reply with quote

Disciple

Joined: 29 Jun 2010
Posts: 162

We are trying to use dmpmqcfg command in our powershell script to take backup of all our queue managers from a remote server.

Our server has MQ installed but it does not have a connection to every queue manager.

In the script we set the MQSERVER environment variable and to the connection string we want to use and then call dmpmqcfg with -c default

On my local machine it works fine.

On our windows server with only MQ explorer 8.0.0.5 the command returns empty. No error and no result either. No logs either to indicate what could have happened.

Anyone seen this before or knows what could be the issue?
Back to top
View user's profile Send private message
bruce2359
PostPosted: Tue Dec 11, 2018 4:27 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8258
Location: US: west coast, almost. Otherwise, enroute.

If you manually enter the same command to backup the remote qmgr, does it work?
_________________
There are two types of people in this world:
1) Those that can extrapolate from incomplete data
Back to top
View user's profile Send private message
souciance
PostPosted: Tue Dec 11, 2018 4:36 pm Post subject: Reply with quote

Disciple

Joined: 29 Jun 2010
Posts: 162

bruce2359 wrote:
If you manually enter the same command to backup the remote qmgr, does it work?


If I run dmpmqcfg on my dev machine against the remote qmgr then it works.

If I run dmpmqcfg on the build server (windows server) against the remote qmgr I get nothing back and goes straight to prompt.

If I run dmpmqcfg on the build server against a local queue manager then it works.

So its is some issue when we are trying to connect as a client..
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Dec 12, 2018 5:49 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19855
Location: LI,NY

  1. Do not use powershell remoting. It is not able to set the environment correctly as per setmqenv
  2. I would discourage the use of the MQServer variable for dmpmqcfg. Rather build the client end of the channel on the fly as per the documentation
  3. And you may need to use the mqccred security exit to pass the userid in the MQCSP structure
    (Works like a charm for me)...


And I doubt that the return is empty. However to see the error you're getting you probably need to add to your misdirection 2>&1

And before I'd run that I would check with runmqsc to make sure the qmgr is running to avoid overwriting a good file... with and error.

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
souciance
PostPosted: Mon Dec 17, 2018 11:29 am Post subject: Reply with quote

Disciple

Joined: 29 Jun 2010
Posts: 162

fjb_saper wrote:
  1. Do not use powershell remoting. It is not able to set the environment correctly as per setmqenv
  2. I would discourage the use of the MQServer variable for dmpmqcfg. Rather build the client end of the channel on the fly as per the documentation
  3. And you may need to use the mqccred security exit to pass the userid in the MQCSP structure
    (Works like a charm for me)...


And I doubt that the return is empty. However to see the error you're getting you probably need to add to your misdirection 2>&1

And before I'd run that I would check with runmqsc to make sure the qmgr is running to avoid overwriting a good file... with and error.

Have fun


It does indeed return empty and the misdirection returned also empty. We solved it by simply using powershell to login to the server from our base server and run the dmpmqcfg command then the piping the output to a file. That works.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ Supportdmpmqcfg returns empty
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.