ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportPublication node on IIB10

Post new topicReply to topic
Publication node on IIB10 View previous topic :: View next topic
Author Message
matuwe
PostPosted: Tue Nov 27, 2018 7:46 am Post subject: Publication node on IIB10 Reply with quote

Master

Joined: 05 Dec 2007
Posts: 266

Hi I would like to migrate my flow from broker 7 to IIB10, all my mq nodes, use mq policy. I don't have mq manager connected to my iib server. I cannot use publication node, is there anyway that I can publish to a topic without using this node? JMS or? Thank you in advance

Last edited by matuwe on Tue Nov 27, 2018 11:54 pm; edited 1 time in total
Back to top
View user's profile Send private message
timber
PostPosted: Tue Nov 27, 2018 8:32 am Post subject: Reply with quote

Sentinel

Joined: 25 Aug 2015
Posts: 889

Not sure about others, but I did not understand most of that. You may want to explain your question in more detail.
Back to top
View user's profile Send private message
matuwe
PostPosted: Tue Nov 27, 2018 11:51 pm Post subject: Reply with quote

Master

Joined: 05 Dec 2007
Posts: 266

Hi thanks for the reply.

What I am asking is, are there other ways that I could publish to a topic without using the publication node. The problem with publication node is it requires iib to have mq connected to it.

I do not have a local mq on my iib server.
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Wed Nov 28, 2018 1:39 am Post subject: Reply with quote

Master

Joined: 17 Jul 2017
Posts: 236
Location: UK

hi...so how does the publishing currently works in V7 flows that you are migrating?

Or are you saying that you want to add new functionality (Publishing in this case) once the flows are migrated?

There are MQTTPublish/Subscribe nodes that you could explore, iib 10 comes with a built in MQTT server

https://www.ibm.com/support/knowledgecenter/SSMKHH_10.0.0/com.ibm.etools.mft.doc/bn23632_.htm
Back to top
View user's profile Send private message
matuwe
PostPosted: Wed Nov 28, 2018 2:21 am Post subject: Reply with quote

Master

Joined: 05 Dec 2007
Posts: 266

Thanks a million for the response. On broker 7 MQ server was manditory. So the Publish node worked fine. I have setup a topic on Mq and all my subscribers got the message as expected. So I just wanted to follow the same pattern of pub sub.

Thanks a million, I'll explore the MQTT Publish and see how that works. Thanks once again. I see it allows use of MQ policy so that's good start.
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Wed Nov 28, 2018 2:32 am Post subject: Reply with quote

Master

Joined: 17 Jul 2017
Posts: 236
Location: UK

hi...If V7 were using local MQ is there a specific reason you are planning to move away from it in V10? I believe the IIB license allows you to run an MQ on the local node without any additional cost which means you can continue with the similar V7 setup but still use the client-connection where it adds value.
Back to top
View user's profile Send private message
matuwe
PostPosted: Wed Nov 28, 2018 1:56 pm Post subject: Reply with quote

Master

Joined: 05 Dec 2007
Posts: 266

My client insists on not having MQ connected to IIB 10 just for two flows to work.

Thanks for the advice, I have started using MQTT publish node . And I have MQTT server started on MQ Explorer. My flow Publish with no errors, but somehow I dono where to find messages on MQ. I can see the number of messages published increased.

Now I am trying to testing using JMS output node to send to a topic.

I have 5 subscribers per topic.
Back to top
View user's profile Send private message
matuwe
PostPosted: Thu Nov 29, 2018 10:47 pm Post subject: Reply with quote

Master

Joined: 05 Dec 2007
Posts: 266

Hi. I got this to work using JMS output node.

Thanks for all the assistance.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportPublication node on IIB10
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.