ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportFTE from windows server to AS400 resulting 2087 error code

Post new topicReply to topic
FTE from windows server to AS400 resulting 2087 error code View previous topic :: View next topic
Author Message
mnavon
PostPosted: Tue Oct 16, 2018 4:40 am Post subject: FTE from windows server to AS400 resulting 2087 error code Reply with quote

Newbie

Joined: 16 Oct 2018
Posts: 2

Hi!
I am trying to transfer a file using the MQ file transfer from windows 2012 server to AS400.
So I created a Queue manager at the windows server named 'QWind' and coordinator named 'WFTE'.
At the AS400 side I created a Queue manager named 'QAs'.
After that I created an agents for each side, 'QwindAgent' and 'QAsAgent'.
At last I created a template transfer from the AS400 to the Windows, and I got a massage:
Code:
BFGEL0003E: A messaging problem prevented the command from completing successfully, for queue SYSTEM.FTE.COMMAND.QAsAgent on Queue manager QAs. The WebSphere MQ completion code was 2, and the reason code was 2087.

Any idea to what was went wrong? all senders and receivers channels are running.
Back to top
View user's profile Send private message
Vitor
PostPosted: Tue Oct 16, 2018 5:08 am Post subject: Re: FTE from windows server to AS400 resulting 2087 error co Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25310
Location: Ohio, USA

mnavon wrote:
Any idea to what was went wrong?


Well, 30 seconds research will yield that 2087 is "unknown queue manager".

So (given that you've created channels that are working) what else did you do to explain to the QWind queue manager where the QAs queue manager is?
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
gbaddeley
PostPosted: Tue Oct 16, 2018 4:03 pm Post subject: Reply with quote

Padawan

Joined: 25 Mar 2003
Posts: 1898
Location: Melbourne, Australia

FTE / MFT is a MQ application. If it tries to open a qmgr / queue, its connected qmgr will resolve it just like any other mqopen request. Determine why the qmgr can't resolve it. Do you have a transmission queue or a qmgr alias for QAs so that the name can be resolved?
.
After starting the 2 agents, did you check that there were no errors in their output0.log files? Did you run ftePingAgent to verify that both agents are accessible by both servers?
_________________
Glenn
Back to top
View user's profile Send private message
bruce2359
PostPosted: Tue Oct 16, 2018 8:02 pm Post subject: Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 8187
Location: US: west coast, almost. Otherwise, enroute.

I'm pondering the issue of MixedCase name QAs not enclosed in apostrophes in some definition or command is being folded into UPPERCASE. QAS is not equal to QAs.
_________________
I would tell you a UDP joke, but you might not get it.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ SupportFTE from windows server to AS400 resulting 2087 error code
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.