ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportUnable to locate a class definition named... at Tollkit v.10

Post new topicReply to topic
Unable to locate a class definition named... at Tollkit v.10 View previous topic :: View next topic
Author Message
alaychem
PostPosted: Thu Aug 16, 2018 6:22 am Post subject: Unable to locate a class definition named... at Tollkit v.10 Reply with quote

Apprentice

Joined: 10 Feb 2016
Posts: 39

After migrating from Toolkit v8, one of the projects, containing JAVA compute node, gets the above error.

The referenced project is present, and referenced correctly.

Double clicking the node DOES open the .java file, and java browse from the node properties DOES bring the correct java class.

Numerous cleans, rebuilds, toolkit/computer restarts preformed as well as erasing and re-importing the project to the workspace
I also tried changing the project name.
Other projects didn't got this error.

Back to top
View user's profile Send private message
fjb_saper
PostPosted: Thu Aug 16, 2018 2:37 pm Post subject: Re: Unable to locate a class definition named... at Tollkit Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19770
Location: LI,NY

alaychem wrote:
After migrating from Toolkit v8, one of the projects, containing JAVA compute node, gets the above error.

The referenced project is present, and referenced correctly.

Double clicking the node DOES open the .java file, and java browse from the node properties DOES bring the correct java class.

Numerous cleans, rebuilds, toolkit/computer restarts preformed as well as erasing and re-importing the project to the workspace
I also tried changing the project name.
Other projects didn't got this error.


Well you don't specify which class it is not finding...
So may be it is an external library that does not exist or get loaded when you moved to the new release. It is referenced in your development environment but missing in the deployed environment...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
alaychem
PostPosted: Fri Aug 17, 2018 5:10 am Post subject: Reply with quote

Apprentice

Joined: 10 Feb 2016
Posts: 39

@fjb_saper
Sorry about that, it's a class that we wrote.
I don't fail at deployment - the toolkit complier gives me an error, although it can locate the java code with double click on the node and auto-complete the class name in the compute node "java browse"
It is located under the same root folder, with the referencing project.
It is referenced by other project in the workspace, with no problem.


Back to top
View user's profile Send private message
alaychem
PostPosted: Tue Aug 21, 2018 1:46 am Post subject: Reply with quote

Apprentice

Joined: 10 Feb 2016
Posts: 39

OK, after 3 days, I nailed it.


"Normal" java projects and javaCompute projects are not the same, for some reason. The src/output libs in. classpath file are not the same, and probably some other differences, that casue the toolkit to treat them differently.


My project was normal java project, that a java compute class added into it later. The v8 toolkit manage with it, but v10 does not.


Moving the javaCompute class to a new javaCompue project (through double clicking new javaCompute Node) did the trick


P.S Adding the normal java files into javaCompue project seems like a bad strategy. It caused some import issues at ibm classes.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Tue Aug 21, 2018 2:32 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19770
Location: LI,NY

Thanks for posting your resolution
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportUnable to locate a class definition named... at Tollkit v.10
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.