ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportWeb user interface authorizations

Post new topicReply to topic
Web user interface authorizations View previous topic :: View next topic
Author Message
tungnt3010
PostPosted: Tue Jul 24, 2018 8:00 am Post subject: Web user interface authorizations Reply with quote

Newbie

Joined: 23 Jul 2018
Posts: 3

After configuring role-based for web ui, i login to web ui and received the popup message "The logged-on user ID does not have the required permissions to access data or broker resources in the web user interface. See your broker administrator to set up the required permissions".

Softwares and platform i am working as below:
- Operating System Window server 2016 standard
- IBM Webpher MQ version 8.0.0.201404291830
- IIB version 10.0.0.12

I already enabling the web UI, creating system groups and users, configuring role-based security for web UI, creating web user accounts and enabling administrative security and executing commands step by step as following:
- mqsichangeproperties IB10NODE -b webadmin -o server -n enabled,enableSSL -v true,false
- mqsichangeauthmode IB10NODE -s active -m mq
- setmqaut -m QMGRIIB -n SYSTEM.BROKER.AUTH -t queue -g wmbadmin +inq +put +set
- setmqaut -m QMGRIIB -n "SYSTEM.BROKER.AUTH.**" -t queue -g wmbadmin +inq +put +set
- setmqaut -m QMGRIIB -n SYSTEM.BROKER.DC.AUTH -t queue -g wmbadmin +inq +set
- mqsiwebuseradmin IB10NODE -c -u wmbadmin1 -r wmbadmin -a - mypassword.

I have successfuly login to web ui by local wmbadmin1 user but the error authorization popup shows. It seem to be the local wmbadmin has not authorization rights.

I open webphere MQ explorer and grant full administrative access to all Webphere MQ resources and grant all authorities (administration, context, MQI) of two queue SYSTEM.BROKER.AUTH, SYSTEM.BROKER.DC.AUTH for local wmbadmin group but the error popup still shows.

I add administrator user to web user account and to mqm group, login to web ui by using local administrator account but it show same message popup. In II9, I successfully config role-based for Web UI.
Can anyone help me?
Tks
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportWeb user interface authorizations
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.