ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportExecution Groups Restarting after applying fix Pack 9.0.0.10

Post new topicReply to topic
Execution Groups Restarting after applying fix Pack 9.0.0.10 View previous topic :: View next topic
Author Message
IIB_newbie_2018
PostPosted: Wed Jun 20, 2018 9:13 am Post subject: Execution Groups Restarting after applying fix Pack 9.0.0.10 Reply with quote

Newbie

Joined: 20 Jun 2018
Posts: 1

Hello people.

I am in trouble trying to figure out why after updating IIB fro 9.0.0.1 to 9.0.0.10, the EGs I have in this environment stopped working.

From all I can see is that the EGS are starting and then stopping in this endless cycle.

Follow a piece of the log I have:

Jun 20 14:00:30 amlapsr1sp0083 IIB[30064]: IBM Integration Bus v90010 [Thread 30064] (Msg 1/1) BIP4512S: java.lang.NoClassDefFoundError: com.ibm.phpj.reflection.XAPIClassCallbacks2BaseImpl was thrown while loading Java user-defined node class com.ibm.broker.php.MbMessageClassCallbacks.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30064]: IBM Integration Bus v90010 () [Thread 30064] (Msg 1/1) BIP4512S: java.lang.NoClassDefFoundError: com.ibm.phpj.reflection.XAPIIterator was thrown while loading Java user-defined node class com.ibm.broker.php.PhpComputeElementIterator.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30064]: IBM Integration Bus v90010 () [Thread 30064] (Msg 1/1) BIP4512S: java.lang.NoClassDefFoundError: com.ibm.phpj.reflection.XAPIObjectCallbacks4BaseImpl was thrown while loading Java user-defined node class com.ibm.broker.php.MbMessageProxy.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30031]: IBM Integration Bus v90010 () [Thread 30031] (Msg 1/1) BIP2116E: Message broker internal error: diagnostic information 'Fatal Error; exception thrown before initialisation completed', 'Initialise execution group manager', '30031', '30031', '23', '22'.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30031]: IBM Integration Bus v90010 [Thread 30031] (Msg 1/3) BIP2203E: An execution group has encountered a problem whilst starting.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30064]: IBM Integration Bus v90010 [Thread 30064] (Msg 1/1) BIP4512S: java.lang.NoClassDefFoundError: com.ibm.phpj.sapi.SAPICommand was thrown while loading Java user-defined node class com.ibm.broker.php.PhpComputeNode.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30064]: IBM Integration Bus v90010 [Thread 30064] (Msg 1/1) BIP4512S: java.lang.NoClassDefFoundError: com.ibm.phpj.reflection.ProxyObjectFactory was thrown while loading Java user-defined node class com.ibm.broker.php.GenericProxyFactory.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30031]: IBM Integration Bus v90010 [Thread 30031] (Msg 2/3) BIP5024E: The creation and preprocessing of the XML schemas in message set '/var/mqsi/components/?????/0f4bd049-5b01-0000-0080-e3b7fa9dc9ac/config/XMAP/' has failed.
Jun 20 14:00:30 amlapsr1sp0083 IIB[30031]: IBM Integration Bus v90010 [Thread 30031] (Msg 3/3) BIP4395E: Java exception: 'java.lang.NoClassDefFoundError'; thrown from class name: 'java.lang.ClassLoader', method name: 'defineClassImpl', file: 'ClassLoader.java', line: '-2'
Jun 20 14:00:30 amlapsr1sp0083 IIB[30031]: IBM Integration Bus v90010 ([Thread 30031] (Msg 1/1) BIP2204I: Execution group using process '30031' thread '30031' stopped.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Jun 20, 2018 7:05 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19701
Location: LI,NY

Did you also update the way you source the IIB profile?
Looks to me like you might be trying to run the broker without having sourced the profile...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportExecution Groups Restarting after applying fix Pack 9.0.0.10
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.