ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportTest connection failed with 2035 error

Post new topicReply to topic
Test connection failed with 2035 error View previous topic :: View next topic
Author Message
senMQ
PostPosted: Wed Jan 03, 2018 10:39 am Post subject: Test connection failed with 2035 error Reply with quote

Acolyte

Joined: 14 Aug 2006
Posts: 66
Location: Palo Alto, CA

I'm trying to set up a QCF from WAS v8.5 instance to connect to MQ9.0.0.1 queue manager. I get this error when I try to test the connection:
A connection could not be made to WebSphere MQ for the following reason: JMSCMQ0001: WebSphere MQ call failed with compcode '2' ('MQCC_FAILED') reason '2035' ('MQRC_NOT_AUTHORIZED').
I have set the channel auth already. It looks like:
dis chlauth(WAS.CLIENTS)
1 : dis chlauth(WAS.CLIENTS)
AMQ8878: Display channel authentication record details.
CHLAUTH(WAS.CLIENTS) TYPE(BLOCKUSER)
DESCR( ) CUSTOM( )
USERLIST(ALLOWANY) WARN(NO)
ALTDATE(2018-01-03) ALTTIME(13.19.04)
The queue emanager's CHLAUTH attribute is set to disabled and finally, I have give the necessary authotity for the application id to connect to the queu manager using setmqauth. Any ideas on what I'm missing here?
Back to top
View user's profile Send private message Send e-mail
exerk
PostPosted: Wed Jan 03, 2018 11:19 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5778

Did you refresh security or restart the queue manager after?
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
senMQ
PostPosted: Wed Jan 03, 2018 11:27 am Post subject: Reply with quote

Acolyte

Joined: 14 Aug 2006
Posts: 66
Location: Palo Alto, CA

yep, I have restarted the queu emanager after the change. Btw, I changed the authinfo too just now:CHCKCLNTis set to OPTIONAL. But, I see this error in the MQ error logs:
AMQ9557: Queue Manager User ID initialization failed for 'RMADMIN'.

EXPLANATION:
The call to initialize the User ID 'RMADMIN' failed with CompCode 2 and Reason
2035. If an MQCSP block was used, the User ID in the MQCSP block was ''.
ACTION:
Correct the error and try again.
Back to top
View user's profile Send private message Send e-mail
senMQ
PostPosted: Wed Jan 03, 2018 11:38 am Post subject: Reply with quote

Acolyte

Joined: 14 Aug 2006
Posts: 66
Location: Palo Alto, CA

The test connection works fine now after I changed the mcauser id parameter in the server connection channel to 'rmadmin' instead of just rmadmin.

But, is there a way to set it up with out passing a parameter in the mcauser field of the server connection channel?
Back to top
View user's profile Send private message Send e-mail
exerk
PostPosted: Wed Jan 03, 2018 11:53 am Post subject: Reply with quote

Jedi Council

Joined: 02 Nov 2006
Posts: 5778

Work your way through THIS set of blogs, your answer is in there.
_________________
It's puzzling, I don't think I've ever seen anything quite like this before...and it's hard to soar like an eagle when you're surrounded by turkeys.

Back to top
View user's profile Send private message
fjb_saper
PostPosted: Thu Jan 04, 2018 7:07 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19548
Location: LI,NY

You really want to use authinfo with adoptctx(yes), enable chlauth and force the connecting user or the chlauth to determine the user for authorizations.

You need to go back to the infocenter and read up on those things as well as read up on the relevant blogs in developerworks (authored by Morag Hughson).

Make sure your MQ is at least at 9.0.0.1 and you added the channel stanza for the chlauth to kick in after authentication...

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ SupportTest connection failed with 2035 error
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.