ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportSRVCONN channel appear as running, without connection

Post new topicReply to topic
SRVCONN channel appear as running, without connection View previous topic :: View next topic
Author Message
michaesi
PostPosted: Tue Jan 24, 2017 8:41 am Post subject: SRVCONN channel appear as running, without connection Reply with quote

Newbie

Joined: 01 Nov 2004
Posts: 2
Location: Athens, GREECE

A Server Connection channel appears as running while I suspect that is hung. There is no active connection on this channel and the status should be INACTIVE.
I check the status of the channel and I get the following
AMQ8417: Display Channel Status details.
CHANNEL(CHANNEL2) CHLTYPE(SVRCONN)
BUFSRCVD(6) BUFSSENT(5)
BYTSRCVD(1020) BYTSSENT(860)
CHSTADA(2017-01-24) CHSTATI(09.20.51)
COMPHDR(NONE,NONE) COMPMSG(NONE,NONE)
COMPRATE(0,0) COMPTIME(0,0)
CONNAME(10.250.5.150) CURRENT
EXITTIME(0,0) HBINT(1832481381)
JOBNAME(0000235C0000053B) LOCLADDR( )
LSTMSGDA( ) LSTMSGTI( )
MCASTAT(RUNNING) MCAUSER(mqm)
MONCHL(OFF) MSGS(0)
RAPPLTAG( ) RQMNAME(QM_BOAP)
SSLCERTI( ) SSLKEYDA( )
SSLKEYTI( ) SSLPEER( )
SSLRKEYS(0) STATUS(RUNNING)
STOPREQ(NO) SUBSTATE(RECEIVE)
XMITQ( )

The HBINT value seems very strange.
I have checked the log and found the following errors
24/01/2017 08:54:16 - Process(9052.1336) User(mqm) Program(amqrmppa)
AMQ9208: Error on receive from host egarnsrv (10.250.5.150).
EXPLANATION:
An error occurred receiving data from egarnsrv (10.250.5.150) over TCP/IP. This
may be due to a communications failure.
ACTION:
The return code from the TCP/IP (read) call was 104 (X'68'). Record these
values and tell the systems administrator

I am wondering if a connectreset can cause a channel to hung.
Any idea? The client is 7.5 and the server is 6.0. I know this is no longer supported
but there is no capability to upgrade right now
Back to top
View user's profile Send private message
Vitor
PostPosted: Tue Jan 24, 2017 9:47 am Post subject: Re: SRVCONN channel appear as running, without connection Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 24297
Location: Ohio, USA

michaesi wrote:
I am wondering if a connectreset can cause a channel to hung.


Possibly

michaesi wrote:
Any idea? The client is 7.5 and the server is 6.0.


I suspect the v7.5 client is trying something (like a reconnect) that's not supported by v6 and is stuck waiting for the queue manager to do something it doesn't know how to.

michaesi wrote:
I know this is no longer supported but there is no capability to upgrade right now


Then welcome to the world of unsupported versions, where weird stuff like this happens.

IMHO you should degrade the client back to v6 until you're in a position to upgrade the queue manager. There's no value in using a v7.5 client as you can't exploit any of the new features (at best) and at worst stuff like this happens.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Wed Jan 25, 2017 6:40 am Post subject: Reply with quote

Shaman

Joined: 17 Nov 2005
Posts: 790
Location: New Zealand

Prior to MQ V7.0 MQ Channels relied heavily on TCP/IP keep alive to cleanup these types of problems. I have no idea whether it is in fact related to your problem but if you are going to continue with MQ V6.0 then make sure you have KEEPALIVE switched on for your channels.

The heartbeat interval certainly does look very odd. Check that neither the SVRCONN or CLNTCONN channels specify a value as high as that. I doubt it is your problem but having such a high value is not going to help. HBINT is used to ensure that the channel cleans up after a failure in certain circumstances. I see no reason to have it set higher than, say, 15 minutes.

Regards,

Paul.
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ SupportSRVCONN channel appear as running, without connection
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.