ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB9 - Collector Node Issue

Post new topicReply to topic
IIB9 - Collector Node Issue View previous topic :: View next topic
Author Message
abcnil
PostPosted: Mon Jan 23, 2017 1:34 am Post subject: IIB9 - Collector Node Issue Reply with quote

Apprentice

Joined: 29 Mar 2012
Posts: 30

Version - IIB 9002

This how flow is:

SOAP Input > Call 4 internal Services over SOAP JMS > Collector Node


We call 4 different services and collect the responses in Collector and process it further.

Collector node has its configuration service + queues so using different queue than bydefault system queue.

Message Flow instances are 20


Problem:

While doing load testing if we set 5 threads in 1 second. flow works fine.

If we increase it to 6 or more Threads, collector node can not process messages. I can see messages piled up in Collector and Event queues.

Message keep stuck on queue even though expiry is handled properly [Tested separately for expiry cases]

and its start throwing this error on sys logs:

IBM Integration Bus v9002 (IBD01.ISD01) [Thread 8763] (Msg 2/2) BIP2112E: Message broker internal error: diagnostic information 'SYSTEM.BROKER.EDA.CUSTDATA.COLLECTIONS', '2033'.


No new requests get processed until we clean up the queue manually.
Back to top
View user's profile Send private message
smdavies99
PostPosted: Mon Jan 23, 2017 4:51 am Post subject: Reply with quote

Jedi Council

Joined: 10 Feb 2003
Posts: 6077
Location: Somewhere over the Rainbow this side of Never-never land.

I'd raise a PMR. IMHO, there is something deep down inside the product that is getting its knickers in a twist.
_________________
WMQ User since 1999
MQSI/WBI/WMB/'Thingy' User since 2002
Linux user since 1995

Every time you reinvent the wheel the more square it gets (anon). If in doubt think and investigate before you ask silly questions.
Back to top
View user's profile Send private message
zpat
PostPosted: Mon Jan 23, 2017 5:40 am Post subject: Reply with quote

Jedi Council

Joined: 19 May 2001
Posts: 5669
Location: UK

Apply IIB 9.0.0.6 fixpack and re-test.

I have seen some APARs on the collector node.
_________________
Well, I don't think there is any question about it. It can only be attributable to human error. This sort of thing has cropped up before, and it has always been due to human error.
Back to top
View user's profile Send private message
abcnil
PostPosted: Mon Jan 23, 2017 8:34 pm Post subject: Reply with quote

Apprentice

Joined: 29 Mar 2012
Posts: 30

Thanks Guys, I will check with latest pack and see how it goes
Back to top
View user's profile Send private message
abcnil
PostPosted: Fri Jan 27, 2017 6:23 am Post subject: Reply with quote

Apprentice

Joined: 29 Mar 2012
Posts: 30

Workaround - Do not add additional instances if you have Collector Node in your flow
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportIIB9 - Collector Node Issue
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.