ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere DataPowerWeb GUI connection refused

Post new topicReply to topic Goto page 1, 2, 3  Next
Web GUI connection refused View previous topic :: View next topic
Author Message
ivanachukapawn
PostPosted: Tue Nov 17, 2015 5:27 pm Post subject: Web GUI connection refused Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

I wanted to setup a virtual Datapower IDG for training. So I did the following:

1. download VMware player and install it.
2. run vmware player
3. import datapower VM
4. edit VM settings CPUs = 2, networking to host-only
5. run the vm
6. login as admin admin
7. reply no to enable secure backup mode
8. reply no to common compatibility mode
9. enter new admin password xxxxxxxx
10. answer yes to run setup wizard
11. answer yes to configure networks - set each one to dhcp
12. answer yes to configure network services
13. answer no to configure dns
14. answer yes to assign unique system identifier TRAINING
15. answer yes to configure remote access
16. answer yes only to configure web GUI - enter 0 for ALL
17. enter port 9090
18. answer yes for remote user - myid xxxxxxxx
19. answer no for configure RAID array
20. answer no to review and saved the configuration.

At this point I am on the DP command line logged in as admin. I ctrl/alt to get back to the host, and then

checked the ipconfig: noted VMnet1 set to nn.nn.nn.nn

I went to the Chrome browser (Windows 7 Professional) and tried this URL:
https://nn.nn.nn.nn:9090

get connection refused:

this worked OK before using the prior version of VM player.

Anybody have an idea - why connection refused?

incidentally, ping of xx.xx.xx.xx works fine
Back to top
View user's profile Send private message
mqjeff
PostPosted: Wed Nov 18, 2015 5:53 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17448

... dumb question... did you change the VM to expose the relevant ports?
_________________
chmod -R ugo-wx /
Back to top
View user's profile Send private message
ivanachukapawn
PostPosted: Wed Nov 18, 2015 6:23 am Post subject: Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

Jeff,
Thanks for your reply! I am running VMWare Workstation player. I do not see any other VMWare player available for download. I seem to remember a stand-alone player being available but apparently, no longer.
I clicked on "Edit virtual machine settings" and then looked around for a way to expose ports - nothing, no network tab etc. I used "Edit virtual machine settings" earlier to set number of CPUs to 2 (default is and to set the 4 network interfacia to "host-only". (I also tried just setting the first network interface to host-only and leaving the others to "bridged" - that didn't work.
Since I'm using host-only networking, I guess that I should check port exposure on the hypervisor (also since there is no setting available on the VM).
So I ran netstat from my command prompt:
C:\Users\John>netstat -an |find /i "listening"
TCP 0.0.0.0:135 0.0.0.0:0 LISTENING
TCP 0.0.0.0:445 0.0.0.0:0 LISTENING
TCP 0.0.0.0:554 0.0.0.0:0 LISTENING
TCP 0.0.0.0:902 0.0.0.0:0 LISTENING
TCP 0.0.0.0:912 0.0.0.0:0 LISTENING
TCP 0.0.0.0:2869 0.0.0.0:0 LISTENING
TCP 0.0.0.0:5357 0.0.0.0:0 LISTENING
TCP 0.0.0.0:10243 0.0.0.0:0 LISTENING
TCP 0.0.0.0:26143 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49152 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49153 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49154 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49155 0.0.0.0:0 LISTENING
TCP 0.0.0.0:49162 0.0.0.0:0 LISTENING
TCP 127.0.0.1:5354 0.0.0.0:0 LISTENING
TCP 127.0.0.1:27015 0.0.0.0:0 LISTENING
TCP 127.0.0.1:49177 0.0.0.0:0 LISTENING
TCP 127.0.0.1:49178 0.0.0.0:0 LISTENING
TCP 127.0.0.1:52001 0.0.0.0:0 LISTENING
TCP 192.168.1.3:139 0.0.0.0:0 LISTENING
TCP 192.168.21.1:139 0.0.0.0:0 LISTENING
TCP 192.168.41.1:139 0.0.0.0:0 LISTENING
TCP 192.168.56.1:139 0.0.0.0:0 LISTENING
TCP [::]:135 [::]:0 LISTENING
TCP [::]:445 [::]:0 LISTENING
TCP [::]:554 [::]:0 LISTENING
TCP [::]:2869 [::]:0 LISTENING
TCP [::]:3587 [::]:0 LISTENING
TCP [::]:5357 [::]:0 LISTENING
TCP [::]:10243 [::]:0 LISTENING
TCP [::]:26143 [::]:0 LISTENING
TCP [::]:49152 [::]:0 LISTENING
TCP [::]:49153 [::]:0 LISTENING
TCP [::]:49154 [::]:0 LISTENING
TCP [::]:49155 [::]:0 LISTENING
TCP [::]:49162 [::]:0 LISTENING

and don't see any reference to 9090. Not sure what this means. I suspect that the Datapower web server may not be running (despite the fact that Web GUI is enabled and "on", but if that was the case, what process would be refusing the connection?

Incidentally, I thought I would use Datapower CLI to debug the Web GUI server on the Datapower command line, but was disabused of this by the "Catch-22" - cannot use (echo) command until the license is accepted using the Web GUI.
Back to top
View user's profile Send private message
mqjeff
PostPosted: Wed Nov 18, 2015 6:59 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17448

I think you should set them all to bridged.

Host only means it will use one of the VMWare network interfaces, rather than your main ones... Not sure which one, and not 100% sure on that. But bridged means that they're listening to the same network your machine in general is.

That *should* show that the webui port is running from netstat.

As an aside, there is a VMWare Player.
_________________
chmod -R ugo-wx /
Back to top
View user's profile Send private message
ivanachukapawn
PostPosted: Wed Nov 18, 2015 8:50 am Post subject: Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

jeff,

Looks like I am running VMWare Workstation 12 player - I haven't found the download link for vanilla VMWare player yet - I'll keep looking.

I changed to bridged on all 4 VM ports - then did netstat -a and still did not find reference to 9090

I did try to open the ova in VirtualBox - but VirtualBox complains about the ova / ovf format - so VirtualBox does not look like a viable option.
Back to top
View user's profile Send private message
ivanachukapawn
PostPosted: Wed Nov 18, 2015 9:36 am Post subject: Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

jeff,

I found the link to the VMWare player and now have VMWare player version 6 running.

I tried the network interfacia all set to bridged, and got connection refused.

I tried with the network interfacia set to host-only and got connection refused.

I am not seeing 9090 in netstat displays

beginning to suspect that the Datapower Web server is not running, despite enabling the Web GUI in setup and seeing Web GUI enabled and "on" in configuration review before saving the configuration.
Back to top
View user's profile Send private message
mqjeff
PostPosted: Wed Nov 18, 2015 9:58 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17448

I think I'll agree at this point that the webserver isn't running.

Can't speculate why, really.

Did you give the vm enough memory per the specs from the KC?
_________________
chmod -R ugo-wx /
Back to top
View user's profile Send private message
ivanachukapawn
PostPosted: Wed Nov 18, 2015 10:13 am Post subject: Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

The quickstart PDF which in the ova distribution states that 4GB RAM is minimum. I configured the VM for 8GB.

I have an indication that the underlying OS for the Datapower IDG is Suse (the identity of the OS has been hidden until I noticed it in the Virtual version)
If the web server is not running, would it be the Datapower OS which refuses the connection based on there being no listener? I had been thinking that the connection refused message emanated from the web server.
Back to top
View user's profile Send private message
mqjeff
PostPosted: Wed Nov 18, 2015 10:21 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17448

It's not helpful to assume anything about the underlying os.

You won't be able to get to it, except through whatever commands Datapower gives you.

Again, I'm kind of out of ideas. I don't know DP very well at all.
Perhaps someone else will be along.
_________________
chmod -R ugo-wx /
Back to top
View user's profile Send private message
ivanachukapawn
PostPosted: Wed Nov 18, 2015 11:06 am Post subject: Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

Jeff,

I mentioned Suse as the underlying Datapower OS as a point of interest only - obviously we can't get to the OS. But I'm wondering if you know or have an idea as to the source process which triggers the connection refused message - interested in that info because if it is the web server, then I would know that it was started.
Back to top
View user's profile Send private message
mqjeff
PostPosted: Wed Nov 18, 2015 11:12 am Post subject: Reply with quote

Grand Master

Joined: 25 Jun 2008
Posts: 17448

No idea at all.
_________________
chmod -R ugo-wx /
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Wed Nov 18, 2015 9:31 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19400
Location: LI,NY

possibly a firewall? is the port shown as open from the DP command line?
Can you run netstat -an | grep <portnr> from the DP command line?

_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
ivanachukapawn
PostPosted: Thu Nov 19, 2015 4:29 am Post subject: Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

I had thought that I might possibly make some progress with CLI on the DP. However, upon entering any command on the DP command line, a message is displayed which says that first the license must be accepted via the Web GUI. A Catch-22.
On both host-only and bridged attempts port 9090 does not appear in any netstat displays on the host (Windows 7 Pro)
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Thu Nov 19, 2015 5:31 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19400
Location: LI,NY

ivanachukapawn wrote:
I had thought that I might possibly make some progress with CLI on the DP. However, upon entering any command on the DP command line, a message is displayed which says that first the license must be accepted via the Web GUI. A Catch-22.
On both host-only and bridged attempts port 9090 does not appear in any netstat displays on the host (Windows 7 Pro)


It would not because the listening port is not on the Windows 7 IP but on the bridged Ip. If you have a windows 7 firewall in place make sure to punch a hole in it for the bridged ip and port.

What are the results of a telnet <bridgedip> <datapowerport> ?

_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
ivanachukapawn
PostPosted: Thu Nov 19, 2015 6:20 am Post subject: Reply with quote

Knight

Joined: 27 Oct 2003
Posts: 556

fjb,

I checked for a Windows 7 firewall and discovered that that function had been taken over by Kapersky - so for this test, I disabled the Kapersky firewall.

I setup the DP for bridged networking and both Web GUI and Telnet remote admin. Web GUI on port 9090 and Telnet on 2300

Both Web GUI and Telnet attempts result in connection refused.

I sincerely hope that you do not run out of ideas about this problem.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Goto page 1, 2, 3  Next Page 1 of 3

MQSeries.net Forum IndexWebSphere DataPowerWeb GUI connection refused
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.