ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportMultiple annotations found at this line: Deployable WSDL

Post new topicReply to topic
Multiple annotations found at this line: Deployable WSDL View previous topic :: View next topic
Author Message
kumar.MBMQ
PostPosted: Mon May 11, 2015 7:26 am Post subject: Multiple annotations found at this line: Deployable WSDL Reply with quote

Voyager

Joined: 06 May 2011
Posts: 93

I have created a deployable WSDL, But when i try to deploy in EG, Below error pops up .
any idea why I am getting these errors ?
Multiple annotations found at this line:
- XSD: There is no xmlns declaration for namespace 'http://own.com/CDM/MRServiceResponse/
1/0/1/14'
- XSD: The location 'mal_InlineSchema4.xsd' has not been resolved because the import is unused

-----
and the second error is here
Multiple annotations found at this line:
- WS-I BP 1.1: (BP2402) The service does not contain any binding that uses a SOAP 1.1
binding.
- Start tag of element <wsdl:service>
Back to top
View user's profile Send private message
Vitor
PostPosted: Mon May 11, 2015 7:57 am Post subject: Re: Multiple annotations found at this line: Deployable WSDL Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25310
Location: Ohio, USA

kumar.MBMQ wrote:
any idea why I am getting these errors ?


Well....

kumar.MBMQ wrote:

Multiple annotations found at this line:
- XSD: There is no xmlns declaration for namespace 'http://own.com/CDM/MRServiceResponse/
1/0/1/14'


I'd say this is because an xmlns declaration missing for the namespace.

kumar.MBMQ wrote:
- XSD: The location 'mal_InlineSchema4.xsd' has not been resolved because the import is unused


I'd say this is because there's a section defined in the XSD that isn't referenced, and is only an error if you think you should be trying to reference the section in the XSD.

kumar.MBMQ wrote:
and the second error is here
Multiple annotations found at this line:
- WS-I BP 1.1: (BP2402) The service does not contain any binding that uses a SOAP 1.1
binding.
- Start tag of element <wsdl:service>


I'd say this is a missing binding.

What tool did you use to verify the WSDL was valid?
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
kumar.MBMQ
PostPosted: Mon May 11, 2015 9:18 am Post subject: Reply with quote

Voyager

Joined: 06 May 2011
Posts: 93

I 'm using Broker toolkit .
Back to top
View user's profile Send private message
smdavies99
PostPosted: Mon May 11, 2015 9:22 am Post subject: Reply with quote

Jedi Council

Joined: 10 Feb 2003
Posts: 6077
Location: Somewhere over the Rainbow this side of Never-never land.

Tools such as SoapUI can validate your WSDL.
there are also some free online WSDL Validators.

I ALWAYS use at least one of these to validate my WSDL's outside of Broker and before deployment with a flow.
_________________
WMQ User since 1999
MQSI/WBI/WMB/'Thingy' User since 2002
Linux user since 1995

Every time you reinvent the wheel the more square it gets (anon). If in doubt think and investigate before you ask silly questions.
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Mon May 11, 2015 9:23 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19770
Location: LI,NY

kumar.MBMQ wrote:
I 'm using Broker toolkit .


And with right click, verify on the wsdl file you did not get any errors?
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
amrorabi
PostPosted: Sun Oct 14, 2018 7:07 am Post subject: Reply with quote

Newbie

Joined: 07 Nov 2016
Posts: 1

As reference for anyone in the future, I have faced this issue:

XSD: The location 'mal_InlineSchema4.xsd' has not been resolved because the import is unused

and Solved by removing the importing that is not used actually by the WSDL elements.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportMultiple annotations found at this line: Deployable WSDL
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.