ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportCDOutput node SYSOPTS issue

Post new topicReply to topic
CDOutput node SYSOPTS issue View previous topic :: View next topic
Author Message
seeknee
PostPosted: Wed Apr 15, 2015 5:08 pm Post subject: CDOutput node SYSOPTS issue Reply with quote

Apprentice

Joined: 08 Aug 2002
Posts: 41
Location: Melbourne, Australia

Hi

We are using the CDOutput node to transfer a file from Linux to OS390.

If we run a Connect:Direct process manually to transfer the file.. all is well.

If we use the WMB v8.0.0.4 CDOutput node to transfer the file we get the following error.

PNODE side
Remote file open failed. RC=8 FDBK=0 File=MHT1.S.PEXA.CDTEST. Message ID XCPS003I, rc=8, fdbk=0.|MSST=Remote file open failed. RC=8 FDBK=0 File=MHT1.S.PEXA.CDTEST.

SNODE side
SDAA101I - UNKNOWN KEYWORD FOUND IN SYSOPTS SDAA001I - SYSOPTS=:DATATYPE SDAA004I - SYSOPTS=":DATATYPE=binary:STRIP.BLANKS=no:XLATE=no:"

We are using the same Broker and Connect:Direct to send to another client who is also on Linux and all works OK...
So it seems to be an issue with the Linux to OS390 configuration.

Is there away to stop the Broker from sending the SYSOPTS to the SNODE side.

Has anyone ever used the LocalEnvironment tree to set the SYSOPTS

LocalEnvironment.Destination.CD.Copy.To.Option
Copy from options including SYSOPTS
Copy to options including SYSOPTS

Any idea what the issue might be?

Many thanks
_________________
IBM Certified Specialist MQSeries
IBM Certified Specialist WebSphere MQ Integrator
IBM Certified Solution Designer WebSphere Business Integration Message Broker V5

"Good judgement comes from experience, and experience comes from poor judgement"
Back to top
View user's profile Send private message
nelson
PostPosted: Wed Apr 15, 2015 7:06 pm Post subject: Re: CDOutput node SYSOPTS issue Reply with quote

Partisan

Joined: 02 Oct 2012
Posts: 313

What happens if you put this in your process and send it manually to your OS390?

Code:
:DATATYPE=binary:STRIP.BLANKS=no:XLATE=no:


In the process that works fine against OS390... what values do you set in SYSOPTS?

Have you tried setting some values in LocalEnvironment.Destination.Copy.To in the CD for OS390 format?

I'm wondering that Broker is setting some default values for you:

Quote:
You must take care to ensure that the created script is valid, because any existing value created by the node is overridden.


What happens if you set that value to ""?
Back to top
View user's profile Send private message
seeknee
PostPosted: Wed Apr 15, 2015 9:22 pm Post subject: Reply with quote

Apprentice

Joined: 08 Aug 2002
Posts: 41
Location: Melbourne, Australia

Thanks for the quite reply.

We've tried quite a few combinations.
Nothing seems to work.

These are only a few we have tried .. both lower and upper case

SET localEnvRef.Destination.CD.Copy.From.Option = ':DATATYPE=BINARY:';
SET localEnvRef.Destination.CD.Copy.From.Sysopts = 'DATATYPE(BINARY) STRIP.BLANKS(NO) XLATE(NO)';
SET localEnvRef.Destination.CD.Copy.To.Sysopts = '';
SET localEnvRef.Destination.CD.Copy.From.DATATYPE = 'BINARY';

Ideally I would like someone who has already done this to tell me what they have done too set a SYSOPTS.

Many thanks
_________________
IBM Certified Specialist MQSeries
IBM Certified Specialist WebSphere MQ Integrator
IBM Certified Solution Designer WebSphere Business Integration Message Broker V5

"Good judgement comes from experience, and experience comes from poor judgement"
Back to top
View user's profile Send private message
nelson
PostPosted: Wed Apr 15, 2015 10:05 pm Post subject: Reply with quote

Partisan

Joined: 02 Oct 2012
Posts: 313

seeknee wrote:
Ideally I would like someone who has already done this to tell me what they have done too set a SYSOPTS.


I haven't...

seeknee wrote:
We've tried quite a few combinations.
Nothing seems to work.

These are only a few we have tried .. both lower and upper case

SET localEnvRef.Destination.CD.Copy.From.Option = ':DATATYPE=BINARY:';
SET localEnvRef.Destination.CD.Copy.From.Sysopts = 'DATATYPE(BINARY) STRIP.BLANKS(NO) XLATE(NO)';
SET localEnvRef.Destination.CD.Copy.To.Sysopts = '';
SET localEnvRef.Destination.CD.Copy.From.DATATYPE = 'BINARY';


When you try this options you get different errors or get the same error? Do you see in fact the SYSOPTS changing and overwriting?

Code:
SDAA101I - UNKNOWN KEYWORD FOUND IN SYSOPTS SDAA001I - SYSOPTS=:DATATYPE SDAA004I - SYSOPTS=":DATATYPE=binary:STRIP.BLANKS=no:XLATE=no:"


If you always see the same error I suggest you to open a PMR... (unless someone else here has implemented your scenario...)
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Thu Apr 16, 2015 4:24 am Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19898
Location: LI,NY

So manually works? How do you invoke the process? What are the options defined in the process invoked?
The error seems to be unable to open the file... When you run it manually but using the broker id does it work or do you get the same error?
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
pradeep3j
PostPosted: Mon Feb 11, 2019 6:35 pm Post subject: Need the command Reply with quote

Newbie

Joined: 11 Feb 2019
Posts: 5

Hi, I was wondering if you could find the solution. I am facing the same problem where I need to send file to Windows environment from Linux. I am getting error of "Invalid Sysopts". I need to know the correct format of specifying the SYSOTPS in OutputLocalEnvironment but not getting the exact command in any of the forums.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportCDOutput node SYSOPTS issue
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.