ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexiSeries, OpenVMS, HP-NSSTime zones on HP NonStop / Tandem

Post new topicReply to topic
Time zones on HP NonStop / Tandem View previous topic :: View next topic
Author Message
aspre1b
PostPosted: Wed Jun 05, 2013 6:20 am Post subject: Time zones on HP NonStop / Tandem Reply with quote

Voyager

Joined: 05 Jul 2007
Posts: 76
Location: Coventry, UK

IBM MQ always uses GMT/UTC for its puttime when putting a message to a local queue, but its reliant on the underlying operating system.

Our UNIX estate servers display time that is BST, but puttimes are GMT/UTC. [as expected]

On the HP NS/Tandem machines the OS time is BST, but puttimes are also BST. [I expected UTC timestamps]

I'm not a Tandem/HP NS expert, but I've just found out that HP NS does not support time zones, which is a problem for our monitoring solution as we require all messages to be working from the same time zone.

So my question is how easy is it for HP NS to support time zones? There is a product called OPTA2000 which provides a inception library supporting time zones, has anyone in the financial industry had experience with this product?

http://www.tandsoft.com/files/products/OPTA2000.html

I suspect ultimately I will need to process these messages in a Broker, and update the puttime. This feels like a tactical fix where I would like to propose a more strategic fix and sort the issue out at source. Although this would certainly have implications for the applications that run on HP NS.
Back to top
View user's profile Send private message
Tibor
PostPosted: Tue Jun 18, 2013 2:42 am Post subject: Reply with quote

Grand Master

Joined: 20 May 2001
Posts: 1033
Location: Hungary

I've just tried it on our test Tandem box and it works as it was designed: PutTime is in GMT. So I think your OS setting causes this problem.

TZ environment variable here:
Code:
TZ=MET-1MST-2,84,301
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexiSeries, OpenVMS, HP-NSSTime zones on HP NonStop / Tandem
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.