ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportMO03 - qload for Linux x64 (GLIBC 2.5)

Post new topicReply to topic Goto page 1, 2  Next
MO03 - qload for Linux x64 (GLIBC 2.5) View previous topic :: View next topic
Author Message
czaszek
PostPosted: Mon May 13, 2013 11:56 am Post subject: MO03 - qload for Linux x64 (GLIBC 2.5) Reply with quote

Apprentice

Joined: 30 May 2006
Posts: 34
Location: Poland

Hi All

We migrate from AIX to Linux x64 (RHEL 5.8 Tikanga) - which runs with GLIBC_2.5. Unfortunately support pack MO02 (qload) is compiled for Linux with GLIBC 2.7 - which makes it unusable for us.
Moreover, Paul ('paulg_clarke@uk.ibm.com') who took care of qload and q programs seems to be no longer IBM employee (got delivery failed of an email I send to him).
Does anyone of You have a working qload binaries for Linux on x86 or x86(64) which are compiled with GLIBC2.5?

Many thanks in advance
Best Regards
Lukas
Back to top
View user's profile Send private message
zpat
PostPosted: Mon May 13, 2013 11:27 pm Post subject: Reply with quote

Jedi Council

Joined: 19 May 2001
Posts: 5658
Location: UK

Mark E Taylor mentioned on here that you can contact him in lieu of Paul.

marke_taylor@uk.ibm.com
Back to top
View user's profile Send private message
czaszek
PostPosted: Mon May 13, 2013 11:53 pm Post subject: Reply with quote

Apprentice

Joined: 30 May 2006
Posts: 34
Location: Poland

Many thanks!
I will do so.

Best Regards
Lukas
Back to top
View user's profile Send private message
czaszek
PostPosted: Fri May 17, 2013 12:31 pm Post subject: Reply with quote

Apprentice

Joined: 30 May 2006
Posts: 34
Location: Poland

Hi All

Unfortunately Mark can not help me.
Is there anyone of you who has qload compiled with older GLIBC version?

Best Regards
lukasz
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Sat May 25, 2013 4:54 am Post subject: Reply with quote

Guardian

Joined: 17 Nov 2005
Posts: 913
Location: New Zealand

Hi,

If you send me an email I may be able to route out an old version of QLOAD which might work if that's any good.

Send an email to support@mqgem.com

Cheers,
Paul
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
czaszek
PostPosted: Sun May 26, 2013 9:28 pm Post subject: Many Thanks, Paul!! Reply with quote

Apprentice

Joined: 30 May 2006
Posts: 34
Location: Poland

Many Thanks, Paul!
The version you provided works!

Best Regards
lukasz
Back to top
View user's profile Send private message
Dolapevich
PostPosted: Tue Jun 04, 2013 3:11 am Post subject: Re: Many Thanks, Paul!! Reply with quote

Novice

Joined: 29 Oct 2012
Posts: 11
Location: Buenos Aires, Argentina

I have exactly the same scenario
Can somebody send me the qload against 2.5 by email?
basurerosebita at gmail dot com .

Thanks in advance,
Sebastian
Back to top
View user's profile Send private message Yahoo Messenger
czaszek
PostPosted: Tue Jun 04, 2013 11:35 pm Post subject: Reply with quote

Apprentice

Joined: 30 May 2006
Posts: 34
Location: Poland

hi Sebastian

my email : lukasz.strzeszynski@gmail.com, I can send you the qload I got.

Best Regards
lukasz
Back to top
View user's profile Send private message
odium74
PostPosted: Mon Jun 10, 2013 8:28 am Post subject: Reply with quote

Newbie

Joined: 10 Jun 2013
Posts: 8

hi there,

i have the same problem but running SLES 10 SP4 with GLIBC 2.4 ...

is there a qload version compiled for glibc 2.4 available ?

thanks for any help ...
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Mon Jun 10, 2013 8:38 am Post subject: Reply with quote

Guardian

Joined: 17 Nov 2005
Posts: 913
Location: New Zealand

I am not sure but I have one or two old version of QLOAD you can try if you'd like to send a message to support@mqgem.com

Cheers,
Paul.
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
czaszek
PostPosted: Tue Jun 11, 2013 6:36 am Post subject: Reply with quote

Apprentice

Joined: 30 May 2006
Posts: 34
Location: Poland

hi

qload can be used in client mode, I have tried it in my environment, thanks to that could use the last 1.9 version and run it from another server.

All you have to do is to is to export location where you want to connect, e.g.:
export MQSERVER="SYSTEM.ADMIN.SVRCONN/TCP/10.20.30.40(1416)"
and add " -l mqic32" to the qload command line, e.g.:
./qload -oQUEUE1 -f$IMPORT_DIR/file_QUEUE1 -l mqic32 -m $QMGR

Best Regards
lukasz
Back to top
View user's profile Send private message
Studv01
PostPosted: Wed Feb 25, 2015 12:37 pm Post subject: Reply with quote

Apprentice

Joined: 23 Jan 2015
Posts: 27

Hi Paul
could you please send me a copy for the qload you have for Linux 64 bit at swaroopv8 at gmail dot com
here is what I am fighting with
./qload: /lib64/libc.so.6: version `GLIBC_2.7' not found (required by ./qload)

Linux al1-thule2-ilb-mq 2.6.18-398.el5 #1 SMP Tue Aug 12 06:26:17 EDT 2014 x86_64 x86_64 x86_64 GNU/Linux


Name: WebSphere MQ
Version: 7.0.1.10
CMVC level: p701-110-130419
BuildType: IKAP - (Production)
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Wed Feb 25, 2015 1:36 pm Post subject: Reply with quote

Guardian

Joined: 17 Nov 2005
Posts: 913
Location: New Zealand

I'm sorry....was 'send a message to support@mqgem.com' ambiguous in some way ?
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
kordi
PostPosted: Tue Dec 08, 2015 11:45 pm Post subject: Reply with quote

Centurion

Joined: 28 May 2012
Posts: 126
Location: PL

Hi Paul,

Is it still possible to get a copy of qload working with glibc version 2.5?
Back to top
View user's profile Send private message
PaulClarke
PostPosted: Wed Dec 09, 2015 12:20 am Post subject: Reply with quote

Guardian

Joined: 17 Nov 2005
Posts: 913
Location: New Zealand

Hi,

glibc 2.5 seems very old to me....aren't we currently at glic 2.22 ?

I think your best bet of finding a version of QLOAD which runs on an old version of Linux now is to try out the MQGem product version of QLOAD. This has the advantage that, although it runs on old versions of Linux, it contains the latest options. It can even do more than the latest version of the IBM MQ SupportPac.

Regards,

Paul.
_________________
Paul Clarke
MQGem Software
www.mqgem.com
Back to top
View user's profile Send private message Visit poster's website
Display posts from previous:
Post new topicReply to topic Goto page 1, 2  Next Page 1 of 2

MQSeries.net Forum IndexGeneral IBM MQ SupportMO03 - qload for Linux x64 (GLIBC 2.5)
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.