ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Interchange Server + AdaptersmySAP.com Adapter fails to start under MQ V7

Post new topicReply to topic
mySAP.com Adapter fails to start under MQ V7 View previous topic :: View next topic
Author Message
smeunier
PostPosted: Wed Jun 27, 2012 10:30 am Post subject: mySAP.com Adapter fails to start under MQ V7 Reply with quote

Master

Joined: 19 Aug 2002
Posts: 280

MQ was recently upgraded from V6 to V7 of the Message Broker which put a requirement to upgrade to V7 of MQ as well.

I am unable to start the adapter under MQ v7 because of the following error:

Code:

[Time: 2012/06/27 14:15:24.792] [System: ConnectorAgent] [SS: SAP_ERPMIXEDConnector] [Thread: wbia_main (#633948871)] [T
ype: Error] [MsgID: 30001] [Mesg: MQClientSessionManager.createSession caught error while trying to create session. Erro
r: com.ibm.msg.client.jms.DetailedJMSException: JMSFMQ6312: An exception occurred in the Java(tm) MQI. The Java(tm) MQI
has thrown an exception describing the problem.  See the linked exception for further information..]
[Time: 2012/06/27 14:15:24.795] [System: ConnectorAgent] [SS: SAP_ERPMIXEDConnector] [Thread: wbia_main (#633948871)] [T
ype: Error] [MsgID: 30002] [Mesg: MQClientSessionManager.createSession : JMSException raised. Error code JMSFMQ6312. Err
orMessage : com.ibm.mq.jmqi.JmqiException: CC=2;RC=2495;AMQ8568: The native JNI library 'mqjbnd' was not found. [3=mqjbn
d]. ]
[Time: 2012/06/27 14:15:24.795] [System: ConnectorAgent] [SS: SAP_ERPMIXEDConnector] [Thread: wbia_main (#633948871)] [T
ype: Fatal Error] [MsgID: 23041] [Mesg: Error in VisionConnectorAgent.init() , Error key :  , Error Message : java.lang.
Exception: MQClientSessionManager.createSession() : com.ibm.msg.client.jms.DetailedJMSException: JMSFMQ6312: An exceptio
n occurred in the Java(tm) MQI. The Java(tm) MQI has thrown an exception describing the problem.  See the linked excepti
on for further information.. Cause :  .]
[Time: 2012/06/27 14:15:24.796] [System: ConnectorAgent] [SS: SAP_ERPMIXEDConnector] [Thread: wbia_main (#633948871)] [T
ype: Fatal Error] [MsgID: 17058] [Mesg: Application call to method init() returned failure. The application could not be
 contacted.]


I have dealt with the JMSFMQ6312. Err
orMessage : com.ibm.mq.jmqi.JmqiException: CC=2;RC=2495;AMQ8568: The native JNI library 'mqjbnd' was not found. issue before with applications under WebSphere and was able to resolve that using the technotes on the subject.

Those same techniques do not seem to resolve this problem. I have run the dlmqlnks command and have run MQ IVTRun verification programs and they are successful.

I modified the adapterEnv.sh script to change the MQ_LIB variable to point to the 64 bit MQ libraries, but still have the same issue. Has anyone run into this before with getting adapter to run under V7 and if so, what was the process?

Any help would be appreciated
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
fjb_saper
PostPosted: Wed Jun 27, 2012 2:13 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19758
Location: LI,NY

You need a different version of the adapter for WMBV7.
I believe V7 uses the JCO version that is entirely java. V6 uses the JCO that still requires native libraries.
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
smeunier
PostPosted: Thu Jun 28, 2012 11:20 am Post subject: Reply with quote

Master

Joined: 19 Aug 2002
Posts: 280

Is this documented somewhere? Eg. Tech note, white paper...etc. I'd like to read up on it before just installing a new version of the adapter. this seems like another level of frustration.

Currently running:

Version = 6.0.7,
WebSphere Business Integration Adapter Framework version = 2.6.0.7
SAP Middleware Info: jCO Version = "2.1.8 (2006-12-11)

Is it just a new JCO version or adapter version I would need.
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
fjb_saper
PostPosted: Thu Jun 28, 2012 12:33 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19758
Location: LI,NY

smeunier wrote:
Is this documented somewhere? Eg. Tech note, white paper...etc. I'd like to read up on it before just installing a new version of the adapter. this seems like another level of frustration.

Currently running:

Version = 6.0.7,
WebSphere Business Integration Adapter Framework version = 2.6.0.7
SAP Middleware Info: jCO Version = "2.1.8 (2006-12-11)

Is it just a new JCO version or adapter version I would need.

Check up in the Framework what version of SAPJCO is supported.

WMB V7 AFAIK supports JCO Version 3 and up. As for the adapter if it does not come standard with the product, you will probably have to upgrade it...
I believe there were a few caveats and APAR's in the early releases.
Better be @ WMB V7.0.0.4....

But apparently we are not talking about WMBV7 but WBIAF V 2.6.0.7. Did you check what framework level was supported in the new version?

Also what version of java are you using? I believe there is a minimum of java 6 for the JCO V3....

Have fun
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
smeunier
PostPosted: Thu Jun 28, 2012 1:16 pm Post subject: Reply with quote

Master

Joined: 19 Aug 2002
Posts: 280

We are doing a two phase approach.

1) Migrate from WMBV6 to WMBV7 (leaving current adapter infrastructure asis)

2) Migrate off external adapters to WMBV7 SAP Nodes.


I guess it is time to open PMR. It seems that from the error, the issue is a LIBPATH/CLASSPATH specification. But my attempts to resolve this for the external adapter have not been fruitful.

Thanks for your insight
Back to top
View user's profile Send private message Send e-mail Yahoo Messenger
fjb_saper
PostPosted: Thu Jun 28, 2012 1:35 pm Post subject: Reply with quote

Grand Poobah

Joined: 18 Nov 2003
Posts: 19758
Location: LI,NY

smeunier wrote:
We are doing a two phase approach.

1) Migrate from WMBV6 to WMBV7 (leaving current adapter infrastructure asis)

2) Migrate off external adapters to WMBV7 SAP Nodes.


I guess it is time to open PMR. It seems that from the error, the issue is a LIBPATH/CLASSPATH specification. But my attempts to resolve this for the external adapter have not been fruitful.

Thanks for your insight

For the SAP Adapter I would forgo the 2 phase approach and go directly with the WMB7 SAP nodes. The configurable service may ask you about the jar url and the native library path.
Although even supplying those would not work with the 2.x JCO.
Check out the 3.x JCO you will find it changed quite a bit...
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
mb01mqbrkrs
PostPosted: Mon Jul 02, 2012 2:28 am Post subject: Reply with quote

Apprentice

Joined: 18 Nov 2011
Posts: 48

See here: http://www-01.ibm.com/support/docview.wss?rs=695&context=SSMKUK&q1=matrix&uid=swg21271602&loc=en_US&cs=utf-8&lang=en#t8

It looks like the WBI adapter framework is only supported with MQ 7 from FP12.

Also, look here for the WBI adapter details....
http://www-01.ibm.com/support/docview.wss?rs=0&q1=compatibility+matrix%3a&q2=compatibility+matrix+adapters&q3=compatibility+matrix%3a+Websphere+Business+Integration+Adapters+and+WebSphere+Adapters&uid=swg21252626&loc=en_US&cs=utf-8&cc=us&lang=en
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Interchange Server + AdaptersmySAP.com Adapter fails to start under MQ V7
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.