ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum Index » WebSphere MQ Installation/Configuration Support » Unable to open MQ Explorer with "run as" facility

Post new topic  Reply to topic
 Unable to open MQ Explorer with "run as" facility « View previous topic :: View next topic » 
Author Message
raymonde45
PostPosted: Thu Jul 13, 2006 5:21 am    Post subject: Unable to open MQ Explorer with "run as" facility Reply with quote

Newbie

Joined: 13 Jul 2006
Posts: 2
Location: France

Hello,
I installed WebSphere MQ server 6.0.1.1 on my Windows XP platform, as administrator, and it is running just fine.

I am now trying to start MQ Explorer as a different Windows user, so I right click on the icon, and select "Run as......" . MQ Explorer never starts. I do not have any error message

Do you have any idea of what is wrong ? Is the "run as......" facility available with MQ V6 ? I used it without any problem with MQ Explorer V5.3.........
Thanks for any advice !
Back to top
View user's profile Send private message
rowles
PostPosted: Thu Jul 13, 2006 7:02 am    Post subject: Reply with quote

Acolyte

Joined: 12 Oct 2005
Posts: 51

contact admin works just fine... however you need to ensure that the appropriate environment is set before running.

When running the Explorer the strmqcfg command actually runs one of 2 batch scripts called runmqcfg_rcp.cmd or runmqcfg.cmd

These scripts use the Windows environment variable %APPDATA% as the source for the workspace location.

If I remember correctly windows does not set %APPDATA% when launching as another user, and so the launch of eclipse fails. Either that or it uses the one of the launched user, rather than the one specified in contact admin, and so has no write permissions.

The two possible solutions are:

1) edit the appropriate command script (probably both of them to be sure) to hard code an %APPDATA% location that you would like to use and that all users will have write access to

2) wrapper your call to strmqcfg in another command script which will set an appropriate %APPDATA% directory first.

If that does work, try using a small contact admin command script to launch a command window, and from there execture strmqcfg -d to display any errors that might occur, this will also help with debuging problems with you environment.
_________________
--

Steve.
Back to top
View user's profile Send private message
raymonde45
PostPosted: Mon Oct 09, 2006 3:57 am    Post subject: Reply with quote

Newbie

Joined: 13 Jul 2006
Posts: 2
Location: France

I am copying here the small script I created to bypass this problem :

set APPDATA=C:\Documents and Settings\Administrator\Application Data
cd C:\Program Files\IBM\WebSphere MQ\bin
contact admin /env /user:<appropriate_user> "strmqcfg.exe -d"
Back to top
View user's profile Send private message
Display posts from previous:   
Post new topic  Reply to topic Page 1 of 1

MQSeries.net Forum Index » WebSphere MQ Installation/Configuration Support » Unable to open MQ Explorer with "run as" facility
Jump to:  



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP
 
 


Theme by Dustin Baccetti
Powered by phpBB © 2001, 2002 phpBB Group

Copyright © MQSeries.net. All rights reserved.