ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportMQSI for Sun Solaris Installation Problem

Post new topicReply to topic
MQSI for Sun Solaris Installation Problem View previous topic :: View next topic
Author Message
KittieKat
PostPosted: Thu Jan 24, 2002 2:40 pm Post subject: Reply with quote

Apprentice

Joined: 17 Dec 2001
Posts: 31

Hi,

I recently intalled MQSI 2.0.2 on a Solaris Box, but every time I try to create a broker using the "mqsicreatebroker" command, the same error message would show up:

ld.so.1: mqsicreatebroker: fatal: relocation error: file /opt/mqsi/lib/libbipicu
.so: symbol __1cDstdJbad_allocG__vtbl_: referenced symbol not found

I have checked that the file it's referring does exist. So then I tried to uninstall MQSI (I thought maybe I didn't install it correctly), but the "pkgrm mqsi" command doesn't exist. Can anyone tell me what am I doing wrong here? I'm all out of ideas, thank you.
Back to top
View user's profile Send private message Send e-mail
kolban
PostPosted: Thu Jan 24, 2002 10:09 pm Post subject: Reply with quote

Grand Master

Joined: 22 May 2001
Posts: 1072
Location: Fort Worth, TX, USA

Quote:

PROBLEM SUMMARY:
Mqseries Integrator v2 - unable to create a broker. Error
message " relocation error file/opt/mqsi/lib/libbipicu.so
symbol_1cdstdjbad_allokg_vtbl_referenced symbol not found".
I think something is more fundamentally amiss with MQSI on this
system. No MQSI program can begin executing, since the linker is
having trouble linking in any MQSI shared lib:
isq-sa-01:% export MQSI_UTILITY_TRACE=bug
isq-sa-01:% mqsicreatebroker BRKUS02
ld.so.1: mqsicreatebroker: fatal: relocation error: file
/opt/mqsi/lib/libbipicu.so: symbol __1cDstdJbad_allocG__vtbl_:
referenced symbol not found


SOLUTION:
The unscrambled version of the missing symbol is
std::bad_alloc::__vtbl.
And libbipicu.so does require this. Looking at the Solaris libraries
to find where this comes from we found it in libCrun.so.1. Looking
back at the required Solaris patches that coincide with libCrun.so.1
(see the readme.txt file) we found patch 106327-08. I then checked
the list of patches in the notes sent to mqserv@uk.ibm.com and I
could not find this one. This will need to be installed. Go to the
http://access1.sun.com site and search for 106327. Download and
install it and this should clear up the problem. Also ask customer to
re-read the readme.txt file just in case something else is missing.
The Solaris patch resolved the problem along with some DB2 config
changes. Cust considers the problem closed.


Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexIBM MQ Installation/Configuration SupportMQSI for Sun Solaris Installation Problem
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.