ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ SupportGetting Dot characters while pulling message from MQ by Main

Post new topicReply to topic
Getting Dot characters while pulling message from MQ by Main View previous topic :: View next topic
Author Message
Jeffries
PostPosted: Fri Jan 27, 2023 11:05 am Post subject: Getting Dot characters while pulling message from MQ by Main Reply with quote

Newbie

Joined: 27 Jan 2023
Posts: 1

Hi All,

We receiving messages from DotNet Client application to our Mainframe Queue manager and while the Mainframe application tries to pull the message from our Mainframe Queue the messages are appending with dot (.) Characters in front of each messages

Please suggest some solution for this.

Thank you.[/b]
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Sat Jan 28, 2023 2:28 am Post subject: Re: Getting Dot characters while pulling message from MQ by Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20640
Location: LI,NY

Jeffries wrote:
Hi All,

We receiving messages from DotNet Client application to our Mainframe Queue manager and while the Mainframe application tries to pull the message from our Mainframe Queue the messages are appending with dot (.) Characters in front of each messages

Please suggest some solution for this.

Thank you.[/b]

What is the CCSID on the message, what is the message format and how did the message get written to the queue(API method called)?
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
bruce2359
PostPosted: Sat Jan 28, 2023 5:34 am Post subject: Re: Getting Dot characters while pulling message from MQ by Reply with quote

Poobah

Joined: 05 Jan 2008
Posts: 9284
Location: US: west coast, almost. Otherwise, enroute.

Jeffries wrote:
... message from our Mainframe Queue the messages are appending with dot (.) Characters in front of each messages

I'm a bit confused by this. When you append something to something else, you attach it or add it to the end of it - not the start of it. (For example, I appended a dot character to the end of this sentence.) Conversely, prepend usually means attach (a piece of data) to the beginning of another.

A message consists of a message descriptor header (MQMD) and your application data payload.

So, are you saying that the . is now the first (left-most) non-blank character of your application data payload? Or the right-most character? Or somewhere else?

It might help if you displayed a portion of the message for us to see - both MQMD and application data payload - in character character and hex formats.

The CCSID and message format are part of the MQMD.
_________________
I like deadlines. I like to wave as they pass by.
ב''ה
Lex Orandi, Lex Credendi, Lex Vivendi. As we Worship, So we Believe, So we Live.
Back to top
View user's profile Send private message
zpat
PostPosted: Sun Jan 29, 2023 7:21 am Post subject: Reply with quote

Jedi Council

Joined: 19 May 2001
Posts: 5824
Location: UK

Byte Order Mark
_________________
Well, I don't think there is any question about it. It can only be attributable to human error. This sort of thing has cropped up before, and it has always been due to human error.
Back to top
View user's profile Send private message
hughson
PostPosted: Mon Jan 30, 2023 5:07 pm Post subject: Re: Getting Dot characters while pulling message from MQ by Reply with quote

Padawan

Joined: 09 May 2013
Posts: 1830
Location: Bay of Plenty, New Zealand

Jeffries wrote:
We receiving messages from DotNet Client application to our Mainframe Queue manager and while the Mainframe application tries to pull the message from our Mainframe Queue the messages are appending with dot (.) Characters in front of each messages

A dot (.) character is classically used to represent a character that does not have a printable form. Often nulls but also other non-printable control characters.

You seem to be describing that every character has a dot in front of it? This makes me think that the message is in a UniCode codepage, where each character is represented by 2 bytes, where for many" normal" characters, e.g. your A-Z and 0-9 characters, the first of the two bytes is 0x00. If you take a stream of bytes and assume it is single-byte ASCII when it is actually Double-byte UniCode, it would be printed out as dot-character-dot-character.

Others have asked what the code page of the message is - I would reiterate that, and also ask, does your mainframe application use MQGET with MQGMO_CONVERT?

Cheers,
Morag
_________________
Morag Hughson @MoragHughson
IBM MQ Technical Education Specialist
Get your IBM MQ training here!
MQGem Software
Back to top
View user's profile Send private message Visit poster's website
gbaddeley
PostPosted: Tue Jan 31, 2023 4:56 pm Post subject: Re: Getting Dot characters while pulling message from MQ by Reply with quote

Jedi

Joined: 25 Mar 2003
Posts: 2413
Location: Melbourne, Australia

Jeffries wrote:
Hi All,
We receiving messages from DotNet Client application to our Mainframe Queue manager and while the Mainframe application tries to pull the message from our Mainframe Queue the messages are appending with dot (.) Characters in front of each messages
Please suggest some solution for this.
Thank you.[/b]

Can you provide a dump of the message descriptor and a hex byte dump of the message data?
eg. Using MO71 browse, or using amqsbcg sample program.
This will reveal the CCSID of the message and the format of the data.
_________________
Glenn
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ SupportGetting Dot characters while pulling message from MQ by Main
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.