ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Interchange Server + AdaptersJDBC adapter Delete issue

Post new topicReply to topic
JDBC adapter Delete issue View previous topic :: View next topic
Author Message
somsayan
PostPosted: Wed Jun 11, 2008 2:35 am Post subject: JDBC adapter Delete issue Reply with quote

Apprentice

Joined: 06 Apr 2007
Posts: 49

Hi
We have JDBC WBI adapter 2.6.9 installed in our system. When we are sending the Wrapper message with Delete verb the data isn't deleted from the DB2 database. But when the same message is sent using Create or Update verb the operation is successfully done in the database.
Please help.
Thanking you all in anticipation of your solution
Back to top
View user's profile Send private message
somsayan
PostPosted: Wed Jun 11, 2008 3:29 am Post subject: A bit more information Reply with quote

Apprentice

Joined: 06 Apr 2007
Posts: 49

When we are trying to delete the data without using the Wrapper BO, the deleting seems to be going on perfectly, but using the wrapper BO the Deleting is not taking place.
Our sytem is using
Framework version: 2.6.0.11
Adapter version: 2.6.9
O/S: Windows


Please help
Back to top
View user's profile Send private message
Gaya3
PostPosted: Wed Jun 11, 2008 4:55 am Post subject: Reply with quote

Jedi

Joined: 12 Sep 2006
Posts: 2493
Location: Boston, US

plz let us know the error that you can see on the Adapter logs..

Regards
Gayathri
_________________
Regards
Gayathri
-----------------------------------------------
Do Something Before you Die
Back to top
View user's profile Send private message
somsayan
PostPosted: Wed Jun 11, 2008 7:46 pm Post subject: Reply with quote

Apprentice

Joined: 06 Apr 2007
Posts: 49

Hi Gaya3, thanks for your quick reply.
The log states:
Code:
[Type: Error] [MsgID: 37004] [Mesg: Execution of Prepared Update Statement Failed : COM.ibm.db2.jdbc.DB2Exception: [IBM][CLI Driver][DB2/NT] SQL0803N  One or more values in the INSERT statement, UPDATE statement, or foreign key update caused by a DELETE statement are not valid because the primary key, unique constraint or unique index identified by "1" constrains table "DB2ADMIN.TEST_MASTER" from having duplicate rows for those columns.  SQLSTATE=23505
Back to top
View user's profile Send private message
Gaya3
PostPosted: Wed Jun 11, 2008 8:24 pm Post subject: Reply with quote

Jedi

Joined: 12 Sep 2006
Posts: 2493
Location: Boston, US

somsayan wrote:

Code:
[Type: Error] [MsgID: 37004] [Mesg: Execution of Prepared Update Statement Failed : COM.ibm.db2.jdbc.DB2Exception: [IBM][CLI Driver][DB2/NT] SQL0803N  [b]One or more values in the INSERT statement, UPDATE statement, or foreign key update caused by a DELETE statement are not valid because the primary key, unique constraint or unique index identified by "1" constrains table "DB2ADMIN.TEST_MASTER" from having duplicate rows for those columns.[/b]  SQLSTATE=23505


is it possible for you to provide me the sql statement..

its violating the contraints of your BO thats the reason its not able to delete the row.

https://publib.boulder.ibm.com/infocenter/db2luw/v9r5/index.jsp?topic=/com.ibm.db2.luw.messages.sql.doc/doc/msql00803n.html


Regards
Gayathri
_________________
Regards
Gayathri
-----------------------------------------------
Do Something Before you Die
Back to top
View user's profile Send private message
somsayan
PostPosted: Wed Jun 11, 2008 8:36 pm Post subject: Reply with quote

Apprentice

Joined: 06 Apr 2007
Posts: 49

As per the trace file the BO is being populated successfully.
The SQL Command issued is :
Code:
select NAME,EMPLID,DEPT from TEST_MASTER where EMPLID=017000

The BO is correctly picking up the datas from the table.[/code]
Back to top
View user's profile Send private message
Gaya3
PostPosted: Wed Jun 11, 2008 8:48 pm Post subject: Reply with quote

Jedi

Joined: 12 Sep 2006
Posts: 2493
Location: Boston, US

how about for the delete SQL command.

did you go through the link

Regards
Gayathri
_________________
Regards
Gayathri
-----------------------------------------------
Do Something Before you Die
Back to top
View user's profile Send private message
somsayan
PostPosted: Wed Jun 11, 2008 9:01 pm Post subject: Reply with quote

Apprentice

Joined: 06 Apr 2007
Posts: 49

Gaya3 wrote:
how about for the delete SQL command.

did you go through the link

Regards
Gayathri


Hi I did go through the link. But as per the adapter trace, no delete command is issued.
Back to top
View user's profile Send private message
Gaya3
PostPosted: Wed Jun 11, 2008 9:22 pm Post subject: Re: A bit more information Reply with quote

Jedi

Joined: 12 Sep 2006
Posts: 2493
Location: Boston, US

somsayan wrote:
When we are trying to delete the data without using the Wrapper BO, the deleting seems to be going on perfectly, but using the wrapper BO the Deleting is not taking place.
Our sytem is using
Framework version: 2.6.0.11
Adapter version: 2.6.9
O/S: Windows




I got confused here..you said you try to delete..and didnt work out..

Regards
Gayathri
_________________
Regards
Gayathri
-----------------------------------------------
Do Something Before you Die
Back to top
View user's profile Send private message
somsayan
PostPosted: Wed Jun 11, 2008 9:42 pm Post subject: Reply with quote

Apprentice

Joined: 06 Apr 2007
Posts: 49

Yes we are trying to delete the data, but the adapter didn't issue any delete command. Instead it issued a select statement. The adapter did go into the doDelete, doRecursive delete functions but didn't issue any delete statement. As per the trace file it also states that the transaction was commited successfully but the database isn't changed to reflect the changes.
I think you missed that i mentioned the delete verb worked fine without the wrapper BO. when only the child BO was used with the delete verb, the deletion was successful. But now as per the requirement, we need to add the wrapper BO. when we set the wrapper BO verb as Delete the deletion is not taking place. We are doing physical deletion hence the change to the data should be reflected in the Database. But it's not showing any change to data
Back to top
View user's profile Send private message
roasta_3
PostPosted: Mon Jun 06, 2022 7:03 pm Post subject: Reply with quote

Newbie

Joined: 06 Jun 2022
Posts: 3

Are there any option, way or software to work similary to new version ACE or IIB v10?

where can polling to database events to send data query to a MQ queue?
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Interchange Server + AdaptersJDBC adapter Delete issue
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.