ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportACE Switching from embedded listeners to integration

Post new topicReply to topic
ACE Switching from embedded listeners to integration View previous topic :: View next topic
Author Message
MKHODER1
PostPosted: Fri Feb 12, 2021 5:48 am Post subject: ACE Switching from embedded listeners to integration Reply with quote

Apprentice

Joined: 18 Aug 2018
Posts: 28

Hi,

I switched from embedded listeners to an integration node listener and the listener is still embedded

mqsireportproperties TEST -b NodeHttpListener -o HTTPListener -n startListener

TRUE

mqsireportproperties TEST -e EGT1 -o HTTPConnector -r
active
ListenerPort='7801'
serverRestartRequired='false'
detailed
connectors
Embedded
discardedRequests='0'
port='7801'
secure='false'
urlRegistrations
urlRegistration
outstandingRequests='0'
url='/soap'
usedByHTTPNodes='false'
usedBySOAPNodes='true'
nodes
node
flowLabel='test'
nodeLabel='SOAP Input'
urlRegistration
outstandingRequests='0'
url='/http'
usedByHTTPNodes='true'
usedBySOAPNodes='false'
nodes
node
flowLabel='test'
nodeLabel='HTTP Input'

BIP8071I: Successful command completion.

mqsireportproperties TEST -e EGT1 -o ExecutionGroup -r

ExecutionGroup
name='ExecutionGroup'
type='resourceManager'
activeUserExitList=''
failedMessageWaitTime='1000'
httpNodesUseEmbeddedListener='false'
inactiveUserExitList=''
soapNodesUseEmbeddedListener='false'
suppressMessageNumbers=''
threadLocalProxyNameManagers='false'
traceNodeLevel='true'
active
httpNodesUseEmbeddedListener='true'
soapNodesUseEmbeddedListener='true'


How to set the values of active httpNodesUseEmbeddedListener and soapNodesUseEmbeddedListener to false ?

Many thanks
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Fri Feb 12, 2021 9:08 am Post subject: Reply with quote

Chevalier

Joined: 17 Jul 2017
Posts: 419
Location: UK

hi...please crosscheck the steps you took against the ones listed in the below link

https://www.ibm.com/support/knowledgecenter/SSMKHH_10.0.0/com.ibm.etools.mft.doc/bc55190_.html
Back to top
View user's profile Send private message
MKHODER1
PostPosted: Fri Feb 12, 2021 9:27 am Post subject: Reply with quote

Apprentice

Joined: 18 Aug 2018
Posts: 28

Thanks for your answer.

I did exactly the same.

The problem is I have not a local queue manager
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Sat Feb 13, 2021 2:07 am Post subject: Reply with quote

Chevalier

Joined: 17 Jul 2017
Posts: 419
Location: UK

MKHODER1 wrote:

The problem is I have not a local queue manager


That is the issue, see the highlighted text from the ACE link,


Quote:
The integration node listener requires access to system queues on the queue manager specified on the integration node, so you must install
IBM MQ Server and ensure that a queue manager is specified
.



https://www.ibm.com/support/knowledgecenter/SSTTDS_11.0.0/com.ibm.etools.mft.doc/bc55190_.html
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportACE Switching from embedded listeners to integration
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.