ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportBROKER HTTP SERVER change from Apache-Coyote/1.1 to NULL

Post new topicReply to topic
BROKER HTTP SERVER change from Apache-Coyote/1.1 to NULL View previous topic :: View next topic
Author Message
anil kumar
PostPosted: Mon Oct 05, 2020 5:53 am Post subject: BROKER HTTP SERVER change from Apache-Coyote/1.1 to NULL Reply with quote

Voyager

Joined: 22 Jan 2017
Posts: 78
Location: India

I'm trying to change the brokerwide HTTP Listener/connector parameter

The default value is Apache-Coyote/1.1 and as per documentation this value can be changed.

Quote:
-n serverName
Set the value that is set in the "Server" header for all HTTP responses sent by this server.
Value type - string
Initial value - Apache-Coyote/1.1


Can this value be completely removed for all the HTTP response of broker.

I was able to change the name from Apache-Coyote/1.1 to a random string.

Is it possible to completely remove this parameter?

if complete removal is not possible, can we make this parameter NULL?

So far I tried

Quote:
mqsichangeproperties BROKER -o HTTPConnector -n serverName -v NULL

mqsichangeproperties BROKER -o HTTPSConnector -n serverName -v NULL


if I pass NULL it is not updating the broker.(just tried NULL, not sure if NULL is allowed or not.)

I have even changed did some changes in the broker file
(i know it is not recommended but wanted to check )
Quote:
IBM\MQSI\registry\BROKER\CurrentVersion\HTTPListener\HTTPConnector\serverName.dat

if I delete the contents of this file or delete the whole files, the broker is defaulting the server name back to Apache-Coyote/1.1


Is there a way to make it NULL or completely disable or make it empty?
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Mon Oct 05, 2020 8:05 am Post subject: Reply with quote

Partisan

Joined: 17 Jul 2017
Posts: 381
Location: UK

hi...try the below and see,
Code:
-n serverName -v ''

or
Code:
-n serverName -v ""
Back to top
View user's profile Send private message
anil kumar
PostPosted: Mon Oct 05, 2020 11:03 am Post subject: Reply with quote

Voyager

Joined: 22 Jan 2017
Posts: 78
Location: India

Hi Abhi ,

Quote:
worked
-n serverName -v "{space}"

Aparently single quotes with space did not work

If I pass space as value then in the Http response header the serverrname is empty, if I just give "" two quotes with no space or two single quotes with no space in those cases the value is defaulted to Apache-coyote/1.1.

Now as I can send empty server name in response that is okay but is there a possibility to completely disable that parameter?

If I make it Empty or deleted the serverName.dat file from registry folder then it is automatically taking Apache-Coyote/1.1 by default
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportBROKER HTTP SERVER change from Apache-Coyote/1.1 to NULL
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.