ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportSymbol resolution failed warning -

Post new topicReply to topic
Symbol resolution failed warning - View previous topic :: View next topic
Author Message
nukalas2010
PostPosted: Sun Jul 12, 2020 3:35 am Post subject: Symbol resolution failed warning - Reply with quote

Master

Joined: 04 Oct 2010
Posts: 220
Location: Somewhere in the World....

Dears,

Recently we upgraded IIB from 10.0.0.11 to 10.0.0.18 in AIX environment. everything went fine and services are also working normally.

But we observed the below error in broker logs for any activity like start of Integration node or reload of EG causing these warnings..

Quote:
user:err|error IIB[4981146]: IBM Integration Bus v100011 (NODEXXX1.EG1) [Thread 1] (Msg 1/1) BIP2308E: File '/opt/IBM/mqsi/iib
-10.0.0.18/server/SecurityProviders/wstrustSecurityProvider.lsl' could not be loaded; operating system return code 'Symbol resolution failed for /opt
/IBM/mqsi/iib-10.0.0.18/server/SecurityProviders/wstrustSecurityProvider.lsl because: Symbol __ct__19ImbExceptionDetailsFPC12ImbLogSourcePCciT2RC10
ImbWstringN23 (number 104) is not exported from dependent module /opt/IBM/mqsi/iib-10.0.0.11/server/lib/libCommonServices.a[libCommonServices
.a.so]. Symbol __ct__25ImbConfigurationExceptionFRC19ImbExceptionDetailsQ3_6ImbLog4Item4Type (number 112) is not exported from dependent
module /opt/IBM/mqsi/iib-10.0.0.11/server/lib/libCommonServices.a[libCommonServices.a.so]. Symbol __ct__20ImbSecurityExceptionFRC19ImbEx
ceptionDetailsQ3_6ImbLog4Item4Type (number 115) is not exported from dependent module /opt/IBM/mqsi/iib-10.0.0.11/server/lib/libCommonServices.a[l
ibCommonServices.a.so].


Can anyone have come through this error anytime.. please throw some light on this.

Thanks,
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Mon Jul 13, 2020 12:57 am Post subject: Reply with quote

Partisan

Joined: 17 Jul 2017
Posts: 357
Location: UK

hi...

Quote:
IBM Integration Bus v100011 (NODEXXX1.EG1)

Quote:
/opt/IBM/mqsi/iib-10.0.0.11/server/lib/libCommonServices.a


why is the integration node process still showing as fixpack 11 instead of 18, also it is still trying to access fixpack11 files...can you please crosscheck whether the service and the node indeed got upgraded completely to fixpack 18,
'mqsiservice -v' and 'mqsiservice <nodename>' should help
Back to top
View user's profile Send private message
nukalas2010
PostPosted: Mon Jul 13, 2020 6:22 am Post subject: Reply with quote

Master

Joined: 04 Oct 2010
Posts: 220
Location: Somewhere in the World....

Yeah.. version details matching with 10.0.0.18

also mqsireportbroker returns path of 10.0.0.18

Opened PMR, will wait for the feedback.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportSymbol resolution failed warning -
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.