ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexGeneral IBM MQ Supportdmpmqcfg client connection not working

Post new topicReply to topic
dmpmqcfg client connection not working View previous topic :: View next topic
Author Message
vmanel
PostPosted: Fri Apr 17, 2020 12:46 am Post subject: dmpmqcfg client connection not working Reply with quote

Acolyte

Joined: 12 Mar 2019
Posts: 56

Hi,

We need to take dump of iSeries Queue manager present in a different server. I tried the following commands from another linux server:

Code:

dmpmqcfg -m RemoteQM -c "DEF CHANNEL(ABC.ABC) CHLTYPE(CLNTCONN) CONNAME('host(port)')"
dmpmqcfg -m LocalQM -c "DEF CHANNEL(ABC.ABC) CHLTYPE(CLNTCONN) CONNAME('host(port)')"


But this neither returning any result, nor any errors. ABC.ABC is a server connection channel present in the Queue Manager

Not able to figure out the issue here, can someone please help?
Back to top
View user's profile Send private message
hughson
PostPosted: Fri Apr 17, 2020 1:51 am Post subject: Reply with quote

Padawan

Joined: 09 May 2013
Posts: 1512
Location: Bay of Plenty, New Zealand

Are there any errors on the iSeries Queue Manager?
_________________
Morag Hughson @MoragHughson
IBM MQ Technical Education Specialist
Get your IBM MQ training here!
MQGem Software
Back to top
View user's profile Send private message Visit poster's website
vmanel
PostPosted: Fri Apr 17, 2020 2:44 am Post subject: Reply with quote

Acolyte

Joined: 12 Mar 2019
Posts: 56

hughson wrote:
Are there any errors on the iSeries Queue Manager?


We do not have access to error logs of iSeries Queue Managers, but no messages have gone to DLQ in that QM when this command was executed. And I tried this command with a queue manager present in same linux server. Even there, nothing is coming up. No errors is logs as well.
Back to top
View user's profile Send private message
hughson
PostPosted: Fri Apr 17, 2020 4:11 am Post subject: Reply with quote

Padawan

Joined: 09 May 2013
Posts: 1512
Location: Bay of Plenty, New Zealand

Do you have access to the Linux queue manager error logs where you see the same behaviour? I try that command on my Windows queue manager and it works fine, so nothing obviously wrong from the syntax.

What version of MQ are you using?

Cheers,
Morag
_________________
Morag Hughson @MoragHughson
IBM MQ Technical Education Specialist
Get your IBM MQ training here!
MQGem Software
Back to top
View user's profile Send private message Visit poster's website
vmanel
PostPosted: Fri Apr 17, 2020 8:19 pm Post subject: Reply with quote

Acolyte

Joined: 12 Mar 2019
Posts: 56

hughson wrote:
Do you have access to the Linux queue manager error logs where you see the same behaviour? I try that command on my Windows queue manager and it works fine, so nothing obviously wrong from the syntax.

What version of MQ are you using?


Yes I have access to Error logs of Linux Queue Manager, but no errors in log when the command is executed. MQ version is 9.0
Back to top
View user's profile Send private message
hughson
PostPosted: Sat Apr 18, 2020 5:45 pm Post subject: Reply with quote

Padawan

Joined: 09 May 2013
Posts: 1512
Location: Bay of Plenty, New Zealand

Are you able to determine whether it is successfully connecting to the queue manager at all? For example, can you see the SVRCONN is DISPLAY CHSTATUS or does it not stay running long enough to see this?

Are there any errors in the client side AMQERR01.LOG?

Cheers,
Morag
_________________
Morag Hughson @MoragHughson
IBM MQ Technical Education Specialist
Get your IBM MQ training here!
MQGem Software
Back to top
View user's profile Send private message Visit poster's website
vmanel
PostPosted: Mon Apr 20, 2020 10:14 pm Post subject: Reply with quote

Acolyte

Joined: 12 Mar 2019
Posts: 56

hughson wrote:
Are there any errors in the client side AMQERR01.LOG?


Yes. This error was found in client side logs.

Code:
AMQ6174I: The dynamically loadable shared library '/opt/mqm/lib64/libmqdc_r.so'
was not found. The system returned error number '2' and error message 'No such
file or directory'.

EXPLANATION:
This message applies to UNIX systems. The shared library
'/opt/mqm/lib64/libmqdc_r.so' was not found.


The MQ version is 9.0.5.0, tried from a different server having MQ version 9.1.0.3, and it worked. Thanks for the help
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexGeneral IBM MQ Supportdmpmqcfg client connection not working
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.