ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportFile Input Node Archiving Failing

Post new topicReply to topic
File Input Node Archiving Failing View previous topic :: View next topic
Author Message
HIMAGAR
PostPosted: Wed Nov 13, 2019 10:47 pm Post subject: File Input Node Archiving Failing Reply with quote

Novice

Joined: 05 Nov 2015
Posts: 17

Hi,


I have a flow like this.

File Input Node ---> Compute ---> end of Flow.

ARCHIVING of File is set at File Input Node properties as

Action on Success Processing ==> Add Timestamp and move to archive.

But It shows an intermittent behavior, sometimes, it goes to the archive, while sometimes it won't.

I have enough space in the file system.

Please suggest.



Thanks,
HIMAGAR
want to be HIMAGAR
Back to top
View user's profile Send private message
abhi_thri
PostPosted: Thu Nov 14, 2019 2:01 am Post subject: Reply with quote

Partisan

Joined: 17 Jul 2017
Posts: 329
Location: UK

hi...archiving is one of the basic features of the FileInput node which should ideally work without any issues, what version of broker are you using?

Is the flow reporting any errors when the archiving failed? what you could do is, enable user trace for the flow and compare the success trace with the failure one and see whether there are any issues reported in it.
Back to top
View user's profile Send private message
Vitor
PostPosted: Thu Nov 14, 2019 6:01 am Post subject: Reply with quote

Grand High Poobah

Joined: 11 Nov 2005
Posts: 25856
Location: Texas, USA

abhi_thri wrote:
hi...archiving is one of the basic features of the FileInput node which should ideally work without any issues, what version of broker are you using?

Is the flow reporting any errors when the archiving failed? what you could do is, enable user trace for the flow and compare the success trace with the failure one and see whether there are any issues reported in it.




This is a function which has been included since forever and it's solid. The most likely thing to be hosing it up (which will show up in the logs my associate mentions) is an OS level problem.

Given the intermittent nature, I'd guess that something else has the file open (a virus scanner, a space management application, something of that nature) at the time broker tries to move it.
_________________
Honesty is the best policy.
Insanity is the best defence.
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportFile Input Node Archiving Failing
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.