ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportCant debug flow include Java_Compute with App Connect 11.0.0

Post new topicReply to topic
Cant debug flow include Java_Compute with App Connect 11.0.0 View previous topic :: View next topic
Author Message
hunghip95
PostPosted: Mon Aug 19, 2019 2:31 am Post subject: Cant debug flow include Java_Compute with App Connect 11.0.0 Reply with quote

Novice

Joined: 12 Oct 2017
Posts: 18

I'm creating a service with App Connect 11.0.0:
https://drive.google.com/file/d/1-UIzXSBBlDowkfCzqHsPgsRshkBv4hkM/view?usp=sharing

This is the subflow InquiryRateInfo:
https://drive.google.com/file/d/1K0vYxh3RPZN3kf8-x5EA-MbRa6Xz-888/view?usp=sharing

Subflow InquiryRateInfo include a Java_Compute node.
The service is running on a Linux Server good. But when I debug ( from Toolkit on Windows OS), message can run until subflow InquiryRateInfo, exception is throwed:

Code:
ExceptionList
   RecoverableException
         File:CHARACTER:/build/slot3/S000_P/src/DataFlowEngine/MessageServices/ImbDataFlowNode.cpp
         Line:INTEGER:1780
         Function:CHARACTER:ImbDataFlowNode::createExceptionList
         Type:CHARACTER:ComIbmSOAPInputNode
         Name:CHARACTER:ServiceImpl.AgriBankDemoService#FCMComposite_1_2
         Label:CHARACTER:ServiceImpl.AgriBankDemoService.SOAP Input
         Catalog:CHARACTER:BIPmsgs
         Severity:INTEGER:3
         Number:INTEGER:2230
         Text:CHARACTER:Node throwing exception
         Insert
               Type:INTEGER:14
               Text:CHARACTER:ServiceImpl.AgriBankDemoService.SOAP Input
         RecoverableException
               File:CHARACTER:/build/slot3/S000_P/src/DataFlowEngine/SQLNodeLibrary/ImbComputeNode.cpp
               Line:INTEGER:344
               Function:CHARACTER:ImbComputeNode::evaluate
               Type:CHARACTER:ComIbmComputeNode
               Name:CHARACTER:ServiceImpl.AgriBankDemoService#FCMComposite_1_6.Service.Common.Subflows.SOAHandleRequest#FCMComposite_1_5
               Label:CHARACTER:ServiceImpl.AgriBankDemoService.SOAHandleRequest.routeToOperationLabel
               Catalog:CHARACTER:BIPmsgs
               Severity:INTEGER:3
               Number:INTEGER:2230
               Text:CHARACTER:Caught exception and rethrowing
               Insert
                     Type:INTEGER:14
                     Text:CHARACTER:ServiceImpl.AgriBankDemoService.SOAHandleRequest.routeToOperationLabel
               RecoverableException
                     File:CHARACTER:/build/slot3/S000_P/src/DataFlowEngine/ImbRdl/ImbRdlStatementGroup.cpp
                     Line:INTEGER:792
                     Function:CHARACTER:SqlStatementGroup::execute
                     Type:CHARACTER:
                     Name:CHARACTER:
                     Label:CHARACTER:
                     Catalog:CHARACTER:BIPmsgs
                     Severity:INTEGER:3
                     Number:INTEGER:2488
                     Text:CHARACTER:Error detected, rethrowing
                     Insert
                           Type:INTEGER:5
                           Text:CHARACTER:Service.Common.ESQLs.routeToOperationLabel.Main
                     Insert
                           Type:INTEGER:5
                           Text:CHARACTER:14.4
                     Insert
                           Type:INTEGER:5
                           Text:CHARACTER:PROPAGATE TO LABEL TRIMBOTH(BOTH FROM OperationName) || '_' || TRIMBOTH(BOTH FROM ServiceVersion) FINALIZE NONE DELETE NONE;
                     ConfigurationException
                           File:CHARACTER:/build/slot3/S000_P/src/DataFlowEngine/MessageServices/ImbResource.cpp
                           Line:INTEGER:1040
                           Function:CHARACTER:ImbResource::getAttribute
                           Type:CHARACTER:ComIbmJavaComputeNode
                           Name:CHARACTER:ServiceImpl.AgriBankDemoService#FCMComposite_1_5.Version1.DemoOperation.Subflow.InquiryRateInfo#FCMComposite_1_15
                           Label:CHARACTER:ServiceImpl.AgriBankDemoService.InquiryRateInfo.InquiryRateInfo
                           Catalog:CHARACTER:BIPmsgs
                           Severity:INTEGER:3
                           Number:INTEGER:2210
                           Text:CHARACTER:Invalid attribute name
                           Insert
                                 Type:INTEGER:5
                                 Text:CHARACTER:javaClassName
                           Insert
                                 Type:INTEGER:14
                                 Text:CHARACTER:ServiceImpl.AgriBankDemoService.InquiryRateInfo.InquiryRateInfo


It seem like problem with debug feature. Because if I turn off debug, everything right, and no exception is throwed. Maybe cause flatform between Toolkit ( on Window) and service environment ( on Linux) different.
So what can I fix this problem?
Thanks all!


Last edited by hunghip95 on Mon Aug 19, 2019 6:43 pm; edited 3 times in total
Back to top
View user's profile Send private message
fjb_saper
PostPosted: Mon Aug 19, 2019 4:54 am Post subject: Reply with quote

Grand High Poobah

Joined: 18 Nov 2003
Posts: 20091
Location: LI,NY

Well you just showed the top of the exception tree where we would need to see the bottom of the exception tree. So at this point we are unable to give you any advice...

The Invalid Attribute Name lets me think that the class mentioned on the node does not match the class name implementing the code... In other words when you look at the subflow and the java compute node, does a double click on the node give you the correct code?
_________________
MQ & Broker admin
Back to top
View user's profile Send private message Send e-mail
hunghip95
PostPosted: Mon Aug 19, 2019 5:53 am Post subject: Reply with quote

Novice

Joined: 12 Oct 2017
Posts: 18

fjb_saper wrote:
Well you just showed the top of the exception tree where we would need to see the bottom of the exception tree. So at this point we are unable to give you any advice...

The Invalid Attribute Name lets me think that the class mentioned on the node does not match the class name implementing the code... In other words when you look at the subflow and the java compute node, does a double click on the node give you the correct code?

Sorry, but it is all the exception. I copy all of them. I have just add more information in post ( that is Service is running on Linux OS, and I debug by Toolkit on Windows OS).
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportCant debug flow include Java_Compute with App Connect 11.0.0
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.