ASG
IBM
Zystems
Cressida
Icon
Netflexity
 
  MQSeries.net
Search  Search       Tech Exchange      Education      Certifications      Library      Info Center      SupportPacs      LinkedIn  Search  Search                                                                   FAQ  FAQ   Usergroups  Usergroups
 
Register  ::  Log in Log in to check your private messages
 
RSS Feed - WebSphere MQ Support RSS Feed - Message Broker Support

MQSeries.net Forum IndexWebSphere Message Broker SupportIBM ACE 11.0.0.4 | User-Defined Node - LILPATH Issue

Post new topicReply to topic
IBM ACE 11.0.0.4 | User-Defined Node - LILPATH Issue View previous topic :: View next topic
Author Message
abcnil
PostPosted: Sat Jul 13, 2019 1:44 am Post subject: IBM ACE 11.0.0.4 | User-Defined Node - LILPATH Issue Reply with quote

Apprentice

Joined: 29 Mar 2012
Posts: 32

Facing an issue with IBM ACE 11.0.0.4 Version on Window 10.

So basically if we create a User Defined Nodes with Java implementation, somehow it is not working and gives typical BIP2241 error.

Code:
BIP2241E: A Loadable Implementation Library (.lil, .jar, or .par) is not found for message flow node type 'com_test_BasicNode'


Followed same steps on IIB9/10 and it does work perfectly on same Windows-10.

[ For ACE, just adapted lilpath setup on node.conf.yaml ]

Infocenter has exact same steps for IIB9/10 and ACE for creating, packaging and installing User Defined Nodes [Except for setting lilpath]

For Quick Test if node class is loaded, added following sysout in getNode:

Code:
public static String getNodeName()
   {
      System.out.println("I have been found!!!");
      return "BasicNode";
   }


and i do see its getting printed during Node start.


Do we have follow something extra for ACE 11?
Back to top
View user's profile Send private message
abcnil
PostPosted: Thu Jul 25, 2019 8:09 pm Post subject: PMR Raised Reply with quote

Apprentice

Joined: 29 Mar 2012
Posts: 32

FYI : PMR Raised and IBM L3 Team is working on the fix
Back to top
View user's profile Send private message
Display posts from previous:
Post new topicReply to topic Page 1 of 1

MQSeries.net Forum IndexWebSphere Message Broker SupportIBM ACE 11.0.0.4 | User-Defined Node - LILPATH Issue
Jump to:



You cannot post new topics in this forum
You cannot reply to topics in this forum
You cannot edit your posts in this forum
You cannot delete your posts in this forum
You cannot vote in polls in this forum
Protected by Anti-Spam ACP


Theme by Dustin Baccetti
Powered by phpBB 2001, 2002 phpBB Group

Copyright MQSeries.net. All rights reserved.